Bug 462630 - fence_scsi: clear key_list after each use
fence_scsi: clear key_list after each use
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: cman (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ryan O'Hara
Cluster QE
:
Depends On: 462628
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-17 12:59 EDT by Ryan O'Hara
Modified: 2009-10-12 15:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-12 15:05:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Ryan O'Hara 2008-09-17 17:12:43 EDT
Fixed in RHEL4.

Turns out the problem was not that we needed to clear the key_list hash, but that the get_key_list subroutine did not correcntly declare the key_list. Because Perl does dynamic scoping, the undeclared key_list variable was assumed to be global. The result is/was that the key_list hash was never getting updated correctly.

Simple, one line fix.

Note You need to log in before you can comment on or make changes to this bug.