Bug 462651 - Missing BuildRequires leads to missing component (lablgtksourceview.cma) in binary package
Missing BuildRequires leads to missing component (lablgtksourceview.cma) in b...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ocaml-lablgtk (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alan Dunn
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-17 16:02 EDT by Alan Dunn
Modified: 2008-10-24 19:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 19:53:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backport of F-10 changes to F-9 - fix missing BuildRequires (1.46 KB, patch)
2008-10-22 10:48 EDT, Alan Dunn
no flags Details | Diff

  None (edit)
Description Alan Dunn 2008-09-17 16:02:58 EDT
Description of problem:

It seems that a component that typically is created during a lablgtk version 2.10.0 install, lablgtksourceview.cma, is not in the binary package in the repositories. If I rebuild the package myself (with rpmbuild --rebuild), the component appears. I believe this is due to a missing

BuildRequires: gtksourceview-devel

the lack of which causes lablgtk to not detect gtksourceview and thus not create this component.
Comment 1 Richard W.M. Jones 2008-09-18 08:00:43 EDT
I fixed this in Rawhide which is the only thing I use for OCaml
development at the moment.

http://koji.fedoraproject.org/koji/taskinfo?taskID=831768

rpm2cpio ocaml-lablgtk-2.10.1-4.fc10.x86_64.rpm |
  cpio -t |
  grep lablgtksourceview.cma
./usr/lib64/ocaml/lablgtk2/lablgtksourceview.cma

If you want to get the updated package, enable the Fedora development
repository in F9.  If you really really want it in F9, reopen the bug...
Comment 2 Alan Dunn 2008-09-18 08:51:38 EDT
I would actually like it in F9 if possible - other packages I want to add (and also add into F9) require this component.
Comment 3 Alan Dunn 2008-10-22 10:48:13 EDT
Created attachment 321163 [details]
Backport of F-10 changes to F-9 - fix missing BuildRequires
Comment 4 Alan Dunn 2008-10-22 10:49:13 EDT
(In reply to comment #1)
> I fixed this in Rawhide which is the only thing I use for OCaml
> development at the moment.
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=831768
> 
> rpm2cpio ocaml-lablgtk-2.10.1-4.fc10.x86_64.rpm |
>   cpio -t |
>   grep lablgtksourceview.cma
> ./usr/lib64/ocaml/lablgtk2/lablgtksourceview.cma
> 
> If you want to get the updated package, enable the Fedora development
> repository in F9.  If you really really want it in F9, reopen the bug...

Looks like the changes didn't happen in F-9, but I made a patch for it, or if I have the appropriate access I can do it myself.
Comment 5 Richard W.M. Jones 2008-10-22 11:52:52 EDT
Alan, I don't have much time to handle bug reports like this.  The
easiest thing is if you get a FAS account and I'll sponsor you to
make changes yourself to OCaml packages.

http://fedoraproject.org/wiki/Infrastructure/AccountSystem
Comment 6 Alan Dunn 2008-10-22 12:31:33 EDT
(In reply to comment #5)
> Alan, I don't have much time to handle bug reports like this.  The
> easiest thing is if you get a FAS account and I'll sponsor you to
> make changes yourself to OCaml packages.
> 
> http://fedoraproject.org/wiki/Infrastructure/AccountSystem

I have an account, I meant more on the order of two things - that I had heard there were changes coming to the commit system that would necessitate actually acquiring permissions to do a commit on someone else's package and that I didn't want to just commit a fix to someone else's package without knowing if anything had changed. Since it sounds like you don't mind, I'll just make the fix myself, I apologize for taking your time.
Comment 7 Richard W.M. Jones 2008-10-22 13:41:06 EDT
Basically, all my packages should have "cvsextras commit" access
which (AIUI) means anyone who is sponsored should be able to
make changes.  So go ahead and do it.

If you find a permissions problem let me know & I'll fix it.
Comment 8 Alan Dunn 2008-10-22 15:45:40 EDT
(In reply to comment #7)
> Basically, all my packages should have "cvsextras commit" access
> which (AIUI) means anyone who is sponsored should be able to
> make changes.  So go ahead and do it.
> 
> If you find a permissions problem let me know & I'll fix it.

It doesn't want to let me commit:

cvs commit...
**** Access denied: amdunn is not in ACL for rpms/ocaml-lablgtk/F-9
cvs commit: Pre-commit check failed
cvs [commit aborted]: correct above errors first!

and what I was thinking of I believe was this:

https://www.redhat.com/archives/fedora-announce-list/2008-August/msg00007.html

in that cvsextras -> packager and there's the new uberpackager group, of which I am not a part.
Comment 9 Fedora Update System 2008-10-24 06:57:38 EDT
ocaml-lablgtk-2.10.1-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/ocaml-lablgtk-2.10.1-1.fc9
Comment 10 Fedora Update System 2008-10-24 19:52:59 EDT
ocaml-lablgtk-2.10.1-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.