Bug 462653 - qpid-bench (and/or qpid-java client?) deadlocks on exceptions
qpid-bench (and/or qpid-java client?) deadlocks on exceptions
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-java (Show other bugs)
1.0
All Linux
medium Severity medium
: 1.3
: ---
Assigned To: Rafael H. Schloming
Kim van der Riet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-17 16:15 EDT by David Sommerseth
Modified: 2016-05-22 19:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-10 09:09:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Sommerseth 2008-09-17 16:15:41 EDT
During running tests with qpid-bench, I experienced that qpid-bench deadlocked.  I was using the MRG/M-1.0.1 packages, and latest qpid-bench from SVN trunk/qpid/java (r694671)

I ran this test against a broker being run via valgrind:

        qpid-bench -c 100000 -w 0 -s 4096 --sample 10000 

And after a little while I received this exception:

---------------------------------------------------------------------------------
Exception in thread "Thread-2" java.lang.RuntimeException: org.apache.qpid.transport.SessionException: [ch=0 id=0 ExecutionException(errorCode=RESOURCE_LIMIT_EXCEEDED, commandId=28535, classCode=0, commandCode=0, fieldIndex=0, description=resource-limit-exceeded: Policy exceeded for test-queue size: max=104857600, current=104861696; count unlimited, current=0 (qpid/broker/Queue.cpp:418), errorInfo={})]
        at org.apache.qpid.tools.QpidBench$2.run(QpidBench.java:460)
Caused by: org.apache.qpid.transport.SessionException: [ch=0 id=0 ExecutionException(errorCode=RESOURCE_LIMIT_EXCEEDED, commandId=28535, classCode=0, commandCode=0, fieldIndex=0, description=resource-limit-exceeded: Policy exceeded for test-queue size: max=104857600, current=104861696; count unlimited, current=0 (qpid/broker/Queue.cpp:418), errorInfo={})]
        at org.apache.qpid.transport.Session.invoke(Session.java:276)
        at org.apache.qpid.transport.Invoker.messageTransfer(Invoker.java:127)
        at org.apache.qpid.tools.QpidBench.native_publisher(QpidBench.java:789)
        at org.apache.qpid.tools.QpidBench.access$500(QpidBench.java:45)
        at org.apache.qpid.tools.QpidBench$2.run(QpidBench.java:455)
---------------------------------------------------------------------------------

The program never seems to stop, and running strace on the qpid-bench process showed no activity ... waiting for a futex(0x...., FUTEX_WAIT, 23, NULL

Broker (C++) behaves as expected, and other clients can connect and run as normal.
Comment 1 Rafael H. Schloming 2008-10-27 16:52:07 EDT
This should be fixed on 1.1

Note You need to log in before you can comment on or make changes to this bug.