Bug 462674 - The installer can't start in graphical mode on PS3
The installer can't start in graphical mode on PS3
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-09-18 02:46 EDT by Kazunori Asayama
Modified: 2009-09-08 12:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-08 12:16:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kazunori Asayama 2008-09-18 02:46:02 EDT
Description of problem:

The installer can't start in graphical mode on PS3, maybe because of memory shortage. The text mode can start.

Version-Release number of selected component (if applicable):

  anaconda-11.4.1.36-1.ppc
  boot.iso 2008.09.16 (UTC)

How reproducible:

  Every time.

Steps to Reproduce:
1. Insert the installer DVD into PS3.
2. Boot PS3.
3. Start installer in graphical mode.
4. Select 'Skip' in the 'Disc Found' page in the 1st stage.

Actual results:

  The installer stalls after the 'Disc Found' page.

Expected results:

  There's any progress in the installation process.

Additional info:

  I waited 1 hour+, but no progress.

  I selected 'OK' in the 'Disc Found' page so check the disc. But no error was detected.
Comment 1 Chris Lumens 2008-09-22 11:08:42 EDT
Are there any messages on tty3, tty4, or tty5 that could indicate a problem?
Comment 2 Kazunori Asayama 2008-09-22 12:03:51 EDT
I couldn't switch to the tty3 etc. I got a black screen after the 'Disc Found' page and the PS3 didn't respond to any input from keyboard or mouse. However it looks like the installer continued to access the DVD-ROM, because I could hear seek noise from the optical drive.
Comment 3 Kazunori Asayama 2008-09-22 14:35:35 EDT
The graphical installer can start if I use a special hardware with 512MB memory. A retail PS3 console has 256MB memory, and only about 210MB is available for Linux. So I guessed the cause of this problem was memory shortage, but I'm not sure about that.
Comment 4 Kazunori Asayama 2008-09-22 15:16:04 EDT
I tried similar situation on x86 PC by passing kernel option "mem=220M" to the installer, then the installer complained:

  You do not have enough RAM to use graphical installer. Starting text mode.

and entered text mode. So the PowerPC installer should also behave the same?
Comment 5 Chris Lumens 2008-09-22 16:04:50 EDT
When you say "available for Linux", what do you mean?
Comment 6 Kazunori Asayama 2008-09-22 16:17:25 EDT
(In reply to comment #5)
> When you say "available for Linux", what do you mean?

Part of the memory is used by the hypervisor.
Comment 7 Bug Zapper 2008-11-25 22:07:43 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Chris Lumens 2009-07-10 13:31:56 EDT
This should be fixed in notting's latest patch to anaconda.
Comment 9 Joel Andres Granados 2009-09-08 12:16:14 EDT
I'm assuming this fixed since its so old.  Feel free to reopen if you continue to see the bad behavior.

Note You need to log in before you can comment on or make changes to this bug.