Bug 462687 - Selecting toplevel tasks still shows all tasks
Selecting toplevel tasks still shows all tasks
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: koji (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/ta...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-18 06:12 EDT by Jan Pazdziora
Modified: 2013-01-09 20:52 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-18 12:06:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2008-09-18 06:12:47 EDT
Description of problem:

When I click on Tasks -> State: toplevel, I expect to see just the toplevel tasks (newRepo, build) but not the child tasks (createrepo, buildArch). This is not the case. with koji on koji.fedoraproject.org.

Version-Release number of selected component (if applicable):

Koji installed on koji.fedoraproject.org as of today (there does not seem to be any "About" info there).

How reproducible:

Deterministic.

Steps to Reproduce:
1. Go to http://koji.fedoraproject.org/koji/tasks?state=toplevel&method=all&order=-completion_time
  
Actual results:

Title says "Top-level Tasks" yet there are

831655  	  newRepo (dist-f10-kernel)

    * createrepo (i386)
    * createrepo (x86_64)
    * createrepo (ppc)
    * createrepo (ppc64)

	kojira 	noarch 		open
831656 	 newRepo (dist-f10-build)

    * createrepo (i386)
    * createrepo (x86_64)
    * createrepo (ppc)
    * createrepo (ppc64)

	kojira 	noarch 		open
831664 	 buildNotification (libwfut-0.2.0-3.fc8.2) 	ppc3.fedora.redhat.com 	noarch 	2008-09-18 10:05:55 	closed
831646 	 build (dist-f8-updates-candidate, /cvs/pkgs:rpms/libwfut/F-8:libwfut-0_2_0-3_fc8_2)

    * buildSRPMFromSCM (/cvs/pkgs:rpms/libwfut/F-8:libwfut-0_2_0-3_fc8_2)
    * buildArch (libwfut-0.2.0-3.fc8.2.src.rpm, ppc)
    * buildArch (libwfut-0.2.0-3.fc8.2.src.rpm, x86_64)
    * buildArch (libwfut-0.2.0-3.fc8.2.src.rpm, i386)
    * buildArch (libwfut-0.2.0-3.fc8.2.src.rpm, ppc64)
    * tagBuild (noarch)

there.

Expected results:

Only toplevel tasks shown.

Additional info:
Comment 1 Mike McLean 2008-09-18 11:05:50 EDT
I see your point, though the current 'toplevel' view, while perhaps mis-named, is useful and should not go away entirely.

At the risk of cluttering up the form, it would be nice to split the current 'State' selector in two:
  - active vs all (or a specific state)  ["State"]
  - toplevel-only vs threaded vs flat  ["View"]
Comment 2 Jan Pazdziora 2008-09-18 11:12:54 EDT
Yes, that might be nice as well.

I've noticed this primarily because this is where koji differs from brew (and I only use the toplevel view in brew).
Comment 3 Mike McLean 2008-09-18 12:04:02 EDT
Filed upstream: https://fedorahosted.org/koji/ticket/109

Note You need to log in before you can comment on or make changes to this bug.