Bug 4627 - wait does not wake
wait does not wake
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
6.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Cristian Gafton
:
: 8908 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-20 10:48 EDT by scottc
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-20 08:23:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description scottc 1999-08-20 10:48:18 EDT
The system call wait does not get interupted from a sig
alarm, sigusr1. It only ever seems to return when a child
process dies, or a sig kill/int is received. The man page
details that the wait call should return when the process
receives a signal that is being caught is sent, as well as
the sig kill/int signals.
The code was ported from HP-UX and it works correctly there,
along with Solaris.
If you require i have some sample code that proves the
problem. Is this a known bug, and if so is there a patch ??
Comment 1 Jeff Johnson 1999-08-21 10:45:59 EDT
Could you supply a program that exhibits this problem? Thanks.
Comment 2 Cristian Gafton 1999-08-29 22:06:59 EDT
changed priorities to low/low until a test case is supplied.
Comment 3 Cristian Gafton 1999-09-20 08:23:59 EDT
test case supplied. the test was using signal() to set the signal
handlers, but by default those signals will have the SA_RESTART flag
associated, so the system calls were automatically restarted. One
should use sigaction for this type of very fine control (and it also
clears things up when it comes to race conditions)
Comment 4 Cristian Gafton 2000-01-27 03:03:59 EST
*** Bug 8908 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.