Bug 462716 - Firstboot uses a very old icon
Firstboot uses a very old icon
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fedora-logos (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
http://fedoraproject.org/wiki/Image:T...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-18 10:40 EDT by Denny Crane
Modified: 2008-10-16 16:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-16 16:46:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Echo icon theme "Computer" icon (36.63 KB, image/svg+xml)
2008-09-18 14:44 EDT, Denny Crane
no flags Details
Fedora/Mist/Gnome icon theme "Computer" icon (as used in F7-F9) (77.23 KB, image/svg+xml)
2008-09-18 14:50 EDT, Denny Crane
no flags Details
The icon I am going to use unless I hear otherwise. (4.26 KB, image/png)
2008-09-18 15:42 EDT, Tom "spot" Callaway
no flags Details

  None (edit)
Description Denny Crane 2008-09-18 10:40:22 EDT
Description of problem:
Firstboot uses a very old icon, has not kept up with the icons released with F7-F9. The icon is antiquated and looks out of place with all the new graphics which are included in the installer.

See top leftish of this image:
http://fedoraproject.org/wiki/Image:Tours_Fedora9_013_Setup_Welcome.png

Version-Release number of selected component (if applicable):
F7-F9

How reproducible:
100%

Steps to Reproduce:
1. Install Fedora
2. See icon
  
Actual results:
See old icon.

Expected results:
See modern icon which doesn't stick out like a sore thumb among new graphics.

Additional info:
Comment 1 Chris Lumens 2008-09-18 10:58:19 EDT
This image is provided by the fedora-logos package now.  Reassigning.
Comment 2 Nicu Buculei 2008-09-18 11:23:06 EDT
As that is not a logo but the "computer" icon, I think firstboot should use the "Computer" icon from the *default* icon theme (not the ancient Bluecurve).

If, on the other hand, the goal is to have a logo displayed there, please request a proper logo from the Art team (but in my personal opinion, another logo would be overkill, we have enough branding in that screen).
Comment 3 Tom "spot" Callaway 2008-09-18 11:30:05 EDT
Nicu, please let me know what icon should be there (attach it to this bugzilla) and I'll fix it in the fedora-logos package.
Comment 4 Denny Crane 2008-09-18 14:44:02 EDT
Created attachment 317106 [details]
Echo icon theme "Computer" icon

Retrieved from https://fedorahosted.org/echo-icon-theme/wiki/IconThemeStatus/Devices (18/09/08)
Comment 5 Denny Crane 2008-09-18 14:50:38 EDT
Created attachment 317108 [details]
Fedora/Mist/Gnome icon theme "Computer" icon (as used in F7-F9)

Retrieved from /usr/share/icons/gnome/scalable/computer.svg in F9 (18/09/08)
Comment 6 Tom "spot" Callaway 2008-09-18 15:41:26 EDT
Well, I'm only going to fix this in rawhide for F10, it doesn't make any sense to do this in earlier builds... thus, I'll use the Echo icon.

I flipped the SVG so that the computer faces to the right, that's how the old icon faced, and I think the firstboot context, it looks better that way. I'll attach the png I generated and if either of you are unhappy, now is the time to say so. :)
Comment 7 Tom "spot" Callaway 2008-09-18 15:42:27 EDT
Created attachment 317112 [details]
The icon I am going to use unless I hear otherwise.
Comment 8 Denny Crane 2008-09-18 15:49:05 EDT
Just to clarify, I only attached the "old" (F7-F9) version because the echo icon set is, I believe, only *tentatively* scheduled for F10. I think it was originally scheduled for F9, and maybe even F8?
Comment 9 Nicu Buculei 2008-09-19 02:07:35 EDT
@Nate: no, only for F10 we feel we have a real chance to get it "good enough" and proposed it formally as a feature. Before that it was just included like any other non-default theme.
Comment 10 Denny Crane 2008-09-19 08:20:50 EDT
Okay, cool :-)
Comment 11 Tom "spot" Callaway 2008-09-23 17:40:38 EDT
The firstboot/workstation.png icon in fedora-logos-9.99.4-1.fc10 (now built in rawhide) is the Echo icon, reversed, as I attached here.

It is worth noting that firstboot-1.100-1.fc10 still has a local copy of this icon, so I'm reassigning this bug to firstboot so they can either fix this in their local copy or really use fedora-logos.
Comment 12 Chris Lumens 2008-09-23 18:46:18 EDT
The copy in firstboot is a fallback, should /usr/share/firstboot/themes/fedora-waves/workstation.png not exist.  fedora-waves is provided by fedora-logos, and that's what firstboot uses by default.  The local copy of workstation.png provided by firstboot is that cheesy COM-PU-TER logo I made just to have something as a fallback.  So, kicking this back to fedora-logos.  firstboot will use whatever it provides.

Note You need to log in before you can comment on or make changes to this bug.