Bug 462728 - Need gfs2-kmod rebuilt with 5.3 code.
Need gfs2-kmod rebuilt with 5.3 code.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Chris Feist
Cluster QE
: Reopened
Depends On:
Blocks: RHEL5u3_relnotes
  Show dependency treegraph
 
Reported: 2008-09-18 12:03 EDT by Chris Feist
Modified: 2009-05-27 23:31 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
(all architectures) GFS2 is an incremental advancement of GFS. This update applies several significant improvements that require a change to the on-disk file system format. GFS file systems can be converted to GFS2 using the utility gfs2_convert, which updates the metadata of a GFS file system accordingly. In Red Hat Enterprise Linux 5.2, GFS2 was provided as a kernel module for evaluation purposes. Consquently, upgrading from older versions of Red Hat Enterprise Linux would fail due to module conflicts. In Red Hat Enterprise Linux 5.3, GFS2 is now part of the kernel package. If the Red Hat Enterprise Linux 5.2 GFS2 kernel modules have been installed they must be removed to use GFS2 in Red Hat Enterprise Linux 5.3.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 07:30:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Feist 2008-09-18 12:03:50 EDT
Need gfs2-kmod rebuilt with 5.3 code.
Comment 8 Steve Whitehouse 2008-12-09 10:22:51 EST
The release note is in bz #248129 so we need to update that one I think, rather than adding a new note.
Comment 9 Chris Feist 2008-12-09 10:33:54 EST
Users are advised that in order to continue using gfs2 (which is no longer a
Technology Preview in Red Hat Enterprise Linux 5.3), manual removal of the
gfs2-kmod package must be performed, for example:

   rpm -e kmod-gfs2
   rpm -e kmod-gfs2-PAE
   rpm -e kmod-gfs2-xen
Comment 11 Chris Feist 2008-12-16 19:33:43 EST
I've grabbed the release note from bz 248129 which doesn't appear to have the proper flags to make it into 5.3.
Comment 12 Chris Feist 2008-12-16 19:33:43 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
(all architectures)
GFS2 is an incremental advancement of GFS. This update applies several significant improvements that require a change to the on-disk file system format. GFS file systems can be converted to GFS2 using the utility gfs2_convert, which updates the metadata of a GFS file system accordingly.

In Red Hat Enterprise Linux 5.2, GFS2 was provided as a kernel module for evaluation purposes. Consquently, upgrading from older versions of Red Hat Enterprise Linux would fail due to module conflicts. In Red Hat Enterprise Linux 5.3, GFS2 is now part of the kernel package. If the Red Hat Enterprise Linux 5.2 GFS2 kernel modules have been installed they must be removed to use GFS2 in Red Hat Enterprise Linux 5.3.

Note You need to log in before you can comment on or make changes to this bug.