Bug 462809 - xml-commons-apis-javadoc conflicts with older xml-commons-apis
xml-commons-apis-javadoc conflicts with older xml-commons-apis
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xml-commons-apis (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wringe
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-09-18 22:14 EDT by Sean Flanigan
Modified: 2008-09-19 16:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-19 16:02:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Flanigan 2008-09-18 22:14:24 EDT
Description of problem:

Installing xml-commons-apis-javadoc from rawhide leads to yum conflict if older xml-commons-apis is already installed.

Version-Release number of selected component (if applicable):
xml-commons-apis-javadoc-1.3.04-1.2.fc10.i386


How reproducible:

Probably depends on whether you have a different version of xml-commons-apis installed before trying to install xml-commons-apis-javadoc.

Steps to Reproduce:

1. Start with a Fedora 9 development machine which has previously installed rawhide Eclipse (ie a messy F9/rawhide hybrid)
2. yum --enablerepo=rawhide install eclipse-*

But I think you could reproduce this simply with:
1. Install Fedora 9
2. yum install xml-commons-apis
3. yum --enablerepo=rawhide install xml-commons-apis-javadoc

(Or by installing xml-commons-apis, waiting for a revision bump, then installing xml-commons-apis-javadoc.)

Actual results:

Transaction Check Error:
  file /usr/lib/gcj/xml-commons-apis/xml-commons-apis-1.3.04.jar.so from install of xml-commons-apis-javadoc-1.3.04-1.2.fc10.i386 conflicts with file from package xml-commons-apis-1.3.04-1jpp.1.fc9.i386


Expected results:

Yum should install the packages without conflict, upgrading other packages if necessary.


Additional info:

I had an older version of the .jar.so from xml-commons-apis, so it conflicted with the updated .jar.so in the javadoc package.  

I don't think the documentation package xml-commons-apis-javadoc should be containing a jar.so file.  Removing it should eliminate the conflict.


Workaround:

1. Force the xml-commons-apis* packages to be synchronised
  yum --enablerepo=rawhide install xml-commons-apis xml-commons-apis-javadoc
2. Install dependent packages
  yum --enablerepo=rawhide install eclipse-*
Comment 1 John Poelstra 2008-09-19 13:58:13 EDT
adding to blocker because of unresolved dependencies
Comment 2 Matt Wringe 2008-09-19 15:02:29 EDT
The xml-commons-apis package does not own anything outside of /usr/share/javadoc.

The error message you are seeing is very misleading and basically means that when trying to install xml-commons-apis-javadoc one of its dependencies (or the dependencies of a dependency) has a file conflict with the jar.so file. 

Can you please output the result of the command below. I really need to know what package or packages are providing this.

rpm -q --whatprovides xml-commons-apis
Comment 3 Matt Wringe 2008-09-19 15:04:34 EDT
The xml-commons-apis package does not own anything outside of
/usr/share/javadoc.

Oops,
That should have been "The xml-commons-apis-javadoc package...
Comment 4 Matt Wringe 2008-09-19 15:10:39 EDT
And Oops again, yes the javadoc is providing the jar.so
Fixing this right now

Note You need to log in before you can comment on or make changes to this bug.