Bug 462832 - cpan2rpm doesn't work with latest Pod::Text
cpan2rpm doesn't work with latest Pod::Text
Status: CLOSED DUPLICATE of bug 481147
Product: Fedora
Classification: Fedora
Component: cpan2rpm (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: Gavin Henry
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks: 498746
  Show dependency treegraph
 
Reported: 2008-09-19 04:37 EDT by Benny Amorsen
Modified: 2009-05-12 08:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-12 08:45:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Switch to Pod::Parser instead of Pod::Text (550 bytes, patch)
2008-09-19 04:37 EDT, Benny Amorsen
no flags Details | Diff

  None (edit)
Description Benny Amorsen 2008-09-19 04:37:21 EDT
Created attachment 317167 [details]
Switch to Pod::Parser instead of Pod::Text

+++ This bug was initially created as a clone of Bug #279251 +++

I am cloning this bug because it now affects Fedora 9 without adding any third party packages. The original bug expired because Fedora 7 End-of-Life.

Description of problem:

Pod::Text no longer derives from Pod::Parser so the method 'interpolate' does
not exist.  As near as I can tell, this is the only method used in cpan2rpm, so
Pod::Text can be changed to Pod::Parser in the two places it appears.  This is
what I did locally and it now works for me.

Version-Release number of selected component (if applicable):

cpan2rpm-2.028-2.fc8.1.noarch
perl-5.10.0-33.fc9.i386

How reproducible:

Run cpan2rpm for some module (any will do...)
  
Actual results:

[...]
-- module: /var/cache/cpan/build/libwww-perl-5.808-baHtIL --
Metadata retrieval
Can't locate object method "interpolate" via package "Pod::Text" at
/usr/bin/cpan2rpm line 522.
-- Done --


Expected results:

No failure from above.

Additional info:
I have added a patch. It works for me...
Comment 1 John Poelstra 2008-09-19 11:38:35 EDT
changed version to "9"
Comment 2 Marcela Mašláňová 2008-09-22 03:35:38 EDT
The last release of cpan2rpm was in 2005. I suggest using cpanspec.
Comment 3 Benny Amorsen 2008-09-22 10:58:05 EDT
Ok, can we either get rid of the package or fix it though?
Comment 4 Marcela Mašláňová 2008-09-23 04:17:10 EDT
It can be build and possibly some people still use it.

Thougths from perl-sig?
Comment 5 Stepan Kasal 2009-05-12 08:45:56 EDT

*** This bug has been marked as a duplicate of bug 481147 ***

Note You need to log in before you can comment on or make changes to this bug.