Bug 462848 - kernel oops on eeePC 901
kernel oops on eeePC 901
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FedoraMini/Mobility
  Show dependency treegraph
 
Reported: 2008-09-19 07:27 EDT by Peter Robinson
Modified: 2008-10-25 03:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-25 03:36:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2008-09-19 07:27:32 EDT
The kernel in current rawhide is oops during startup on the eee PC 901 (Intel Atom based netbook). Kernel is 2.6.27-0.329.rc6.git2.fc10.i686 from yesterday (last couple of days?) rawhide install.

Two different oops from boots below but it seems to happen everytime.

First oops:

RPC: Registered udp transport module.
RPC: Registered tcp transport module.
SELinux: initialized (dev rpc_pipefs, type rpc_pipefs), uses genfs_contexts

=================================
[ INFO: inconsistent lock state ]
2.6.27-0.329.rc6.git2.fc10.i686 #1
---------------------------------
inconsistent {hardirq-on-W} -> {in-hardirq-W} usage.
NetworkManager/2369 [HC1[1]:SC0[1]:HE0:SE0] takes:
 (&adapter->mdio_lock){+-..}, at: [<f89d854e>] atl1e_intr+0x22d/0x3f7 [atl1e]
{hardirq-on-W} state was registered at:
  [<c044c97e>] __lock_acquire+0x2ad/0xae6
  [<c044d212>] lock_acquire+0x5b/0x81
  [<c0695b80>] _spin_lock+0x23/0x50
  [<f89dbfdc>] atl1e_probe+0x50b/0x6bc [atl1e]
  [<c052639a>] pci_device_probe+0x3e/0x5e
  [<c059067e>] driver_probe_device+0xa5/0x141
  [<c059075c>] __driver_attach+0x42/0x64
  [<c0590031>] bus_for_each_dev+0x43/0x6d
  [<c0590506>] driver_attach+0x19/0x1b
  [<c058fa46>] bus_add_driver+0xa8/0x1c8
  [<c0590911>] driver_register+0x89/0xe9
  [<c052658c>] __pci_register_driver+0x58/0x84
  [<f881601c>] 0xf881601c
  [<c0401139>] do_one_initcall+0x42/0x133
  [<c0454f72>] sys_init_module+0x8e/0x183
  [<c0404d02>] syscall_call+0x7/0xb
  [<ffffffff>] 0xffffffff
irq event stamp: 9483
hardirqs last  enabled at (9481): [<c044c0c4>] trace_hardirqs_on+0xb/0xd
hardirqs last disabled at (9483): [<c051a9c4>] trace_hardirqs_off_thunk+0xc/0x10
softirqs last  enabled at (9404): [<c0432725>] __do_softirq+0x104/0x10f
softirqs last disabled at (9482): [<c0695bbe>] _spin_lock_bh+0x11/0x55

other info that might help us debug this:
1 lock held by NetworkManager/2369:
 #0:  (rtnl_mutex){--..}, at: [<c062a821>] rtnetlink_rcv+0x17/0x2b

stack backtrace:
Pid: 2369, comm: NetworkManager Not tainted 2.6.27-0.329.rc6.git2.fc10.i686 #1
 [<c0693747>] ? printk+0x14/0x1d
 [<c044b85e>] valid_state+0x12a/0x13d
 [<c044bc5b>] mark_lock+0xde/0x331
 [<c044c901>] __lock_acquire+0x230/0xae6
 [<c044b2f6>] ? trace_hardirqs_off_caller+0x15/0x91
 [<c044b37d>] ? trace_hardirqs_off+0xb/0xd
 [<c040979a>] ? native_sched_clock+0xb3/0xd3
 [<c044bb9b>] ? mark_lock+0x1e/0x331
 [<c044d212>] lock_acquire+0x5b/0x81
 [<f89d854e>] ? atl1e_intr+0x22d/0x3f7 [atl1e]
 [<c0695b80>] _spin_lock+0x23/0x50
 [<f89d854e>] ? atl1e_intr+0x22d/0x3f7 [atl1e]
 [<f89d854e>] atl1e_intr+0x22d/0x3f7 [atl1e]
 [<c044a914>] ? lock_release_holdtime+0x30/0x125
 [<c046d052>] handle_IRQ_event+0x1f/0x54
 [<c046e150>] handle_fasteoi_irq+0x82/0xbb
 [<c046e0ce>] ? handle_fasteoi_irq+0x0/0xbb
 [<c0406fa5>] do_IRQ+0x9f/0xc9
 [<c0695bbe>] ? _spin_lock_bh+0x11/0x55
 [<c04056f8>] common_interrupt+0x28/0x30
 [<c0695bbe>] ? _spin_lock_bh+0x11/0x55
 [<c0695bbe>] ? _spin_lock_bh+0x11/0x55
 [<f89d007b>] ? snd_pcm_oss_read2+0xb3/0xc4 [snd_pcm_oss]
 [<c0432480>] ? __local_bh_disable+0x7c/0x88
 [<c043249c>] local_bh_disable+0x10/0x12
 [<c0695bbe>] _spin_lock_bh+0x11/0x55
 [<c06217ba>] dev_set_rx_mode+0x19/0x2b
 [<c0623386>] dev_open+0x96/0xb9
 [<c0622da6>] dev_change_flags+0xa1/0x154
 [<c0629b47>] ? rtnl_setlink+0x0/0xdb
 [<c0629a95>] do_setlink+0x26d/0x31f
 [<c069596c>] ? _read_unlock+0x22/0x25
 [<c0629b47>] ? rtnl_setlink+0x0/0xdb
 [<c0629c1e>] rtnl_setlink+0xd7/0xdb
 [<c062a9d2>] rtnetlink_rcv_msg+0x19d/0x1b7
 [<c062a835>] ? rtnetlink_rcv_msg+0x0/0x1b7
 [<c06385d3>] netlink_rcv_skb+0x35/0x7a
 [<c062a82d>] rtnetlink_rcv+0x23/0x2b
 [<c06381cd>] netlink_unicast+0xf6/0x14c
 [<c063845a>] netlink_sendmsg+0x237/0x244
 [<c0616d1f>] __sock_sendmsg+0x4a/0x53
 [<c061755a>] sock_sendmsg+0xbd/0xd3
 [<c043f8c6>] ? autoremove_wake_function+0x0/0x38
 [<c043f8c6>] ? autoremove_wake_function+0x0/0x38
 [<c041f26a>] ? need_resched+0x18/0x22
 [<c051ae7b>] ? copy_from_user+0x3e/0x125
 [<c061de7e>] ? verify_iovec+0x45/0x73
 [<c06176b4>] sys_sendmsg+0x144/0x197
 [<c06181b1>] ? sys_recvmsg+0x11b/0x180
 [<c0617ee5>] ? sys_sendto+0xa9/0xc8
 [<c0498adc>] ? check_valid_pointer+0x24/0x53
 [<c0499149>] ? check_object+0x131/0x165
 [<c044c098>] ? trace_hardirqs_on_caller+0xf9/0x11a
 [<c04acabd>] ? d_free+0x40/0x52
 [<c04acabd>] ? d_free+0x40/0x52
 [<c0618819>] sys_socketcall+0x16d/0x1a4
 [<c040b3cf>] ? syscall_trace_enter+0xba/0xce
 [<c0404d02>] syscall_call+0x7/0xb
 =======================
ADDRCONF(NETDEV_UP): eth0: link is not ready
[drm] Initialized drm 1.1.0 20060810
pci 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
pci 0000:00:02.0: setting latency timer to 64

Second oops:

RPC: Registered udp transport module.
RPC: Registered tcp transport module.
SELinux: initialized (dev rpc_pipefs, type rpc_pipefs), uses genfs_contexts

=================================
[ INFO: inconsistent lock state ]
2.6.27-0.329.rc6.git2.fc10.i686 #1
---------------------------------
inconsistent {hardirq-on-W} -> {in-hardirq-W} usage.
S90crond/2396 [HC1[1]:SC0[0]:HE0:SE1] takes:
 (&adapter->mdio_lock){+-..}, at: [<f89eb54e>] atl1e_intr+0x22d/0x3f7 [atl1e]
{hardirq-on-W} state was registered at:
  [<c044c97e>] __lock_acquire+0x2ad/0xae6
  [<c044d212>] lock_acquire+0x5b/0x81
  [<c0695b80>] _spin_lock+0x23/0x50
  [<f89eefdc>] atl1e_probe+0x50b/0x6bc [atl1e]
  [<c052639a>] pci_device_probe+0x3e/0x5e
  [<c059067e>] driver_probe_device+0xa5/0x141
  [<c059075c>] __driver_attach+0x42/0x64
  [<c0590031>] bus_for_each_dev+0x43/0x6d
  [<c0590506>] driver_attach+0x19/0x1b
  [<c058fa46>] bus_add_driver+0xa8/0x1c8
  [<c0590911>] driver_register+0x89/0xe9
  [<c052658c>] __pci_register_driver+0x58/0x84
  [<f881601c>] 0xf881601c
  [<c0401139>] do_one_initcall+0x42/0x133
  [<c0454f72>] sys_init_module+0x8e/0x183
  [<c0404d02>] syscall_call+0x7/0xb
  [<ffffffff>] 0xffffffff
irq event stamp: 4028
hardirqs last  enabled at (4027): [<c051a9b4>] trace_hardirqs_on_thunk+0xc/0x10
hardirqs last disabled at (4028): [<c051a9c4>] trace_hardirqs_off_thunk+0xc/0x10
ADDRCONF(NETDEV_UP): eth0: link is not ready
softirqs last  enabled at (3986): [<c0432725>] __do_softirq+0x104/0x10f
softirqs last disabled at (3981): [<c040704b>] do_softirq+0x7c/0xdd

other info that might help us debug this:
no locks held by S90crond/2396.

stack backtrace:
Pid: 2396, comm: S90crond Not tainted 2.6.27-0.329.rc6.git2.fc10.i686 #1
 [<c0693747>] ? printk+0x14/0x1d
 [<c044b85e>] valid_state+0x12a/0x13d
 [<c044bc5b>] mark_lock+0xde/0x331
 [<c044c901>] __lock_acquire+0x230/0xae6
 [<c044b2f6>] ? trace_hardirqs_off_caller+0x15/0x91
 [<c044b37d>] ? trace_hardirqs_off+0xb/0xd
 [<c040979a>] <6>ATL1E 0000:03:00.0: ATL1E: eth0 NIC Link is Up<100 Mbps Full Duplex>
? native_sched_clock+0xb3/0xd3
 [<c044bb9b>] ? mark_lock+0x1e/0x331
 [<c044d212>] lock_acquire+0x5b/0x81
 [<f89eb54e>] ? atl1e_intr+0x22d/0x3f7 [atl1e]
 [<c0695b80>] _spin_lock+0x23/0x50
 [<f89eb54e>] ? atl1e_intr+0x22d/0x3f7 [atl1e]
 [<f89eb54e>] atl1e_intr+0x22d/0x3f7 [atl1e]
 [<c044a914>] ? lock_release_holdtime+0x30/0x125
 [<c046d052>] handle_IRQ_event+0x1f/0x54
 [<c046e150>] handle_fasteoi_irq+0x82/0xbb
 [<c046e0ce>] ? handle_fasteoi_irq+0x0/0xbb
 [<c0406fa5>] do_IRQ+0x9f/0xc9
 [<c04056f8>] common_interrupt+0x28/0x30
 [<c069007b>] ? init_transmeta+0x8c/0x28e
 =======================
ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[drm] Initialized drm 1.1.0 20060810
pci 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
pci 0000:00:02.0: setting latency timer to 64
Comment 1 Sitsofe Wheeler 2008-09-24 06:32:23 EDT
Looks like locking issues with the atl1e (wired) network driver...

Peter:
Does temporarily disabling the wired network card in the BIOS make the warnings go away?
Comment 2 Peter Robinson 2008-09-25 09:38:58 EDT
Yes, disabling the wired nic in the bios stops the oops from happening so it seems that its the atl1e nic driver (which is what I suspected), it still seems to work after the oops.
Comment 3 Dominik 'Rathann' Mierzejewski 2008-10-23 16:37:24 EDT
Doesn't seem to happen with current rawhide kernel (2.6.27.3-34.fc10.i686) even with eth enabled in BIOS. Can you upgrade and confirm?
Comment 4 Peter Robinson 2008-10-25 03:36:04 EDT
No it seems to be fixed in the -39 build that I'm currently running as well.

Note You need to log in before you can comment on or make changes to this bug.