Bug 462856 - kde cannot login after selecting enable desktop effects kde-settings-4.0-25.fc9.noarch
kde cannot login after selecting enable desktop effects kde-settings-4.0-25.f...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-19 08:04 EDT by vikram goyal
Modified: 2008-09-25 19:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-25 19:33:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The whole dot .kde dir (549.42 KB, application/x-bzip-compressed-tar)
2008-09-19 08:04 EDT, vikram goyal
no flags Details
debug output (7.02 KB, text/plain)
2008-09-19 08:06 EDT, vikram goyal
no flags Details

  None (edit)
Description vikram goyal 2008-09-19 08:04:10 EDT
Created attachment 317185 [details]
The whole dot .kde dir

Description of problem:
Selecting 'enable desktop effects' from System-Settings -> Desktop crashed kde session and could not be started again

Version-Release number of selected component (if applicable):
kdebase-4.1.0-1.fc9.1.i386
kdebase-workspace-4.1.0-8.fc9.i386
kdebase-runtime-4.1.0-3.fc9.i386
kde-settings-4.0-25.fc9.noarch

How reproducible:
as described in description

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 vikram goyal 2008-09-19 08:06:51 EDT
Created attachment 317186 [details]
debug output
Comment 2 Rex Dieter 2008-09-19 08:46:22 EDT
Simply put, your video hw/driver apparently doesn't support compositing.  kwin is *supposed* fail more gracefully than this, however.

kde-4.1.1 has a few fixes that may help here.

In the meantime, you can manually disable compositing (desktop effects), but editing ~/.kde/share/config/kwinrc, and change

[Compositing]
Enabled=true

to

[Compositing]
Enabled=false
Comment 3 Kevin Kofler 2008-09-19 12:36:54 EDT
AFAIK, the test to check if compositing is actually working is not in 4.1.x, only 4.2. OpenSUSE has a backport we could snatch though. Note that 4.2 and OpenSUSE's backport also enable compositing by default (because it has this self-test and automatic fallback now), this is something I don't think is a good idea in an F9 update at this point.
Comment 4 Steven M. Parrish 2008-09-25 19:33:40 EDT
Closing this as NOTABUG since its a hardware issue.

Note You need to log in before you can comment on or make changes to this bug.