Bug 462875 - bbdb-vm.elc missing
bbdb-vm.elc missing
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: emacs-bbdb (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Underwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-19 09:21 EDT by Mikko Huhtala
Modified: 2008-11-22 11:48 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-15 22:04:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikko Huhtala 2008-09-19 09:21:39 EDT
Description of problem:

The file bbdb-vm.elc seems to be missing from the emacs-bbdb package. bbdb-vm.el is part of the source package (BBDB 2.35) and does get compiled with the usual 'make all'. 

Version-Release number of selected component (if applicable):

emacs-bbdb-2.35-8.fc8.noarch

How reproducible:

Always.

Steps to Reproduce:
1. Configure Emacs for VM and BBDB.
2. Run Emacs and start VM with the BBDB hook.
  
Actual results:

Emacs gives an error about not being able to load bbdb-vm.

Expected results:

Successful launch of VM and BBDB, with bbdb-vm (works with BBDB 2.35 from the original tarball).
Comment 1 Jonathan Underwood 2008-09-19 09:33:30 EDT
Thanks for the report, will take a look at this. Just to be clear, can you detail your configuration that you're using (i.e. any relevant parts of .emacs)
Comment 2 Mikko Huhtala 2008-09-19 11:39:27 EDT
I've put the VM configuration in ~/.vm and the BBDB config is there also. VM executes this file on startup. I don't actually have anything relevant in ~/.emacs. As I mentioned, the VM-BBDB combo works with Fedora-packaged VM and stock BBDB from the 2.35 tarball. It seems like only the Fedora-packaged BBDB gives the error. Selected bits from .vm:

(setq vm-spool-files
      '(
        ("~/vm-mail/xxxxxxxx" "imap-ssl:imap.abo.fi:993:inbox:login:xxxxxxxx:*" "~/vm-mail/xxxxxxxx.crash")))

(setq vm-imap-auto-expunge-alist
      '(
        ("imap-ssl:imap.abo.fi:993:inbox:login:xxxxxxxx:*" . t)))


(setq vm-folder-directory "~/vm-mail/")
(setq vm-primary-inbox "~/vm-mail/xxxxxxxx")
(setq mail-archive-file-name "~/vm-mail/sent-mail")
(setq mail-signature t)
(setq user-mail-address "xxxxxxxx")


(require 'bbdb)
(bbdb-initialize)
(bbdb-insinuate-vm)
Comment 3 Jonathan Underwood 2008-09-28 19:38:15 EDT
OK, have built new packages hopefully fixing this issue. They'll appear in updates-testing shortly, but you can also pull them directly from koji here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=64542

I've also updated the VM packages, also to appear in updates-testing, but you can pull them from here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=64467

Any testing would be gratefully received.
Comment 4 Fedora Update System 2008-09-28 19:42:14 EDT
emacs-bbdb-2.35-9.20080928cvs.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/emacs-bbdb-2.35-9.20080928cvs.fc8
Comment 5 Fedora Update System 2008-09-28 19:43:23 EDT
emacs-bbdb-2.35-9.20080928cvs.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/emacs-bbdb-2.35-9.20080928cvs.fc9
Comment 6 Mikko Huhtala 2008-09-29 06:08:40 EDT
I tried the RPMs from Koji (#3) and they mostly work for me. bbdb-vm.elc is found as it should be.

When composing a new message, mail-mode gives an error about not being able to determine the version of VM on the first attempt. There is a timeout and then a composition buffer is opened anyway. The error does not appear when starting new messages after that.
Comment 7 Jonathan Underwood 2008-09-29 07:36:18 EDT
(In reply to comment #6)
> I tried the RPMs from Koji (#3) and they mostly work for me. bbdb-vm.elc is
> found as it should be.
> 

Thanks for taking the time to test, it is appreciated.

> When composing a new message, mail-mode gives an error about not being able to
> determine the version of VM on the first attempt. There is a timeout and then a
> composition buffer is opened anyway. The error does not appear when starting
> new messages after that.

Just to be 100 percent clear: you see this error with VM 8.0.11.581 ? If you shutdown emacs and then restart it, does the same error reappear on the first compose?
Comment 8 Mikko Huhtala 2008-09-29 08:56:55 EDT
> you see this error with VM 8.0.11.581 ?

Yes, emacs-vm-8.0.11.581-1.fc9.i386 on emacs-22.2-5.fc9.i386.

> If you shutdown emacs and then restart it, does the same error
> reappear on the first compose?

Yes.

If I do 'M-x vm-version' without attempting to compose, I get 'ERROR: Cannot determine VM version!'. After that, composing starts without delay or error messages. So the problems seems to be the first call to vm-version.
Comment 9 Jonathan Underwood 2008-09-29 12:25:46 EDT
OK, this is because vm-revno.el[c] isn't installed for some reason in the new package. Will fix.
Comment 10 Jonathan Underwood 2008-09-29 16:48:19 EDT
OK, new packages for VM built which should fix this, 8.0.11.581-2.fc9:

http://koji.fedoraproject.org/koji/buildinfo?buildID=64729
Comment 11 Mikko Huhtala 2008-09-30 03:21:05 EDT
Did a simple test with 8.0.11.581-2.fc9 and it works for me. No complaints from vm-version. Thanks.
Comment 12 Jonathan Underwood 2008-09-30 04:53:09 EDT
OK, thanks for taking the time to test.
Comment 13 Fedora Update System 2008-10-01 02:36:24 EDT
emacs-bbdb-2.35-9.20080928cvs.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update emacs-bbdb'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8468
Comment 14 Fedora Update System 2008-10-01 02:41:34 EDT
emacs-bbdb-2.35-9.20080928cvs.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update emacs-bbdb'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-8498
Comment 15 Fedora Update System 2008-10-15 22:04:02 EDT
emacs-bbdb-2.35-9.20080928cvs.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2008-10-15 22:11:01 EDT
emacs-bbdb-2.35-9.20080928cvs.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2008-11-09 08:38:19 EST
emacs-bbdb-2.35-1.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/emacs-bbdb-2.35-1.fc8
Comment 18 Fedora Update System 2008-11-09 08:39:25 EST
emacs-bbdb-2.35-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/emacs-bbdb-2.35-1.fc9
Comment 19 Fedora Update System 2008-11-09 08:40:14 EST
emacs-bbdb-2.35-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/emacs-bbdb-2.35-1.fc10
Comment 20 Fedora Update System 2008-11-12 22:34:57 EST
emacs-bbdb-2.35-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2008-11-12 22:36:31 EST
emacs-bbdb-2.35-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2008-11-22 11:48:55 EST
emacs-bbdb-2.35-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.