Bug 462917 - nonspare file causes hotplug timeout
nonspare file causes hotplug timeout
Status: CLOSED DUPLICATE of bug 456926
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
http://rhts.redhat.com/testlogs/29609...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-19 13:52 EDT by Jeff Burke
Modified: 2009-12-14 16:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 16:01:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xml script used to duplicate the issue (6.71 KB, text/plain)
2008-09-19 13:52 EDT, Jeff Burke
no flags Details

  None (edit)
Description Jeff Burke 2008-09-19 13:52:06 EDT
Created attachment 317222 [details]
xml script used to duplicate the issue

Description of problem:
virt installs failing.
virDomainCreateLinux() failed POST operation failed: (xend.err 'Device 0 (vif) could not be connected. Hotplug scripts not working.') on host sun-x4600m2-01.rhts.bos.redhat.com arch x86_64 

Version-Release number of selected component (if applicable):
RHEL5.3-Server-20080814.nightly

How reproducible:
unknown

Steps to Reproduce:
1. Attached is the xml file that reproduce the issue for me.
2. You run it by using the RHTS submit_job.py script 
3. Link to RHTS workflows http://intranet.corp.redhat.com/ic/intranet/RHTSMainPage.html#devel
  
Actual results:

virDomainCreateLinux() failed POST operation failed: (xend.err 'Device 0 (vif) could not be connected. Hotplug scripts not working.')
Domain installation may not have been
 successful.  If it was, you can restart your domain
 by running 'virsh start guest69-163.rhts.bos.redhat.com'; otherwise, please
 restart your installation.
Fri, 19 Sep 2008 04:41:53 ERROR    virDomainCreateLinux() failed POST operation failed: (xend.err 'Device 0 (vif) could not be connected. Hotplug scripts not working.')
Traceback (most recent call last):
  File "/usr/sbin/virt-install", line 502, in ?
    main()
  File "/usr/sbin/virt-install", line 462, in main
    dom = guest.start_install(conscb,progresscb)
  File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 813, in start_install
    return self._do_install(consolecb, meter)
  File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 834, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)

  File "/usr/lib64/python2.4/site-packages/libvirt.py", line 573, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: virDomainCreateLinux() failed POST operation failed: (xend.err 'Device 0 (vif) could not be connected. Hotplug scripts not working.')

Expected results:


Additional info:
If you use the attached script please change the submitter line.
<submitter>PutYourNameHere@redhat.com</submitter>
Comment 1 Cole Robinson 2009-02-13 16:01:16 EST

*** This bug has been marked as a duplicate of bug 456926 ***

Note You need to log in before you can comment on or make changes to this bug.