Bug 46292 - (IDE VIA)2.4.3-12 hangs on loading keytable
(IDE VIA)2.4.3-12 hangs on loading keytable
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-06-27 14:11 EDT by Justin Moore
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:39:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Justin Moore 2001-06-27 14:11:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2smp i686)

Description of problem:
I have an AMD 933 running on an ASUS A7V-KT133 that reliably hangs when
trying to load the keytable.  The hard drive is a WD400B, connected to
the ATA100 controller.  It's a hard lockup, where even the SysReq keys
don't work anymore.  In /etc/init.d/keytable I tried removing the redirect
to /dev/null, and adding -vv to the actual loadkey command, but nothing
prints out.  The system ran fine on 2.4.2-2, but I just can't get it to
work now.  The loadkey command works fine when I boot into single mode and
run it from the command line.

How reproducible:

Steps to Reproduce:
1.  Upgrade 2.4.2-2 system on above described hardware to 2.4.3-12
2.  Boot machine.

Actual Results:  The machine locks cold on loading the keytable, and I
can't boot into multi-user mode.

Additional info:
Comment 1 Arjan van de Ven 2001-06-28 04:48:35 EDT
Does it work if you try "ide=nodma" on the lilo prompt ?
Comment 2 Justin Moore 2001-06-28 11:44:22 EDT
The ide=nodma works fine.  The hosts on which this was a problem are part of a
cluster, though, and turning DMA off causes a very noticeable performance hit on
our apps.  Any idea the root cause of this bug, or any other way to work around
it?  I will, however, leave DMA turned off for now.
Comment 3 Arjan van de Ven 2001-06-28 11:52:22 EDT
First suggestion: go to the Asus website and upgrade your bios.
VIA chipsets have bugs that are worked around in VERY recent bioses;
2.4.2-2 had an unoffical bugfix we reverseengineered, 2.4.3-12 has the official
one but it seems to not work with all older bioses.

Second: it might be that the highest DMA setting is causing problems.
You can boot with "ide=nodma" and then use hdparm to enable a dma or udma33;
it's not as fast as udma66/100 but it's still better than no dma at all.
Comment 4 Justin Moore 2001-06-28 14:38:08 EDT
I downloaded and successfully installed the 1005A BIOS (the latest one
for my MB).  I removed the "ide=nodma" from lilo and rebooted. 
It still hung on the keytable.

I kept the "ide=nodma" in lilo.conf, but created a harddiskhde file
in /etc/sysconfig/.  I had USING_DMA uncommented, with options
"-X66 -a 8".  It still hung.  I tried -X34 instead and it still hung.

Let me know if there's any other info you need or any other
possible work-arounds you know of.  Thanks for your help so far.
Comment 5 Ulug Unligil 2001-07-30 15:11:37 EDT
Have you tried a beta ASUS bios from ftp.asuscom.de?  The 1006.01i beta is
available for the a7v133.  I've just installed it, and it would *appear* to have
fixed the problem.
Comment 6 Justin Moore 2001-08-07 12:07:43 EDT
I tried the recommended beta BIOS with limited results.  It boots
and gets past loading the keytable, but freezes later on.  While
starting runlevel 3, it gets to starting atd and then hangs.  Same
kind of hang as before; it requires a cold reboot.
Comment 7 Bugzilla owner 2004-09-30 11:39:03 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.