Bug 462929 - Not able to login to WebUI after upgrading from satellite 5.1.1 with more than one org to 5.2
Not able to login to WebUI after upgrading from satellite 5.1.1 with more th...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
520
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brad Buckingham
Preethi Thomas
:
Depends On:
Blocks: 446861
  Show dependency treegraph
 
Reported: 2008-09-19 15:39 EDT by Preethi Thomas
Modified: 2008-11-05 13:42 EST (History)
1 user (show)

See Also:
Fixed In Version: sat520
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 13:42:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2008-09-19 15:39:30 EDT
Description of problem:

Not able to login to WebUI  after upgrading from satellite 5.1.1 with more than one org to 5.2 . Trying to login to any of the ORG results in ISE

Version-Release number of selected component (if applicable):

Satellite-5.2.0-RHEL4-re20080917.0-i386-embedded-oracle.iso
rhn-upgrade-5.2.0-14.el4

How reproducible:
always

Steps to Reproduce:
1. Set up a 511 satellite with different orgs 
2. Install the rhn-upgrade package and follow the steps to upgrade.
3.  Try to Enable monitoring by /usr/bin/perl rhn-enable-monitoring.pl --enable-scout  (Step 9 in rhn-satellite-5-upgrade-scenario-1b.txt)
4. Notice that it fails.
5. Restart the satellite
6. Try to login to WebUI (Any org)

  
Actual results:
[root@rlx-3-08 satellite-upgrade]# /usr/bin/perl rhn-enable-monitoring.pl --enable-scout
Setting up Monitoring backend
2008-09-19 15:02:36 Monitoring: Debug level = 0
2008-09-19 15:02:36 Monitoring: Switches: install
2008-09-19 15:02:36 Monitoring: Installing Monitoring for SysV startup in runlevels 2,3,5, start=84, stop=16
RHN::Exception: Attempt to get satellite_org_id on database with more than one org
  RHN::DB::SatInstall /usr/lib/perl5/site_perl/5.8.5/RHN/DB/SatInstall.pm 373 RHN::Exception::throw
  main rhn-enable-monitoring.pl 57 RHN::DB::SatInstall::get_satellite_org_id


ISE on trying to login to WebUI


Expected results:
sucessful upgrade

Additional info:

The following exception occurred while executing this request:
GET /rhn/YourRhn.do

Date:9/19/08 3:12:30 PM EDT
Headers:
  host: rlx-3-08.rhndev.redhat.com
  user-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.16) Gecko/20080722 Fedora/2.0.0.16-1.rhis Firefox/2.0.0.16
  accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
  accept-language: en-us,ar;q=0.8,ja;q=0.5,ml;q=0.3
  accept-encoding: gzip,deflate
  accept-charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
  Keep-Alive: 300
  connection: keep-alive
  referer: https://rlx-3-08.rhndev.redhat.com/rhn/Login.do
  cookie: JSESSIONID=733809FCFD3FA93DC9225104FAA5DFD0; rh_omni_tc=70160000000H4AjAAK; s_vi=[CS]v1|48C571AB00001C0E-A3A095300001383[CE]; pxt-session-cookie=2980xedef0fd2c816673460cc5bc45cea11cf
  content-length: 0

Request:
Local Name = rlx-3-08.rhndev.redhat.com
Server Name = rlx-3-08.rhndev.redhat.com
Requested Session Id came from Cookie
Requested Session Valid = true
Session = org.apache.catalina.session.StandardSessionFacade@c5119e[session=StandardSession[733809FCFD3FA93DC9225104FAA5DFD0]]
Protocol = https
Request Locale = en_US
Request Character Encoding = UTF-8
Attribute Names = rhnActiveLang, org.apache.struts.action.MESSAGE, javax.servlet.jsp.jstl.fmt.timeZone.request, org.apache.struts.action.mapping.instance, session, __sitemesh__filterapplied, requestedUri, org.apache.struts.action.MODULE,


User Information:
No User logged in.

Exception:
javax.servlet.ServletException
        at org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:535)
        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:433)
        at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:236)
        at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:78)
        at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
        at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:743)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:69)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)
        at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:63)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:103)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:51)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:93)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:214)
        at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
        at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
        at org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:198)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:152)
        at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
        at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:137)
        at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:118)
        at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:102)
        at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
        at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
        at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
        at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:929)
        at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:162)
        at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:300)
        at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:374)
        at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:743)
        at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:675)
        at org.apache.jk.common.SocketConnection.runIt(ChannelSocket.java:866)
        at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
        at java.lang.Thread.run(Thread.java:595)
Caused by: java.lang.NullPointerException
        at com.redhat.rhn.frontend.action.YourRhnAction.getDisplayPanes(YourRhnAction.java:152)
        at com.redhat.rhn.frontend.action.YourRhnAction.execute(YourRhnAction.java:104)
        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
        ... 51 more
Comment 1 Clifford Perry 2008-09-19 16:29:06 EDT
Caused by: java.lang.NullPointerException
        at
com.redhat.rhn.frontend.action.YourRhnAction.getDisplayPanes(YourRhnAction.java:152)
        at
com.redhat.rhn.frontend.action.YourRhnAction.execute(YourRhnAction.java:104)


100    public ActionForward execute(ActionMapping mapping, ActionForm form,
101            HttpServletRequest request, HttpServletResponse response) {
102        RequestContext ctx = new RequestContext(request);
103        User user = ctx.getCurrentUser();
104        Map panes = getDisplayPanes(user);
105        boolean anyListsSelected = false;


150    private Map getDisplayPanes(User user) {
151        Map panes = PaneFactory.getAllPanes();
152        Set hiddenPanes = user.getHiddenPanes();
153        Map mergedPanes = new HashMap();

from rhn-java-sat-svn-r176858 src.rpm ./code/src/com/redhat/rhn/frontend/action/YourRhnAction.java


Maybe something in web_contact not correct about user in question... or recent changes to rhn/domain/user/User.java or frontend/action/YourRhnAction.java


just taking a quick look, but with Prethi Sat down, hard to do much of ny investigation.
Comment 2 Clifford Perry 2008-09-19 16:38:45 EDT
        <set name = "hiddenPanes"
                table="RHNUSERINFOPANE"
                lazy="true"
                cascade="all">
                <key column="user_id"/>
                <many-to-many class ="com.redhat.rhn.domain.user.Pane" column="pane_id"/>
        </set>


if I had to guess - the user in question has no panes hidden/set within rhnUserInfoPane (table in DB), so of course, it is Null for that user. Unless code changed, I assume a supporting library, or Oracle change made behavior change and thus cause/generate the tracceback on null. 

I will leave it be for now... this is just my best guess at first quick review.
Comment 3 Brad Buckingham 2008-09-22 09:26:59 EDT
In the log there are a set of errors that occur immediately before and after the Exception and they look like the following:

** before exception

2008-09-22 08:21:36,969 [RHN Message Dispatcher] WARN  org.hibernate.util.JDBCExceptionReporter - SQL Error: 904, SQLState: 42000
2008-09-22 08:21:36,970 [RHN Message Dispatcher] ERROR org.hibernate.util.JDBCExceptionReporter - ORA-00904: "ORGIMPL0_"."PASSWORD": invalid identifier

2008-09-22 08:21:36,970 [RHN Message Dispatcher] ERROR com.redhat.rhn.common.messaging.ActionExecutor - org.hibernate.exception.SQLGrammarException: could not load an entity: [com.redhat.rhn.domain.org.OrgImpl#1]
2008-09-22 08:21:36,992 [TP-Processor6] WARN  org.hibernate.util.JDBCExceptionReporter - SQL Error: 904, SQLState: 42000
2008-09-22 08:21:36,992 [TP-Processor6] ERROR org.hibernate.util.JDBCExceptionReporter - ORA-00904: "ORGIMPL2_"."PASSWORD": invalid identifier

2008-09-22 08:21:36,992 [TP-Processor6] ERROR com.redhat.rhn.domain.user.UserFactory - Hibernate exception: org.hibernate.exception.SQLGrammarException: could not load an entity: [com.redhat.rhn.domain.user.legacy.LegacyRhnUserImpl#1]
2008-09-22 08:21:37,035 [TP-Processor6] WARN  org.hibernate.util.JDBCExceptionReporter - SQL Error: 904, SQLState: 42000
2008-09-22 08:21:37,035 [TP-Processor6] ERROR org.hibernate.util.JDBCExceptionReporter - ORA-00904: "ORGIMPL2_"."PASSWORD": invalid identifier

2008-09-22 08:21:37,035 [TP-Processor6] ERROR com.redhat.rhn.domain.user.UserFactory - Hibernate exception: org.hibernate.exception.SQLGrammarException: could not load an entity: [com.redhat.rhn.domain.user.legacy.LegacyRhnUserImpl#1]
2008-09-22 08:21:37,079 [TP-Processor6] WARN  org.apache.struts.action.RequestProcessor - Unhandled Exception thrown: class java.lang.NullPointerException
2008-09-22 08:21:37,087 [TP-Processor6] WARN  org.hibernate.util.JDBCExceptionReporter - SQL Error: 904, SQLState: 42000
2008-09-22 08:21:37,088 [TP-Processor6] ERROR org.hibernate.util.JDBCExceptionReporter - ORA-00904: "ORGIMPL2_"."PASSWORD": invalid identifier


** after the exception

2008-09-22 08:21:37,139 [TP-Processor6] WARN  org.hibernate.util.JDBCExceptionReporter - SQL Error: 904, SQLState: 42000
2008-09-22 08:21:37,139 [TP-Processor6] ERROR org.hibernate.util.JDBCExceptionReporter - ORA-00904: "ORGIMPL2_"."PASSWORD": invalid identifier

2008-09-22 08:21:37,139 [TP-Processor6] ERROR com.redhat.rhn.domain.user.UserFactory - Hibernate exception: org.hibernate.exception.SQLGrammarException: could not load an entity: [com.redhat.rhn.domain.user.legacy.LegacyRhnUserImpl#1]
2008-09-22 08:21:37,150 [TP-Processor6] WARN  org.hibernate.util.JDBCExceptionReporter - SQL Error: 904, SQLState: 42000
2008-09-22 08:21:37,150 [TP-Processor6] ERROR org.hibernate.util.JDBCExceptionReporter - ORA-00904: "ORGIMPL2_"."PASSWORD": invalid identifier

2008-09-22 08:21:37,150 [TP-Processor6] ERROR com.redhat.rhn.domain.user.UserFactory - Hibernate exception: org.hibernate.exception.SQLGrammarException: could not load an entity: [com.redhat.rhn.domain.user.legacy.LegacyRhnUserImpl#1]
2008-09-22 08:21:37,164 [TP-Processor6] WARN  org.hibernate.util.JDBCExceptionReporter - SQL Error: 904, SQLState: 42000
2008-09-22 08:21:37,164 [TP-Processor6] ERROR org.hibernate.util.JDBCExceptionReporter - ORA-00904: "ORGIMPL2_"."PASSWORD": invalid identifier

2008-09-22 08:21:37,164 [TP-Processor6] ERROR com.redhat.rhn.domain.user.UserFactory - Hibernate exception: org.hibernate.exception.SQLGrammarException: could not load an entity: [com.redhat.rhn.domain.user.legacy.LegacyRhnUserImpl#1]
2008-09-22 08:21:37,173 [TP-Processor6] WARN  org.hibernate.util.JDBCExceptionReporter - SQL Error: 904, SQLState: 42000
2008-09-22 08:21:37,174 [TP-Processor6] ERROR org.hibernate.util.JDBCExceptionReporter - ORA-00904: "ORGIMPL2_"."PASSWORD": invalid identifier

2008-09-22 08:21:37,175 [TP-Processor6] ERROR com.redhat.rhn.domain.user.UserFactory - Hibernate exception: org.hibernate.exception.SQLGrammarException: could not load an entity: [com.redhat.rhn.domain.user.legacy.LegacyRhnUserImpl#1]
2008-09-22 08:21:37,188 [TP-Processor6] WARN  org.hibernate.util.JDBCExceptionReporter - SQL Error: 904, SQLState: 42000
2008-09-22 08:21:37,188 [TP-Processor6] ERROR org.hibernate.util.JDBCExceptionReporter - ORA-00904: "ORGIMPL2_"."PASSWORD": invalid identifier

2008-09-22 08:21:37,188 [TP-Processor6] ERROR com.redhat.rhn.domain.user.UserFactory - Hibernate exception: org.hibernate.exception.SQLGrammarException: could not load an entity: [com.redhat.rhn.domain.user.legacy.LegacyRhnUserImpl#1]
2008-09-22 08:21:37,197 [TP-Processor6] WARN  org.hibernate.util.JDBCExceptionReporter - SQL Error: 904, SQLState: 42000
2008-09-22 08:21:37,197 [TP-Processor6] ERROR org.hibernate.util.JDBCExceptionReporter - ORA-00904: "ORGIMPL2_"."PASSWORD": invalid identifier

2008-09-22 08:21:37,197 [TP-Processor6] ERROR com.redhat.rhn.domain.user.UserFactory - Hibernate exception: org.hibernate.exception.SQLGrammarException: could not load an entity: [com.redhat.rhn.domain.user.legacy.LegacyRhnUserImpl#1]
2008-09-22 08:21:37,211 [TP-Processor6] WARN  org.hibernate.util.JDBCExceptionReporter - SQL Error: 904, SQLState: 42000
2008-09-22 08:21:37,212 [TP-Processor6] ERROR org.hibernate.util.JDBCExceptionReporter - ORA-00904: "ORGIMPL2_"."PASSWORD": invalid identifier

2008-09-22 08:21:37,212 [TP-Processor6] ERROR com.redhat.rhn.domain.user.UserFactory - Hibernate exception: org.hibernate.exception.SQLGrammarException: could not load an entity: [com.redhat.rhn.domain.user.legacy.LegacyRhnUserImpl#1]
2008-09-22 08:21:37,225 [TP-Processor6] WARN  org.hibernate.util.JDBCExceptionReporter - SQL Error: 904, SQLState: 42000
2008-09-22 08:21:37,226 [TP-Processor6] ERROR org.hibernate.util.JDBCExceptionReporter - ORA-00904: "ORGIMPL2_"."PASSWORD": invalid identifier

2008-09-22 08:21:37,226 [TP-Processor6] ERROR com.redhat.rhn.domain.user.UserFactory - Hibernate exception: org.hibernate.exception.SQLGrammarException: could not load an entity: [com.redhat.rhn.domain.user.legacy.LegacyRhnUserImpl#1]
2008-09-22 08:21:37,249 [TP-Processor6] WARN  org.hibernate.util.JDBCExceptionReporter - SQL Error: 904, SQLState: 42000
2008-09-22 08:21:37,249 [TP-Processor6] ERROR org.hibernate.util.JDBCExceptionReporter - ORA-00904: "ORGIMPL2_"."PASSWORD": invalid identifier

2008-09-22 08:21:37,250 [TP-Processor6] ERROR com.redhat.rhn.domain.user.UserFactory - Hibernate exception: org.hibernate.exception.SQLGrammarException: could not load an entity: [com.redhat.rhn.domain.user.legacy.LegacyRhnUserImpl#1]
2008-09-22 08:21:37,266 [TP-Processor6] WARN  org.hibernate.util.JDBCExceptionReporter - SQL Error: 904, SQLState: 42000
2008-09-22 08:21:37,267 [TP-Processor6] ERROR org.hibernate.util.JDBCExceptionReporter - ORA-00904: "ORGIMPL2_"."PASSWORD": invalid identifier

2008-09-22 08:21:37,267 [TP-Processor6] ERROR com.redhat.rhn.domain.user.UserFactory - Hibernate exception: org.hibernate.exception.SQLGrammarException: could not load an entity: [com.redhat.rhn.domain.user.legacy.LegacyRhnUserImpl#1]
2008-09-22 08:21:37,285 [TP-Processor6] WARN  org.hibernate.util.JDBCExceptionReporter - SQL Error: 904, SQLState: 42000
2008-09-22 08:21:37,285 [TP-Processor6] ERROR org.hibernate.util.JDBCExceptionReporter - ORA-00904: "ORGIMPL2_"."PASSWORD": invalid identifier

2008-09-22 08:21:37,286 [TP-Processor6] ERROR com.redhat.rhn.domain.user.UserFactory - Hibernate exception: org.hibernate.exception.SQLGrammarException: could not load an entity: [com.redhat.rhn.domain.user.legacy.LegacyRhnUserImpl#1]
2008-09-22 08:21:37,299 [TP-Processor6] WARN  org.hibernate.util.JDBCExceptionReporter - SQL Error: 904, SQLState: 42000
2008-09-22 08:21:37,299 [TP-Processor6] ERROR org.hibernate.util.JDBCExceptionReporter - ORA-00904: "ORGIMPL2_"."PASSWORD": invalid identifier

2008-09-22 08:21:37,299 [TP-Processor6] ERROR com.redhat.rhn.domain.user.UserFactory - Hibernate exception: org.hibernate.exception.SQLGrammarException: could not load an entity: [com.redhat.rhn.domain.user.legacy.LegacyRhnUserImpl#1]
2008-09-22 08:21:37,309 [TP-Processor6] WARN  org.hibernate.util.JDBCExceptionReporter - SQL Error: 904, SQLState: 42000
2008-09-22 08:21:37,309 [TP-Processor6] ERROR org.hibernate.util.JDBCExceptionReporter - ORA-00904: "ORGIMPL2_"."PASSWORD": invalid identifier

2008-09-22 08:21:37,309 [TP-Processor6] ERROR com.redhat.rhn.domain.user.UserFactory - Hibernate exception: org.hibernate.exception.SQLGrammarException: could not load an entity: [com.redhat.rhn.domain.user.legacy.LegacyRhnUserImpl#1]
2008-09-22 08:21:37,321 [TP-Processor6] WARN  org.hibernate.util.JDBCExceptionReporter - SQL Error: 904, SQLState: 42000
2008-09-22 08:21:37,321 [TP-Processor6] ERROR org.hibernate.util.JDBCExceptionReporter - ORA-00904: "ORGIMPL2_"."PASSWORD": invalid identifier

2008-09-22 08:21:37,322 [TP-Processor6] ERROR com.redhat.rhn.domain.user.UserFactory - Hibernate exception: org.hibernate.exception.SQLGrammarException: could not load an entity: [com.redhat.rhn.domain.user.legacy.LegacyRhnUserImpl#1]
2008-09-22 08:21:37,330 [TP-Processor6] WARN  org.hibernate.util.JDBCExceptionReporter - SQL Error: 904, SQLState: 42000
2008-09-22 08:21:37,330 [TP-Processor6] ERROR org.hibernate.util.JDBCExceptionReporter - ORA-00904: "ORGIMPL2_"."PASSWORD": invalid identifier

2008-09-22 08:21:37,330 [TP-Processor6] ERROR com.redhat.rhn.domain.user.UserFactory - Hibernate exception: org.hibernate.exception.SQLGrammarException: could not load an entity: [com.redhat.rhn.domain.user.legacy.LegacyRhnUserImpl#1]
2008-09-22 08:21:37,343 [TP-Processor6] WARN  org.hibernate.util.JDBCExceptionReporter - SQL Error: 904, SQLState: 42000
2008-09-22 08:21:37,343 [TP-Processor6] ERROR org.hibernate.util.JDBCExceptionReporter - ORA-00904: "ORGIMPL2_"."PASSWORD": invalid identifier

2008-09-22 08:21:37,344 [TP-Processor6] ERROR com.redhat.rhn.domain.user.UserFactory - Hibernate exception: org.hibernate.exception.SQLGrammarException: could not load an entity: [com.redhat.rhn.domain.user.legacy.LegacyRhnUserImpl#1]
2008-09-22 08:21:37,358 [TP-Processor6] WARN  org.hibernate.util.JDBCExceptionReporter - SQL Error: 904, SQLState: 42000
2008-09-22 08:21:37,358 [TP-Processor6] ERROR org.hibernate.util.JDBCExceptionReporter - ORA-00904: "ORGIMPL2_"."PASSWORD": invalid identifier

2008-09-22 08:21:37,359 [TP-Processor6] ERROR com.redhat.rhn.domain.user.UserFactory - Hibernate exception: org.hibernate.exception.SQLGrammarException: could not load an entity: [com.redhat.rhn.domain.user.legacy.LegacyRhnUserImpl#1]
Comment 4 Brad Buckingham 2008-09-22 09:54:44 EDT
This bug may be related to the removal of 'password' from the web_customer that was done as part of https://bugzilla.redhat.com/show_bug.cgi?id=453664.

Although it appears that the password is not really used by the code, there are references to it in several classes (e.g. OrgImpl.java which provides the java mapping for hibernate for web_customer, Org.java which is the interface that OrgImpl implements, OrgFactoryTest.java and UserTestUtils.java)

This is what appears to be generating the errors described in comment #3.
Comment 5 Brad Buckingham 2008-09-22 16:52:24 EDT
Removed the application code that referenced the web_customer password.
Using an updated rhn.jar with these changes, was able to verify that the problem was no longer observed on rlx-3-08.


New Revision: 177211

Modified:
   branches/eng/RELEASE-5.2/java/code/src/com/redhat/rhn/domain/org/Org.java
   branches/eng/RELEASE-5.2/java/code/src/com/redhat/rhn/domain/org/OrgFactory.java
   branches/eng/RELEASE-5.2/java/code/src/com/redhat/rhn/domain/org/OrgImpl.java
   branches/eng/RELEASE-5.2/java/code/src/com/redhat/rhn/domain/org/test/OrgFactoryTest.java
   branches/eng/RELEASE-5.2/java/code/src/com/redhat/rhn/testing/UserTestUtils.java
Comment 7 Preethi Thomas 2008-09-29 10:43:27 EDT
verified
Comment 8 Preethi Thomas 2008-10-23 13:43:35 EDT
able to login to all the orgs.
release pending
Comment 9 Brandon Perkins 2008-11-05 13:42:27 EST
5.2.0 Satellite is now GA, bugs Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.