Bug 462947 - [LTC 6.0 FEAT] 201586:Validation Only - Enable eHEA with DLPAR memory remove support
[LTC 6.0 FEAT] 201586:Validation Only - Enable eHEA with DLPAR memory remove ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
ppc64 All
high Severity high
: alpha
: 6.0
Assigned To: Ameet Paranjape
Martin Jenner
: FutureFeature
Depends On:
Blocks: 356741 RHEL6Kernel2.6.27
  Show dependency treegraph
 
Reported: 2008-09-19 17:20 EDT by IBM Bug Proxy
Modified: 2010-10-18 10:26 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-12 18:18:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-19 17:20:29 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:19 EDT
1. Feature Overview:
Feature Id:	[201586]
a. Name of Feature:	Validation Only - Enable eHEA with DLPAR memory remove support
b. Feature Description
Enhance the eHEA driver with the support for the DLPAR memory remove function. This is a standard
requirement for all device drivers running on Power servers.

2. Feature Details:
Sponsor:	PPC
Architectures:
ppc64

Arch Specificity: Purely Arch Specific Code
Affects Kernel Modules: Yes
Delivery Mechanism: Direct from community
Category:	Device Drivers and IO
Request Type:	Driver - Update Version
d. Upstream Acceptance:	Accepted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	kernel 2.6.27.

3. Business Case
DLPAR is a key feature for Power customers. The memory remove function is a requirement for
providing advanced on-demand computing on Power servers.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Stephanie Glass, sglass@us.ibm.com, 512-838-9284

Technical contact(s):
Daisy Chang, daisyc@us.ibm.com
Jan-Bernd Themann, themann@de.ibm.com

IBM Manager:
Wendel Voigt, wvoigt@us.ibm.com
Comment 1 Bill Nottingham 2008-10-01 15:08:13 EDT
If this is validation, is IBM planning to validate this on the RHEL 6 codebase?

If there is code (a target is listed), is it actually in 2.6.27?
Comment 2 IBM Bug Proxy 2009-02-13 15:40:28 EST
The upstream eHEA driver code has been supporting this feature since 2.6.27. Since RHEL6 will have a base kernel even higher than this level, I'm closing this feature as "fix already available."
Comment 3 Bill Nottingham 2009-02-13 16:49:30 EST
OK, setting to MODIFIED on this end.

The feature requested has already been accepted into the upstream code base
planned for the next major release of Red Hat Enterprise Linux.

When the next milestone release of Red Hat Enterprise Linux 6 is available,
please verify that the feature requested is present and functioning as
desired.
Comment 4 Kevin W Monroe 2009-11-12 18:18:19 EST
Closing as support is available in current release.

Note You need to log in before you can comment on or make changes to this bug.