Bug 462953 - [LTC 6.0 FEAT] 201594:Provide CMS script for initial IPL under z/VM
[LTC 6.0 FEAT] 201594:Provide CMS script for initial IPL under z/VM
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
s390x All
high Severity high
: alpha
: 6.0
Assigned To: David Cantrell
Release Test Team
: FutureFeature
Depends On:
Blocks: 356741 554559 563347 580631
  Show dependency treegraph
 
Reported: 2008-09-19 17:30 EDT by IBM Bug Proxy
Modified: 2010-07-02 16:39 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-13.21.9-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 580631 (view as bug list)
Environment:
Last Closed: 2010-07-02 16:39:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-19 17:30:36 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:19 EDT
1. Feature Overview:
Feature Id:	[201594]
a. Name of Feature:	Provide CMS script for initial IPL under z/VM
b. Feature Description
After having loaded the three necessary install files (kernel, parameter file, initrd) to a VM
guest, e.g. via FTP, the user has to IPL the initial install process of zLinux. This requires the
execution of CMS commands, which the user might not be familiar with. Although there are in the
documentation predefined CMS scripts to setup the VM reader and finally IPL the zLinux installation,
the user would still have to bring such a script into his guest.  A script should be provided per
enterprise distribution, which uses the distro specific naming scheme for kernel, parameter file,
and initrd. This script should be placed in the directory of the distro shipping media (DVD/CD/FTP
server), where the other three files already reside. This  way, the user gets relieved from e.g.
entering such a script using  xedit in the CMS environment and can simply download it using FTP 
along with the three other files and then execute it. The distro should take such a CMS EXEC from
their current documentation and ship it with their releases. The corresponding architecture specific
installation documentation should be updated accordingly.

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Purely Arch Specific Code
Affects Installer: Yes
Delivery Mechanism: Request Red Hat development assistance
Category:	zSeries
Request Type:	Installer - Enhancement from Distributor
d. Upstream Acceptance:	No Code Required
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	no
g. Component Version Target:	n/a

3. Business Case
Avoid customer frustation during installation, by just needing to know how to FTP from z/VM (instead
of having to learn how to use z/VM editor).

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):

Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 Bill Nottingham 2008-10-01 15:36:42 EDT
This would be part of the image build process/tree build process in anaconda/pungi.
Comment 2 John Jarvis 2008-10-28 17:43:15 EDT
Switching Severity from Urgent to High.  Urgent should be reserved for problems that need to be fixed asynch.
Comment 3 Jesse Keating 2008-10-28 18:23:43 EDT
You'd want to get this done in Fedora land first, so that it is already working when we move to RHEL 6.
Comment 4 IBM Bug Proxy 2008-10-30 10:32:15 EDT
(In reply to comment #7)
> ------- Comment From jkeating@redhat.com 2008-10-28 18:23:43 EDT-------
> You'd want to get this done in Fedora land first, so that it is already working
> when we move to RHEL 6.

We're fine with bringing this into RHEL6 via Fedora. However, currently there is no official Fedora build for s390. Anyway, as mentioned by notting@redhat.com it's just about taking the example "redhat.exec" [http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.2/html/Installation_Guide/s1-s390-steps-vm.html] and bringing it into the image build process/tree build process in
anaconda/pungi. Also, this is code which is not executed as part of Fedora/RHEL itself but inside the z/VM operating system CMS. I.e. it won't break anything inside Fedora/RHEL. I suppose David Cantrell or others could easily bring this into the anaconda.git and reference the exec-script correspondingly in the (anaconda) build process, such that it will finally reside in images/redhat.exec on the ISOs.

Thanks a lot for your support.
Comment 5 David Cantrell 2008-10-30 17:11:54 EDT
Would adding this as 'redhat.exec' on the install media be sufficient:

/* */
'CL RDR'
'PURGE RDR ALL'
'SPOOL PUNCH * RDR'
'PUNCH KERNEL IMG A (NOH'
'PUNCH GENERIC PRM A (NOH'
'PUNCH INITRD IMG A (NOH'
'CH RDR ALL KEEP NOHOLD'
'I 00C'

I took that from the documentation, but changed the PARM line to reference GENERIC PRM since that's the file we provide on the install media.
Comment 6 Gonzalo Muelas Serrano 2008-10-31 04:41:35 EDT
Hello David,

good idea.

Please DO NOT FORGET to update the DOCUMENTATION
http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.2/html/Installation_Guide/s1-s390-steps-vm.html
, that is, the Installation Guide with the needed changes:
- Ftp Commands
- redhat.exec contents and explaining that one is available in the DVD (see ftp commands), and that is needed to start the installation
- And at the end of the page, where the "Create an executable script containing the commands necessary to IPL the kernel image and start the installation. The following sample script is a typical initial start-up script:" should probably be changed by something like "Download from DVD (as mentioned by ftp commands) or create an executable script...."

Please provide us a draft of the new page ASAP so that we can review and make any possible changes in time.

Thank you,
Gonzalo Muelas Serrano.
Comment 7 IBM Bug Proxy 2008-10-31 09:20:47 EDT
Hi David,

(In reply to comment #9)
> ------- Comment From dcantrell@redhat.com 2008-10-30 17:11:54 EDT-------
> Would adding this as 'redhat.exec' on the install media be sufficient:
>
> /* */
> 'CL RDR'
> 'PURGE RDR ALL'
> 'SPOOL PUNCH * RDR'
> 'PUNCH KERNEL IMG A (NOH'
> 'PUNCH GENERIC PRM A (NOH'
> 'PUNCH INITRD IMG A (NOH'
> 'CH RDR ALL KEEP NOHOLD'
> 'I 00C'
>
> I took that from the documentation, but changed the PARM line to reference
> GENERIC PRM since that's the file we provide on the install media.

Please make sure that the used filenames match the instructions on how to get the files onto the CMS A disk using the CMS FTP client in the Installation Guide [1]. It all relies on the fact that all files referenced by redhat.exec have been downloaded by the user to the CMS A disk with the names mentioned in your documentation. Since the doc used to instruct a customer to download generic.prm as redhat.parm to the CMS A disk
"get generic.prm redhat.parm (repl"
I would stick to this in order to keep the existing renaming behavior, customers might already be familiar with.

As Gonzalo already mentioned, right after this FTP command (and before the quit), the user should be instructed to download the redhat.exec (must be in ascii mode which is the case at this step).

Steffen

[1] http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.2/html/Installation_Guide/s1-s390-steps-vm.html
Comment 8 John Jarvis 2008-10-31 10:04:02 EDT
Regarding comment 6, we are a long ways off from the documentation stage in the schedule and we would need to wait for the feature to be approved.  If IBM has proposed text, please provide it so the docs person can review.
Comment 9 Gonzalo Muelas Serrano 2008-10-31 10:19:15 EDT
Regarding comment 8, since the feature is not yet approved, we do not know how Red Hat will finally implement it (in case it gets approved), and as a result, any text we provide could be wrong and confusing. 

To avoid confusion, we have provided the parts in documentation where we think it could be probable a change, but the developer implementing this feature together with Red Hat documentation editor, should most likely decide the text, and if you want IBM to review it, we will be happy to do it.
Comment 10 David Cantrell 2008-10-31 16:53:03 EDT
(In reply to comment #7)
> Hi David,
> 
> (In reply to comment #9)
> > ------- Comment From dcantrell@redhat.com 2008-10-30 17:11:54 EDT-------
> > Would adding this as 'redhat.exec' on the install media be sufficient:
> >
> > /* */
> > 'CL RDR'
> > 'PURGE RDR ALL'
> > 'SPOOL PUNCH * RDR'
> > 'PUNCH KERNEL IMG A (NOH'
> > 'PUNCH GENERIC PRM A (NOH'
> > 'PUNCH INITRD IMG A (NOH'
> > 'CH RDR ALL KEEP NOHOLD'
> > 'I 00C'
> >
> > I took that from the documentation, but changed the PARM line to reference
> > GENERIC PRM since that's the file we provide on the install media.
> 
> Please make sure that the used filenames match the instructions on how to get
> the files onto the CMS A disk using the CMS FTP client in the Installation
> Guide [1]. It all relies on the fact that all files referenced by redhat.exec
> have been downloaded by the user to the CMS A disk with the names mentioned in
> your documentation. Since the doc used to instruct a customer to download
> generic.prm as redhat.parm to the CMS A disk
> "get generic.prm redhat.parm (repl"
> I would stick to this in order to keep the existing renaming behavior,
> customers might already be familiar with.

Ahh, right.  I did not see the line that tells users to download generic.prm as redhat.parm using:

    get generic.prm redhat.parm (repl

How about this for the redhat.exec script:

    /* */
    'CL RDR'
    'PURGE RDR ALL'
    'SPOOL PUNCH * RDR'
    'PUNCH KERNEL IMG A (NOH'
    'PUNCH REDHAT PARM A (NOH'
    'PUNCH INITRD IMG A (NOH'
    'CH RDR ALL KEEP NOHOLD'
    'I 00C'

> As Gonzalo already mentioned, right after this FTP command (and before the
> quit), the user should be instructed to download the redhat.exec (must be in
> ascii mode which is the case at this step).

Right, definitely need to update the installer guide for this improvement.

jjarvis, is Bugzilla the correct way for us to track updates that need to made to the documentation?  If not, can we make sure that this is on the doc team's work list for the RHEL 6 install guide and then close out this bug?  I'm just going to commit this change to the rawhide anaconda, so it'll be in Fedora and present once we branch for rhel6 development.
Comment 11 John Jarvis 2008-10-31 17:05:30 EDT
Unfortunately while it isn't optimal, it is the only tool we have to track doc changes.  I am setting the release note flag to track this change needs to go into install guide.
Comment 12 IBM Bug Proxy 2008-11-03 10:30:37 EST
(In reply to comment #14)
> ------- Comment From dcantrell@redhat.com 2008-10-31 16:53:03 EDT-------
> How about this for the redhat.exec script:
>
> /* */
> 'CL RDR'
> 'PURGE RDR ALL'
> 'SPOOL PUNCH * RDR'
> 'PUNCH KERNEL IMG A (NOH'
> 'PUNCH REDHAT PARM A (NOH'
> 'PUNCH INITRD IMG A (NOH'
> 'CH RDR ALL KEEP NOHOLD'
> 'I 00C'

Looks good. Thanks.
Comment 13 David Cantrell 2008-11-03 14:31:53 EST
Marking this bug as MODIFIED.  I have added the sample exec script to the upstream anaconda code repository.  Anyone is free to check out the repo and see that the script is there:

    git clone git://git.fedorahosted.org/git/anaconda.git

The sample exec script is anaconda/bootdisk/s390x/redhat.exec

The things left to do for this request:

1) Update installation documentation to reflect the fact that we are providing redhat.exec in the images/ subdirectory on the install media for s390x.

2) Verify that RHEL 6 media contains images/redhat.exec with the contents listed in comment #12.
Comment 15 Ryan Lerch 2010-02-10 20:20:22 EST
does this one need to be documented as a known issue in 6.0beta1?
Comment 16 IBM Bug Proxy 2010-02-11 09:01:58 EST
------- Comment From MAIER@de.ibm.com 2010-02-11 08:57 EDT-------
(In reply to comment #19)
> does this one need to be documented as a known issue in 6.0beta1?

I'm not sure what you mean by documenting as issue. To the best of my knowledge there is no issue. This is an additional feature making the installation of RHEL6 under z/VM easier for users. In order for the users to even know about this new possibility, we requested to update the installation guide since that is the best fit for documenting this new feature. The install guide needs a major rework anyway because of all the changes that came in via upstream fedora. Gonzalo has already pointed out the install guide hits in LTC bug 48079 comment 10 / RH bug 462953 comment 6. In the following, I try to mark the additions/modifications by a + or - sign in the first column (unified diff like) based on fragments copied from http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.4/html/Installation_Guide/s1-s390-steps-vm.html, which seems the latest install guide version I could find. The proposed modifications are just a rough minimum set and may not be complete. You know your install guide better than we do.

FTP to the machine containing the boot images (kernel.img and initrd.img), log in, and execute the following commands (use the (repl option if you are overwriting existing kernel.img and initrd.img image files):
* cd /location/of/boot/images/
* locsite fix 80
* bin
* get kernel.img (repl
* get initrd.img (repl
* ascii
* get generic.prm redhat.parm (repl
+    * get redhat.exec (repl
* quit

...

-Example redhat.exec file:
+This is the content of the downloaded redhat.exec file:

...

-Create an executable script
+You may use the downloaded executable script redhat.exec
containing the commands necessary to IPL the kernel image and start the installation.
+After having IPLed CMS, enter "redhat" on the 3270 console and press the enter key,
+in order to execute this script.
-The following sample script is a typical initial start-up script:
-/* */ 'CL RDR' 'PURGE RDR ALL' 'SPOOL PUNCH * RDR' 'PUNCH KERNEL IMG A (NOH'
-'PUNCH REDHAT PARM A (NOH' 'PUNCH INITRD IMG A (NOH'
-'CH RDR ALL KEEP NOHOLD' 'IPL 00C CLEAR'

If for any reason an install guide update would not be possible at all, I guess the best place to mention this feature would be the release notes. In the best case with the release notes that ship with the install media DVD. In the worst case with the online release notes.
Independent of this feature all other existing methods to install RHEL6 are unaffected and remain working as is.
Comment 17 David Cantrell 2010-02-11 09:15:08 EST
(In reply to comment #15)
> does this one need to be documented as a known issue in 6.0beta1?    

If you look at comment #13, I mention that we should update the RHEL installation documentation to note that we are including the redhat.exec script.  Previous versions of RHEL had the install documentation for s390x telling users to create this file by hand, which does not make sense if we are including that file on the install media.
Comment 19 Denise Dumas 2010-04-08 12:36:48 EDT
This BZ has been cloned to Bug 580631 to track the Install Guide change. Removing Relnote flag here.
Comment 20 Jan Stodola 2010-06-21 07:33:41 EDT
Hello IBM,
were you able to test this feature with any recent snapshot of RHEL6.0?
I would like to make sure you accept implementation of this feature.
Thank you for your feedback.
Comment 21 IBM Bug Proxy 2010-06-24 03:31:18 EDT
------- Comment From mgrf@de.ibm.com 2010-06-24 03:23 EDT-------
This feature is verified on R6 snapshots
Set feature to "verified"  Thx.

Also the install guide is corrected - see
"chapter 16.1.1 Using the z/VM Reader"
Comment 22 Jan Stodola 2010-06-24 09:41:28 EDT
Thank you for feedback, moving to VERIFIED.
Comment 23 releng-rhel@redhat.com 2010-07-02 16:39:37 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.