Bug 462959 - [LTC 6.0 FEAT] 201667:eHEA support for 16GB memory page
[LTC 6.0 FEAT] 201667:eHEA support for 16GB memory page
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
ppc64 All
high Severity high
: alpha
: 6.0
Assigned To: Kevin W Monroe
Martin Jenner
: FutureFeature
Depends On:
Blocks: 356741 RHEL6Kernel2.6.27
  Show dependency treegraph
 
Reported: 2008-09-19 18:02 EDT by IBM Bug Proxy
Modified: 2009-09-23 18:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-23 18:21:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-19 18:02:14 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:21 EDT
1. Feature Overview:
Feature Id:	[201667]
a. Name of Feature:	eHEA support for 16GB memory page
b. Feature Description
To support the 16GB huge memory feature, the eHEA driver would require modifications and driver
update. Since eHEA is the driver for the integrated Ethernet on all p6 systems, this is an essential
update in order to enable the kernel feature on all Power systems.

2. Feature Details:
Sponsor:	PPC
Architectures:
ppc64

Arch Specificity: Purely Arch Specific Code
Affects Kernel Modules: Yes
Delivery Mechanism: Direct from community
Category:	Device Drivers and IO
Request Type:	Driver - Update Version
d. Upstream Acceptance:	Pending
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	kernel 2.6.27

3. Business Case
Enable the IO performance enhancement -16GB huge memory support - feature on Power6 systems.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Stephanie Glass, sglass@us.ibm.com, 512-838-9284

Technical contact(s):
Daisy Chang, daisyc@us.ibm.com
Jan-Bernd Themann, themann@de.ibm.com

IBM Manager:
Wendel Voigt, wvoigt@us.ibm.com
Comment 1 Bill Nottingham 2008-10-01 15:39:38 EDT
Is this code actually in upstream 2.6.27?
Comment 2 IBM Bug Proxy 2009-02-13 15:31:41 EST
The eHEA code for 16GB huge page support is in upstream kernel since 2.6.27. Therefore, for RHEL6, if the base kernel is anything higher than this level, there is no work needs to be done. I'm closing this feature as "already fixed."
Comment 3 Bill Nottingham 2009-02-13 16:49:06 EST
OK, setting to MODIFIED.

The feature requested has already been accepted into the upstream code base
planned for the next major release of Red Hat Enterprise Linux.

When the next milestone release of Red Hat Enterprise Linux 6 is available,
please verify that the feature requested is present and functioning as
desired.
Comment 4 Kevin W Monroe 2009-09-23 18:21:32 EDT
Closing - included in Red Hat Enterprise Linux 6.

Note You need to log in before you can comment on or make changes to this bug.