This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 462970 - adding sudorole object hangs the idm console
adding sudorole object hangs the idm console
Status: CLOSED DUPLICATE of bug 234948
Product: 389
Classification: Community
Component: UI - Dir Browser (Show other bugs)
1.1.1
All Linux
high Severity high
: ---
: ---
Assigned To: Rich Megginson
Chandrasekar Kannan
:
Depends On:
Blocks: 249650
  Show dependency treegraph
 
Reported: 2008-09-19 18:14 EDT by Jan-Frode Myklebust
Modified: 2015-01-04 18:34 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-05 12:45:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from fedora-idm-console -D 9 -f console.log (161.46 KB, text/plain)
2008-09-19 18:14 EDT, Jan-Frode Myklebust
no flags Details

  None (edit)
Description Jan-Frode Myklebust 2008-09-19 18:14:22 EDT
Created attachment 317260 [details]
output from fedora-idm-console -D 9 -f console.log

Description of problem:

When I try to add a sudorole object using idm-console, it just give a busy cursor and a java traceback in the terminal


Version-Release number of selected component (if applicable):

fedora-idm-console-1.1.1-1.fc6 running on RHEL5, x86_64. I get a similar crash when using centos-idm-console-1.0.0-17.el5.centos.4.

How reproducible:

100%

Steps to Reproduce:
1. Install centos-ds-8.0.0-1.4.el5.centos.4 on a server
2. add the following to /etc/dirsrv/slapd-$instance/schema/99user.ldif

attributeTypes: ( 1.3.6.1.4.1.15953.9.1.1 NAME 'sudoUser' DESC 'User(s) who may  run sudo' EQUALITY caseExactIA5Match SUBSTR caseExactIA5SubstringsMatch SYNTAX 1.3.6.1.4.1.1466.115.121.1.26 X-ORIGIN 'SUDO' )
attributeTypes: ( 1.3.6.1.4.1.15953.9.1.2 NAME 'sudoHost' DESC 'Host(s) who may run sudo' EQUALITY caseExactIA5Match SUBSTR caseExactIA5SubstringsMatch SYNTAX 1.3.6.1.4.1.1466.115.121.1.26 X-ORIGIN 'SUDO' )
attributeTypes: ( 1.3.6.1.4.1.15953.9.1.3 NAME 'sudoCommand' DESC 'Command(s) to be executed by sudo' EQUALITY caseExactIA5Match SYNTAX 1.3.6.1.4.1.1466.115.121.1.26 X-ORIGIN 'SUDO' )
attributeTypes: ( 1.3.6.1.4.1.15953.9.1.4 NAME 'sudoRunAs' DESC 'User(s) impersonated by sudo' EQUALITY caseExactIA5Match SYNTAX 1.3.6.1.4.1.1466.115.121.1.26 X-ORIGIN 'SUDO' )
attributeTypes: ( 1.3.6.1.4.1.15953.9.1.5 NAME 'sudoOption' DESC 'Options(s) followed by sudo' EQUALITY caseExactIA5Match SYNTAX 1.3.6.1.4.1.1466.115.121.1.26 X-ORIGIN 'SUDO' )
objectClasses: ( 1.3.6.1.4.1.15953.9.2.1 NAME 'sudoRole' SUP top STRUCTURAL DESC 'Sudoer Entries' MUST ( cn ) MAY ( sudoUser $ sudoHost $ sudoCommand $ sudoRunAs $ sudoOption $ description ) X-ORIGIN 'SUDO' )


3. Restart the dirsrv
4. Connect to the dirserver using idm console, and try adding a new "sudorole" object to the directory tree.
  
Actual results:

No object is added, and cursor spins busy forever.

Expected results:

New sudorole-object added to the directory. 


Additional info:

Adding sudorole-objects using "ldapadd" works fine.
Comment 1 Rich Megginson 2008-12-02 12:52:00 EST
This is probably a dup of https://bugzilla.redhat.com/show_bug.cgi?id=234948
Comment 2 Rich Megginson 2008-12-05 12:45:57 EST

*** This bug has been marked as a duplicate of bug 234948 ***

Note You need to log in before you can comment on or make changes to this bug.