Bug 462997 - Remove perl scripting in docbook-dtds spec file
Remove perl scripting in docbook-dtds spec file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: docbook-dtds (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Target FedoraMini/Mobility
  Show dependency treegraph
 
Reported: 2008-09-20 05:11 EDT by Peter Robinson
Modified: 2009-04-16 11:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-16 11:02:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2008-09-20 05:11:06 EDT
The spec file has a couple of lines of perl script which pulls in the entire perl dependency chain. It would be cool to remove this dependency so as not to require perl just to install the package.
Comment 1 Ondrej Vasik 2008-09-22 04:48:13 EDT
Thanks for suggestion. As opposite side of the problem - I have several requests to rewrite hardcoded catalog registrations to perl scripts - to prevent typos/forgotten registration of files. Docbook-dtds spec file is very fragile thing, now it seems to be broken in rawhide somehow even there is no change between F-9 and devel branch. So I have to think how to improve the spec file to increase stability/fix the issue. I'm ok with removal of perl dependency, we will see if it is possible/easy change.
Comment 2 Ondrej Vasik 2008-09-25 09:12:46 EDT
Added Fedora perl maintainer to CC...
Comment 3 Bug Zapper 2008-11-25 22:09:09 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Ondrej Vasik 2008-12-10 09:51:52 EST
Stepan promised to help with removing of perl scripting from docbook-dtds spec file few weeks ago, setting needinfo on him as reminder... ;)
Stepan, please send me the patch before commiting to CVS, I would like to check it first, tia.
Comment 5 Peter Robinson 2009-04-01 05:31:43 EDT
Any update on this. Would be brilliant to get it done for F11. At the moment if you remove perl this dep also ends up pulling yelp and hence a number of other packages such as some system-config stuff.
Comment 6 Ondrej Vasik 2009-04-01 05:51:11 EDT
Still waiting for Stepan's reaction ... afaik he has almost everything done, so it would be duplicate work to do it again myself. I'll try to get update from him ...
Comment 7 Stepan Kasal 2009-04-10 05:46:13 EDT
Fixed in 1.0-46, to appear in rawhide soon.  I apologize that I blocked this issue for so long.
If you want to see it in Fedora 10 Updates soon, follow the instructions in the subsequent comments, test the update and add a positive/negative comments according to whether it works or not.
Comment 8 Peter Robinson 2009-04-16 11:02:20 EDT
Thank you both very much. Verified fixed!

Note You need to log in before you can comment on or make changes to this bug.