Bug 4630 - Installer cant mount Mitsumi non-ide cdrom. prevents loading of supp.img from floppy
Installer cant mount Mitsumi non-ide cdrom. prevents loading of supp.img from...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-20 13:24 EDT by derekp
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-11 08:33:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description derekp 1999-08-20 13:24:40 EDT
See support incident 990820-0018. Installer fails to mount
non-ide mitsumi CDROM. Media can be mounted and viewed on
same machine using redhat 5.0. Phone Supports "solution" was
to download and put on floppy supp.img, boot.img and
modules.img. Problem is that supp.img isnt loaded til after
a successful mounting of cdrom occurs, thus the proposed
solution to "fix" the cd issue can not occur because I cant
get past a failed mount of the cd. This same machine
currently runs a 5.0 install that successfully auto probed
this CDROM. The 6.0 install fails auto and manual setup of
the CDROM. Some useful messages below:
the 6.0 install gets "mount(/tmp/mcd, /tmp/rhimage,
iso9660,  -1058209791, nil)"
uniform CDROM Driver Rev 2.54
mcd Mitsumi Double Speed @ port 0x300,11
cdrom open fail

When running 5.0 this same machine shows
mddriver .35
linux 2.0.32

Since I cant tell if this is a CD driver bug, an installer
bug or simply a missing file on the CD (I see no manifest of
what should be on the CD.) I assume the issue is in the
installer itself. Basically stuck cause I cant get to the
point of being able to load supp.img to see if it fixes the
ability to mount the cddrom. And since I cant get the CDrom
to load, I cant even get a shell into the system to probe
manually.
This is bad...
Comment 1 David Lawrence 1999-09-08 18:03:59 EDT
At the Boot: prompt when booting the first diskette type

boot: linux forcesupp

This will allow you to load the new supp.img diskette without
requireing the use of the cd-rom.
Comment 2 derekp 1999-09-20 20:52:59 EDT
Uh, your solution of typing linx forcesupp at the command line is not
sufficient. Perhaps had you tried it, you would have found, as I
reported earlier, that this simply puts an asteris in the checkbox on
the appropriate screen. IT DOES NOT cause the supp or modules disks
to be requested UNTIL AFTER THE CDROM IS MOUNTED!!!! GET IT!@!
YOU HAVE A SITUATION THAT PROHIBITS LOADING THE SUPP DISK UNTIL AFTER
THE CDROM IS MOUNTED<<<!!! AND IT WONT!

Pissed? Yes, just a little, you arent listening to your customer.
ITS BROKE AND YOUR 6.0 BOOT sequence PROHIBITS doing what you say it
is supposed to do. LOOK IN THE BOOT code, like I finally figured out
how to do. If I could rebuild it, I'd fix it myself. I cant.


------- Additional Comments From   09/21/99 11:26 -------
Sir, calm down.  The correct way to boot is "linux supp", not
"linux forcesupp".  Please try this.
Comment 3 derekp 1999-09-21 11:43:59 EDT
ok, I'll try calm. Its been too many phone calls and emails, and
no forward progress.
I have tried force supp, forcesupp, supp, and even some other text
that I found in the sources. They either are "unrecognized command"
OR they set an asteris in the screen prior to CDROM mounting.

THEN The cdrom mount is attempted. YOU NEVER get to the point
of prompting for the supp img disk if the CDROM fails mounting.
PLEASE go try it yourself. Your boot sequence is

	Boot floppy
	prompt for other flags (where you tell me to put linux supp)
	do lots of stuff
	put up pretty set of blue screens (aimed at guiding the clueless thru
the process)
	ask about the CD
	show pretty blue screen that says "force supp disk" And its
checked!) and prompt for CDROM info (mitsumi, etc...)

At this point, you all are convinced that something shall go looking
for a floppy that has supp.img on it.

It does not happen.

I can not convince anyone there of this fact

What DOES happen is this:
	System tries to mount CD (which is where my machine dies)
	(and what all "support" claims doesnt happen til "later")
	System now is unable to proceed further.

It cant mount the CDROM.
Regardless of wether the "force supp" checkbox is checked or not
IT WILL NOT look for it until AFTER a SUCCESSFUL MOUNT of the CDROM.

Sorry to persist, but this thing is broke. Either the mcd driver
is hosed, or the boot process is ordered incorrectly, or both.

I am led to believe that boot, supp and modules img floppies somehow
contain the cure for a broken mcd driver. Your boot process can not
proceed because it is ordered boot, cd, ??? (you know, the part that
is supposed to fix what it can never get to.)

Is it clear yet? Do I have to call someone on a phone again and spell
out slowly what is really happening?
Or should I just give up and go get Caldera instead?
Comment 4 derekp 1999-09-21 15:00:59 EDT
As said in direct mail, these commands to direct the use of the
supp disk do not work if the CD does not mount. And the CD does NOT
mount in this 6.0 dist. If there are indeed any fixes on the supp.img
disk, that are supposed to repair a non-mounting non-ide mitsumi
drive, one can not get to them because the boot process prohibits it.

Sit down in front of a machine, disconnect the CD drive, boot linux
with linux supp and see for yourself. It will not work.
Comment 5 derekp 1999-10-13 13:53:59 EDT
If you're not going to offer me a fix for this bug,
tell me how to get a functional version, or get my money back.
The place I purchased it from specifically stated no-refund on
your product.

Note You need to log in before you can comment on or make changes to this bug.