Bug 463022 - gnome-applet-sshmenu has broken deps
gnome-applet-sshmenu has broken deps
Status: CLOSED CANTFIX
Product: Fedora EPEL
Classification: Fedora
Component: sshmenu (Show other bugs)
el5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
PackageBranch
:
Depends On: 478633
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-20 16:47 EDT by Kevin Fenzi
Modified: 2010-05-04 05:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-04 05:13:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2008-09-20 16:47:32 EDT
package: gnome-applet-sshmenu - 3.15-5.el5.noarch from epel-testing
  unresolved deps: 
     ruby(panelapplet2)
     ruby(gconf2)

Either branch and make available those 2 packages, or disable whatever functionality they require.
Comment 1 Kevin Fenzi 2008-09-20 18:36:45 EDT
Additionally: 

package: sshmenu - 3.15-5.el5.noarch from epel-testing
  unresolved deps: 
     ruby(gtk2)

Looks like you need ruby-gtk2 as well.
Comment 2 Matthias Saou 2009-01-02 10:14:22 EST
Note that all of these come from the same ruby-gnome2 source package. I've created a bugzilla entry to ask for its EL-5 branch to be created, it's bug #478633.
Comment 3 Kevin Fenzi 2009-06-21 21:19:17 EDT
It seems that ruby-gnome2 has been branched for epel5, but I don't see that it's ever been built. 

Matthias? Can you build it and then I think we can close this...
Comment 4 Matthias Saou 2009-06-22 04:18:58 EDT
IIRC ruby-gnome2 had further build requirement problems on EL5, I should have written down the exact problems here at the time. I'll try to look into it again ASAP unless someone else beats me to it (feel free).
Comment 5 Matthias Saou 2009-12-08 13:40:08 EST
I've dug again :
http://koji.fedoraproject.org/koji/getfile?taskID=1863185&name=root.log

Current issues to get this fixed are :
No Package Found for gtkglext-devel
No Package Found for ruby-cairo-devel

These don't look trivial to fix, so what I'm considering is disabling sshmenu's gnome-applet-sshmenu sub-package on EL-5.
Comment 6 Matthias Saou 2009-12-08 13:58:52 EST
I was wrong in the last comment, as the main sshmenu package requires ruby-gtk2, provided by the source package ruby-gnome2, which is the one requiring the missing packages detailed above to build...

The easiest will be to get the sshmenu builds removed from EL-5 for now.
Comment 7 Matthias Saou 2010-05-04 05:13:38 EDT
The package was removed from EPEL. This is unfortunate, but the best option. I'll make sure to have it branched for EL6, though.

Note You need to log in before you can comment on or make changes to this bug.