Bug 463022 - gnome-applet-sshmenu has broken deps
Summary: gnome-applet-sshmenu has broken deps
Status: CLOSED CANTFIX
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: sshmenu
Version: el5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: PackageBranch
Keywords:
Depends On: 478633
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-09-20 20:47 UTC by Kevin Fenzi
Modified: 2010-05-04 09:13 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-05-04 09:13:38 UTC


Attachments (Terms of Use)

Description Kevin Fenzi 2008-09-20 20:47:32 UTC
package: gnome-applet-sshmenu - 3.15-5.el5.noarch from epel-testing
  unresolved deps: 
     ruby(panelapplet2)
     ruby(gconf2)

Either branch and make available those 2 packages, or disable whatever functionality they require.

Comment 1 Kevin Fenzi 2008-09-20 22:36:45 UTC
Additionally: 

package: sshmenu - 3.15-5.el5.noarch from epel-testing
  unresolved deps: 
     ruby(gtk2)

Looks like you need ruby-gtk2 as well.

Comment 2 Matthias Saou 2009-01-02 15:14:22 UTC
Note that all of these come from the same ruby-gnome2 source package. I've created a bugzilla entry to ask for its EL-5 branch to be created, it's bug #478633.

Comment 3 Kevin Fenzi 2009-06-22 01:19:17 UTC
It seems that ruby-gnome2 has been branched for epel5, but I don't see that it's ever been built. 

Matthias? Can you build it and then I think we can close this...

Comment 4 Matthias Saou 2009-06-22 08:18:58 UTC
IIRC ruby-gnome2 had further build requirement problems on EL5, I should have written down the exact problems here at the time. I'll try to look into it again ASAP unless someone else beats me to it (feel free).

Comment 5 Matthias Saou 2009-12-08 18:40:08 UTC
I've dug again :
http://koji.fedoraproject.org/koji/getfile?taskID=1863185&name=root.log

Current issues to get this fixed are :
No Package Found for gtkglext-devel
No Package Found for ruby-cairo-devel

These don't look trivial to fix, so what I'm considering is disabling sshmenu's gnome-applet-sshmenu sub-package on EL-5.

Comment 6 Matthias Saou 2009-12-08 18:58:52 UTC
I was wrong in the last comment, as the main sshmenu package requires ruby-gtk2, provided by the source package ruby-gnome2, which is the one requiring the missing packages detailed above to build...

The easiest will be to get the sshmenu builds removed from EL-5 for now.

Comment 7 Matthias Saou 2010-05-04 09:13:38 UTC
The package was removed from EPEL. This is unfortunate, but the best option. I'll make sure to have it branched for EL6, though.


Note You need to log in before you can comment on or make changes to this bug.