This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 463023 - scrolling in gnome-terminal causes flickering of the whole screen
scrolling in gnome-terminal causes flickering of the whole screen
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-20 17:07 EDT by Michal Schmidt
Modified: 2010-04-20 11:31 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-07 11:28:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log (39.06 KB, text/plain)
2008-09-20 17:07 EDT, Michal Schmidt
no flags Details
rhl6856 xorg.0.log (68.34 KB, application/octet-stream)
2010-04-20 11:27 EDT, Ryan H. Lewis (rhl)
no flags Details
rhl6856 xorg.conf (2.80 KB, application/octet-stream)
2010-04-20 11:30 EDT, Ryan H. Lewis (rhl)
no flags Details

  None (edit)
Description Michal Schmidt 2008-09-20 17:07:46 EDT
Created attachment 317292 [details]
Xorg.0.log

Description of problem:
Scrolling text in gnome-terminal causes annoying flickering of the whole desktop. It's like if the whole picture moves a few pixels down, some additional black stripes appear randomly and then the screen is redrawn correctly. All of this happens in a small fraction of a second.


Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.9.0-14.fc10.x86_64


How reproducible:
I can reproduce it at will.

Steps to Reproduce:
1. Run gnome-terminal
2. vim some_long_text_file
3. hold the down or up arrow to scroll the text
  
Actual results:
About once every second the visible flicker occurs.

Expected results:
Scrolling in gnome-terminal should not have any effect outside of the window.

Additional info:

I have a Toshiba laptop with an ATI chip:
01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RS690M [Radeon X1200 Series] [1002:791f]

I do not have an xorg.conf, I let X autodetect everything.

While experimenting with this bug I discovered that it only happens with (the default) EXA acceleration method. Adding a xorg.conf with 'Option "AccelMethod" "XAA"' makes the bug go away.
Comment 1 Matěj Cepl 2008-09-22 10:53:06 EDT
Behdad, any thoughts? Or is it just pure our mess?
Comment 2 Behdad Esfahbod 2008-09-22 12:16:41 EDT
Sounds like X issues.  Very unlikely to be g-t.
Comment 3 Michal Schmidt 2008-09-23 08:27:56 EDT
I downloaded and installed an older version of the driver from Koji: xorg-x11-drv-ati-6.8.0-19.fc10.x86_64

The older version defaults to XAA, but when forced to use EXA with 'Option "AccelMethod" "EXA"', the same flickering happens.
Comment 4 Matěj Cepl 2008-09-24 18:20:23 EDT
And what about other way around? Using the latest -ati driver and put "AccelMethod" "XAA" into xorg.conf?
Comment 5 Michal Schmidt 2008-09-25 04:17:17 EDT
Matej,
I wrote that in the original report. With the current driver version 'Option "AccelMethod""XAA"' makes the bug go away.

So no matter whether I use the old or the new driver version, EXA always flickers, XAA never does.
Comment 6 Michal Schmidt 2008-10-13 10:04:08 EDT
Still reproducible with xorg-x11-drv-ati-6.9.0-25.fc10.x86_64.

The flickering effect is best observed when cpufreq is set to a lower frequency (in my case 800 MHz). With the CPU running at full speed (2 GHz), the flickering is much less visible.

Also I noticed the flickering happens with other applications besides gnome-terminal. With gnome-terminal it's just the easiest to reproduce.
Comment 7 Jan Martinek 2008-10-28 11:00:18 EDT
On my computer (MB Asus M2A-VM with RS690), the flickering is visible only when the display is rotated to portrait mode using "xrandr -o left" AND the system is resumed from sleep mode.

After fresh boot, the flickering is barely visible. But after suspend/resume it becomes clearly noticeable and annoying even with CPU running at full 2.5 GHz. 

kernel: 2.6.27.4-51.fc10.x86_64
driver: xorg-x11-drv-ati-6.9.0-31.fc10.x86_64

Dmesg after wakeup shows this:
[drm] Loading RS690/RS740 Microcode
[drm] Num pipes: 1
Comment 8 Jan Martinek 2008-10-28 11:41:38 EDT
I just noticed that once the flickering starts (after resuming the computer from suspend), killing/restarting the X server does not help. I must reboot the machine to get rid of the flickering.
Comment 9 Bug Zapper 2008-11-25 22:09:29 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Jóhann B. Guðmundsson 2008-12-01 06:35:49 EST
There have been bunch of bug fixes

Could you retest with the latest kernel 
( -132 at the time of this writing )

You can get the latest kernel build here
http://koji.fedoraproject.org/koji/buildinfo?buildID=72270 

And with the latest xorg-x11-drv-ati. 
( -60 at the time of this writing )

You can get the latest xorg-x11-drv-ati build here
http://koji.fedoraproject.org/koji/packageinfo?packageID=95

And report back if it either improves or fixes this issue..

Thanks.
Comment 11 Michal Schmidt 2008-12-01 10:55:00 EST
I have kernel kernel-2.6.27.7-133 (built myself from Fedora CVS) and xorg-x11-drv-ati-6.9.0-60. The bug is still there.
Comment 12 Michal Schmidt 2008-12-01 10:59:42 EST
Unlike Jan, I do not need to rotate the screen or suspend/resume to see the flickering. I am seeing the bug right after a fresh boot and without rotation.
Comment 13 Jóhann B. Guðmundsson 2008-12-02 03:27:43 EST
Hum.. 

Which X server build are you using?

Update to the latest in koji, Let's see if that does some wonders..

http://koji.fedoraproject.org/koji/buildinfo?buildID=69927
Comment 14 Michal Schmidt 2008-12-02 04:47:25 EST
xorg-x11-server-1.5.3-5.fc10 (currently the latest) is the one in F10 GA, so I'm already running that one.
I have upgraded to xorg-x11-drv-ati-6.9.0-61.fc10 and kernel-2.6.27.7-134.fc10 and the bug is still present.
Comment 15 Michal Schmidt 2009-01-28 11:00:31 EST
Still trivially reproducible with:
xorg-x11-drv-ati-6.10.0-1.fc10.x86_64
xorg-x11-server-Xorg-1.5.3-6.fc10.x86_64
kernel-2.6.27.12-170.2.5.fc10.x86_64
Comment 16 Michal Schmidt 2009-03-26 12:47:09 EDT
I upgraded the laptop to Rawhide. I can still reproduce the flickering as described in my original report.

xorg-x11-drv-ati-6.12.0-2.fc11.x86_64
xorg-x11-server-Xorg-1.6.0-15.fc11.x86_64
kernel-2.6.29-0.279.rc8.git6.fc11.x86_64
Comment 17 Sam Tygier 2009-06-15 11:56:29 EDT
seeing the same thing on a toshiba with
01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]
on fedora11

i have tried setting accelmethod to xaa, but i still get exa, and the flickering.
Comment 18 Michal Schmidt 2009-07-03 08:39:59 EDT
The flickering is still reproducible with current Fedora 11, both with or without KMS.

There's a bit of good news: current upstream xf86-video-ati from git master is not affected. Here's a scratch build for testing:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1452541
It has serious issues with modesetting enabled, but works fine with "nomodeset".
Comment 19 Eduardo Habkost 2009-08-08 19:48:25 EDT
Also reproduced here, on a Thinkpad T60 running Fedora 11, with modesetting disabled.

01:00.0 VGA compatible controller [0300]: ATI Technologies Inc M52 [Mobility Radeon X1300] [1002:7149]


I am running xorg-x11-drv-ati-6.12.2-14.fc11.i586.

The problem was gone when using 'Option "AccelMethod" "XAA"'.
Comment 20 Michal Schmidt 2009-09-07 11:28:14 EDT
I cannot reproduce this in Rawhide, with or without KMS.
With KMS the scrolling is slow and far from smooth, but no flickering happens.

kernel-2.6.31-0.204.rc9.fc12.x86_64
xorg-x11-drv-ati-6.13.0-0.2.20090821gitb1b77a4d6.fc12.x86_64
xorg-x11-server-Xorg-1.6.99-45.20090903.fc12.x86_64
Comment 21 Ryan H. Lewis (rhl) 2010-03-31 18:59:34 EDT
I'm running F12 with fluxbox as my desktop manager and having the same problem when using gnome-terminal. I'm on all the latest updates from yum update 

Here is all the relevant package info NOTE-- I'm not using an ATI card at all:

lspci -v | fpaste
http://fpaste.org/Mjj0/

yum info vim* | fpaste
http://fpaste.org/KZOU/

yum info xorg* | grep Name | fpaste
http://fpaste.org/pzYF/

yum info xorg* | fpaste
http://fpaste.org/evVQ/

I fix the issue by closing all my gnome-terminals and the problem goes away immediately.
Comment 22 Michal Schmidt 2010-04-01 08:53:53 EDT
Ryan,
issues like these are almost certainly hardware-specific and this BZ was about ATI, so please file a new bug and attach dmesg, /var/log/Xorg.0.log, /etc/X11/xorg.conf (if you use one) to it (directly to BZ, not via fpaste). Thank you.
Comment 23 Ryan H. Lewis (rhl) 2010-04-20 11:27:41 EDT
Created attachment 407847 [details]
rhl6856 xorg.0.log
Comment 24 Ryan H. Lewis (rhl) 2010-04-20 11:30:03 EDT
Created attachment 407848 [details]
rhl6856 xorg.conf
Comment 25 Ryan H. Lewis (rhl) 2010-04-20 11:31:01 EDT
alright done, 

dmesg | fpaste
Uploading (98.7K)...
http://fpaste.org/wcS9/


it doesn't seem like any of these things are producing relevant error text as the error is occuring.

Note You need to log in before you can comment on or make changes to this bug.