Bug 463036 - LiberationSans-Bold 'u' and 'W' blurred in smaller sizes.
LiberationSans-Bold 'u' and 'W' blurred in smaller sizes.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
12
All Windows
medium Severity medium
: ---
: ---
Assigned To: Caius Chance
Fedora Extras Quality Assurance
: i18n, Reopened, Triaged
Depends On: 503430
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-20 20:13 EDT by saurabh
Modified: 2010-05-05 23:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-05 23:21:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
(Same as original attachment which possibly didnt go in) (48.55 KB, image/jpeg)
2008-09-20 20:16 EDT, saurabh
no flags Details
Screenshot for reference (13.00 KB, image/png)
2008-12-17 11:33 EST, Felix Kaechele
no flags Details
bold font at 11px in 1.04.93 (103.46 KB, image/png)
2009-07-04 14:14 EDT, saurabh
no flags Details
With 1.05.1.20090706 (6.08 KB, image/png)
2009-07-18 10:28 EDT, saurabh
no flags Details

  None (edit)
Description saurabh 2008-09-20 20:13:00 EDT
Description of problem:
n/t, see attached image.
I have not tested this on architectures other than windows xp. 

Version-Release number of selected component (if applicable):
Latest 1.0.4 and 1.0.4.91-devel

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 saurabh 2008-09-20 20:16:31 EDT
Created attachment 317296 [details]
(Same as original attachment which possibly didnt go in)
Comment 2 Caius Chance 2008-09-29 20:48:45 EDT
Is it using bolded LiberationSans-Regular.ttf, or normal LiberationSans-Bold.ttf ?
Comment 3 saurabh 2008-10-01 17:28:23 EDT
I'm almost certain it's the -Bold.ttf. (It's whatever font firefox picks up). I saw it in the Windows font viewer and other font viewers and it looks similarly blurred. I also discovered that it's apparent (to my untrained eye at least) only at <= 12 pt, and it gets progressively worse at lower pt - it's really bad at 9 pt. Also discovered Mono Bold has a similar problem. Serif doesnt have it afaict.
Comment 5 Bug Zapper 2008-11-25 22:09:36 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Fedora Update System 2008-12-06 23:17:03 EST
liberation-fonts-1.04.92-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update liberation-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-10773
Comment 7 Fedora Update System 2008-12-09 23:38:59 EST
liberation-fonts-1.04.92-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Felix Kaechele 2008-12-17 11:32:41 EST
Could this please be reopened?

I started having this issue after the I installed the update mentioned by the Bodhi bot.

I attached a screenshot for reference.
Comment 9 Felix Kaechele 2008-12-17 11:33:25 EST
Created attachment 327266 [details]
Screenshot for reference
Comment 10 saurabh 2009-07-04 14:14:34 EDT
Created attachment 350501 [details]
bold font at 11px in 1.04.93
Comment 11 saurabh 2009-07-04 14:17:24 EDT
My attachment (I dont know why one cant attach as one comments) shows that the problem still exists with 1.04.93, see the horrible u and w rendering at the photo caption comment and the section title. I've accordingly reopened the bug.
Comment 12 saurabh 2009-07-04 14:19:50 EDT
Sorry for the spamming, but the y and v are bad too, and possibly others (need better eyes than mine).
Comment 13 Caius Chance 2009-07-06 00:27:26 EDT
Thank you very much for providing info.

Please re-test w/ 1.05:

https://fedorahosted.org/releases/l/i/liberation-fonts/liberation-fonts-ttf-1.05.1.20090630.tar.gz
Comment 14 Caius Chance 2009-07-07 21:07:43 EDT
Needs bug #503430 to get precondition correct, with traditional kern table conserved.
Comment 15 saurabh 2009-07-18 10:27:10 EDT
I tried it with 1.05.1.20090706, and the u is much better but not perfect (see the word Tour in my attachment to follow, the u is closer to r than o). You can see other imperfections;
- w, y are quite blurry
- Just like u, t's kerning (if that's the right word) is off (see 'other').
- I can totally tell there are other problems but I cant figure out what they are, need a font designer to really identify and fix them.
Comment 16 saurabh 2009-07-18 10:28:01 EDT
Created attachment 354254 [details]
With 1.05.1.20090706
Comment 17 Caius Chance 2009-07-19 19:30:46 EDT
Thanks for test results. I am currently fixing the kern table issue and hope such fix would resolve this problem at once. I guess this bug was related to missing kern table, too.
Comment 18 Bug Zapper 2009-11-18 03:24:46 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 19 Jens Petersen 2009-12-09 02:20:21 EST
Assuming this is still a problem?  So moving to f12.
Comment 20 Caius Chance 2010-05-05 23:21:22 EDT
The blurriness have been worked on with cleaning up in those glyphs and applied auto-instruct for hinting. I am sorry that will not work on the hinting manually for short term. The archive and RPMs are as follows:

http://koji.fedoraproject.org/koji/buildinfo?buildID=171721
http://liberation-fonts.googlecode.com/files/liberation-fonts-ttf-1.05.3.20100506.zip

For the kerning issues, are they reproducible on version 1.02? If so, please file a separate ticket at: http://code.google.com/p/liberation-fonts/issues/entry . If not, I will still fix that but I don't guarantee if this font could have same metrics as Arial in Bold style.

Note You need to log in before you can comment on or make changes to this bug.