Bug 463078 - No 3D with intel graphics; glxgears segfaults
No 3D with intel graphics; glxgears segfaults
Status: CLOSED DUPLICATE of bug 450543
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-21 08:59 EDT by Tomasz Torcz
Modified: 2018-04-11 10:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-21 07:51:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X logfile (33.75 KB, text/plain)
2008-09-21 09:01 EDT, Tomasz Torcz
no flags Details

  None (edit)
Description Tomasz Torcz 2008-09-21 08:59:39 EDT
Description of problem:
I've just installed Fedora 10 Alpha and upgraded to latest rawhide (prebeta). glxgears segfaults when run. I can't run compiz also.

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.4.2-8.fc10.i386

How reproducible:
Always

Steps to Reproduce:
1. run glxgears
  
Actual results:
% glxgears  
zsh: segmentation fault  glxgears

# dmesg | tail
glxgears[15581]: segfault at ffffffff ip 009f1a70 sp bfc9ae70 error 6 in libdricore.so[8c5000+1d7000]


Program received signal SIGSEGV, Segmentation fault.
0x009f1a70 in ?? () from /usr/lib/dri/libdricore.so
(gdb) bt
#0  0x009f1a70 in ?? () from /usr/lib/dri/libdricore.so
#1  0x009f38a0 in x86_push () from /usr/lib/dri/libdricore.so
#2  0x00992ffd in _tnl_generate_sse_emit () from /usr/lib/dri/libdricore.so
#3  0x009923bf in ?? () from /usr/lib/dri/libdricore.so
#4  0x009925af in _tnl_build_vertices () from /usr/lib/dri/libdricore.so
#5  0x009866d0 in ?? () from /usr/lib/dri/libdricore.so
#6  0x0097f65d in _tnl_run_pipeline () from /usr/lib/dri/libdricore.so
#7  0x00150da3 in ?? () from /usr/lib/dri/i915_dri.so
#8  0x009800a8 in _tnl_draw_prims () from /usr/lib/dri/libdricore.so
#9  0x0097eda9 in vbo_save_playback_vertex_list () from /usr/lib/dri/libdricore.so
#10 0x00908e97 in ?? () from /usr/lib/dri/libdricore.so
#11 0x0090b322 in _mesa_CallList () from /usr/lib/dri/libdricore.so
#12 0x00969e54 in ?? () from /usr/lib/dri/libdricore.so
#13 0x0804994f in XParseGeometry ()
#14 0x0804a3ce in XParseGeometry ()
#15 0x002b26e5 in __libc_start_main () from /lib/libc.so.6
#16 0x08048ee1 in XParseGeometry ()


Expected results:
Windows with spinning wheels.

Additional info:
Hardware is ThinkPad z61t with i945.
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
Comment 1 Tomasz Torcz 2008-09-21 09:01:47 EDT
Created attachment 317321 [details]
X logfile
Comment 2 Matěj Cepl 2008-09-22 10:50:29 EDT
Please install mesa-debuginfo and recreate the backtrace for us. Thank you.
Comment 3 Tomasz Torcz 2008-09-22 16:15:49 EDT
(gdb) run
Starting program: /usr/bin/glxgears 
[Thread debugging using libthread_db enabled]
[New Thread 0xb7fe66c0 (LWP 8493)]

Program received signal SIGSEGV, Segmentation fault.
0x009f1a70 in emit_1ub (p=<value optimized out>, b0=<value optimized out>) at x86/rtasm/x86sse.c:64
64	   *csr++ = b0;
(gdb) bt
#0  0x009f1a70 in emit_1ub (p=<value optimized out>, b0=<value optimized out>) at x86/rtasm/x86sse.c:64
#1  0x009f38a0 in x86_push (p=0xbfffea64, reg={file = 0, idx = 5, mod = 3, disp = 0}) at x86/rtasm/x86sse.c:313
#2  0x00992ffd in build_vertex_emit () at tnl/t_vertex_sse.c:359
#3  _tnl_generate_sse_emit (ctx=0x805e668) at tnl/t_vertex_sse.c:661
#4  0x009923bf in choose_emit_func (ctx=0x805e668, count=162, dest=0xb5609020 "") at tnl/t_vertex.c:136
#5  0x009925af in _tnl_build_vertices (ctx=0x805e668, start=0, end=162, newinputs=4294967295) at tnl/t_vertex.c:418
#6  0x009866d0 in run_render (ctx=0x805e668, stage=0x80a148c) at tnl/t_vb_render.c:290
#7  0x0097f65d in _tnl_run_pipeline (ctx=0x805e668) at tnl/t_pipeline.c:158
#8  0x00150da3 in intelRunPipeline (ctx=0x805e668) at intel_tris.c:986
#9  0x009800a8 in _tnl_draw_prims (ctx=0x805e668, arrays=0x8090098, prim=0x8333b50, nr_prims=2, ib=0x0, min_index=0, 
    max_index=161) at tnl/t_draw.c:402
#10 0x0097eda9 in vbo_save_playback_vertex_list (ctx=0x805e668, data=0x8333784) at vbo/vbo_save_draw.c:232
#11 0x00908e97 in execute_list (ctx=0x805e668, list=<value optimized out>) at main/dlist.c:5757
#12 0x0090b322 in _mesa_CallList (list=1) at main/dlist.c:6841
#13 0x00969e54 in neutral_CallList (i=1) at main/vtxfmt_tmp.h:298
#14 0x0804994f in draw () at glxgears.c:260
#15 0x0804a3ce in draw_gears () at glxgears.c:312
#16 draw_frame () at glxgears.c:337
#17 event_loop () at glxgears.c:578
#18 main (argc=1, argv=0xbffff444) at glxgears.c:657


Here you are. Please tell me if I can provide more info.
BTW, my CPU is Core Duo (not Core 2 Duo).
Comment 4 Tomasz Torcz 2008-10-07 12:27:56 EDT
Aby progress or more information I can provide? I *really* miss compiz and quake3 :)
Comment 5 Tomasz Torcz 2008-10-17 06:54:47 EDT
There was update of selinux-policy packages fixing some labeling issues with libGL. This update is slightly broken (#467217) but was enough hint for me. After "setenforce 0" glxgears works! Compiz do not work, but I defer investigation after selinux-policy is fixed (running desktop system without SELinux gives me uneasy feeling).
Comment 6 Matěj Cepl 2008-10-17 16:18:29 EDT
Waiting for that information then.
Comment 7 Tomasz Torcz 2008-10-21 07:51:06 EDT

*** This bug has been marked as a duplicate of bug 450543 ***

Note You need to log in before you can comment on or make changes to this bug.