Bug 463100 - Installation problem with gcc-java and rpmbuild --rebuild pdftk*.src.rpm
Installation problem with gcc-java and rpmbuild --rebuild pdftk*.src.rpm
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpmrebuild (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-21 13:52 EDT by Martin Kuhnke
Modified: 2014-01-21 18:06 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-03 13:15:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logfile for bug (2.87 KB, patch)
2008-09-21 13:54 EDT, Martin Kuhnke
no flags Details | Diff
Logfile for rpmbuild (965 bytes, patch)
2008-09-27 09:15 EDT, Martin Kuhnke
no flags Details | Diff

  None (edit)
Description Martin Kuhnke 2008-09-21 13:52:58 EDT
Description of problem:
For rpmbuild --rebuild pdftk-1.12-0.src.rpm the packages libgcj-devel and gcc-java are needed. It is not possible to install the compiler component and libary.


Version-Release number of selected component (if applicable):
gcc-java-4.1.2-33.i386
libgcj-devel-4.1.2-33.i386

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Martin Kuhnke 2008-09-21 13:54:27 EDT
Created attachment 317325 [details]
Logfile for bug
Comment 2 Martin Kuhnke 2008-09-25 12:03:18 EDT
I checked further that the package libjasper is also not available in the fedora repository. It provides some codec (http://www.ece.uvic.ca/~mdadams/jasper/) for pdftoolkit (http://www.accesspdf.com/article.php/20041129180128366).
Comment 3 Martin Kuhnke 2008-09-26 10:21:00 EDT
I've installed libgcj-devel package without an error. The "java-plugin" gcc-java for the C-compiler causes the error.
Further I've installed packages
jasper-1.900.1-7.fc8.i386
jasper-libs-1.900.1-7.fc8.i386
Perhaps there are other dependencies for fc8 to build pdftk?
Comment 4 James Antill 2008-09-26 10:52:29 EDT
Why is this BZ against yum?
Comment 5 Martin Kuhnke 2008-09-27 04:57:31 EDT
This BZ was primary against gcc.
Comment 6 Martin Kuhnke 2008-09-27 09:15:16 EDT
Created attachment 317865 [details]
Logfile for rpmbuild
Comment 7 Martin Kuhnke 2008-09-27 09:20:48 EDT
That's really strange. I'm able to install the gcc-java package now. However, the rpmbuild -rebuild pdftk*.src.rpm gives an error. I've no gpgkey for source code package. Is this still a bug?
Comment 8 Martin Kuhnke 2008-10-03 08:56:50 EDT
Since the dependencies regarding gcc-java seem to be resolved by an eclipse package or something like that, I've change the issue to rpmrebuild. Maybe Fedora and RedHat are not completely compatible.
Comment 9 Anderson Silva 2008-10-03 10:53:22 EDT
FYI, 

I am pretty sure this isn't related to rpmrebuild, which is a different tool than rpmbuild --rebuild

AS
Comment 10 Panu Matilainen 2008-10-03 13:15:08 EDT
This is not a bug in rpmrebuild, rpmbuild, yum or gcc either. Looking at the log from comment #6:

+ cd /usr/src/redhat/BUILD
+ cd pdftk-1.12
+ '%{suse_update_config' '-fl}'
/var/tmp/rpm-tmp.26219: line 23: fg: no job control
error: Bad exit status from /var/tmp/rpm-tmp.26219 (%build)

You can't take a package from one distribution (Suse in this case) and expect it to build just like that on something else (Fedora in this case). In ideal world this would work but as it is, every vendor uses their own set of macros to help building packages. Those macros are usually vital part of the build process and if they're missing things are likely to kaboom sooner or later, most likely sooner. Which is exactly what the problem here seems to be.

Note You need to log in before you can comment on or make changes to this bug.