This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 463106 - Forced repair console for disks mounted from /dev/disk/by-label/XXX
Forced repair console for disks mounted from /dev/disk/by-label/XXX
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-09-21 16:54 EDT by Saikat Guha
Modified: 2009-01-20 06:36 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 06:36:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Saikat Guha 2008-09-21 16:54:18 EDT
Description of problem:

I have a stack of external USB disks that have an fstab entry of the form /dev/disk/by-label/XXX (this is needed to mount the disks to the correct location even if they get different /dev/sdX names during bootup).

However, the normal bootup process aborts and dumps me into a repair console. No problems are detected by fdisk. Removing the entries from fstab allows normal bootup to proceed without a hitch. Manually mounting the disks after bootup works fine without any dmesg spew. 

Are the /dev/disk/by-label/XXX symlinks created by udev (that is not present in the initrd image)? I assume the disk checking script fails to find the USB disks by that name, which it considers a fatal errors and aborts.

How reproducible:
Always

Steps to Reproduce:
1. Use an external USB disk with a fs label.
2. Mount the disk using that label from /dev/disk/by-label/XXX
3. Reboot
  
Actual results:
Repair console

Expected results:
System boots up

Additional info:
The USB disks have one partition formatted as ext3 with the appropriate descriptor in the partition table. They are labled using e2label.
Comment 1 Bill Nottingham 2008-09-23 14:34:15 EDT
Yes, they're created by udev. But they should still be created by the time fsck runs.
Comment 2 Jeroen van Meeuwen 2008-09-24 05:38:29 EDT
I can try and reproduce this. Give me a day or two.
Comment 3 Kay Sievers 2008-11-02 20:24:11 EST
You should be able to add "nofail" to the fstab options, the handle the case the disk is not there, and to continue without failing.

You would have to mount them by hand later though, because the automounting usually excludes stuff mentioned in fstab.
Comment 4 Bug Zapper 2008-11-25 22:10:16 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.