Bug 463118 - Regression: X presents blank screen
Regression: X presents blank screen
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On: 469502
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-21 18:18 EDT by W. Michael Petullo
Modified: 2009-10-22 08:47 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-13 18:30:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log of X starting -- result is blank screen, changing virtual terminals does not work (31.12 KB, text/plain)
2008-09-21 18:27 EDT, W. Michael Petullo
no flags Details
/var/log/messages with the kernel Oops (36.73 KB, text/plain)
2008-09-30 10:45 EDT, Benjamin Jacobs
no flags Details

  None (edit)
Description W. Michael Petullo 2008-09-21 18:18:54 EDT
Description of problem:
X11 is broken for me on a PowerPC G4 iBook in recent versions of Rawhide. When I boot into X mode, my screen goes black. Switching to another (text) virtual console does not work -- i.e., the screen stays black. My graphics card is identified as an ATI Technologies Inc M9+ 5C63 [Radeon Mobility 9200 (AGP)] (rev 01). I have removed my xorg.conf, but things were working fine without it until the update. 

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.5.0-6.fc10.ppc

How reproducible:
Every time

Steps to Reproduce:
Boot into X mode.
  
Actual results:
Blank screen, as noted above.

Expected results:
X should start.

Additional info:
The update that caused this regression happened sometime after bug #460721 was fixed.
Comment 1 W. Michael Petullo 2008-09-21 18:27:58 EDT
Created attachment 317330 [details]
Log of X starting -- result is blank screen, changing virtual terminals does not work
Comment 2 Benjamin Jacobs 2008-09-30 10:42:27 EDT
Same hardware (iBook G4/ati m9+ m5c63), same problem. However, I'm able to boot in runlevel 3 but the kernel drm/radeon driver is oopsing. So X won't start and I've the black screen in rc5. See the attached log.

Also, with those kernels, plymouth(?) displays some bright white kernel lines and then displays three mixed progress lines (blue, light blue and white) at the bottom of the screen with some more garbage. Sorry no camera but, thrust me, it doesn't look good.
Comment 3 Benjamin Jacobs 2008-09-30 10:45:28 EDT
Created attachment 318081 [details]
/var/log/messages with the kernel Oops
Comment 4 W. Michael Petullo 2008-10-01 20:44:14 EDT
In addition to my X problem, I see the same plymouth problems as Benjamin (comment #2). However, I would like to point out that I did at one point have X working even though plymouth didn't look quite right. So, these seem to be separate problems.
Comment 5 W. Michael Petullo 2008-10-02 18:48:47 EDT
I had hoped that my problem was the same as the one in the thread at https://www.redhat.com/archives/fedora-devel-list/2008-October/msg00088.html. However, an update to the newest Rawhide (including a libdrm resync) did not seem to fix the problem.
Comment 6 Steve 2008-10-16 05:15:02 EDT
I've the same issue since xorg-x11-drv-ati-6.9.0-25.fc10.i386. After graphical boot, the Monitor turns off.

Good: xorg-x11-drv-ati-6.9.0-21.fc10.i386

Bad : xorg-x11-drv-ati-6.9.0-25.fc10.i386
      xorg-x11-drv-ati-6.9.0-27.fc10.i386
Comment 7 Steve 2008-10-16 05:16:26 EDT
Sorry forgot to say: Graphic Card is "ATI Radeon HD 3850 AGP".
Comment 8 Steve 2008-10-21 03:45:08 EDT
xorg-x11-drv-ati-6.9.0-28.fc10.i386 is also broken!
Comment 9 Steve 2008-10-21 17:42:12 EDT
xorg-x11-drv-ati-6.9.0-29.fc10.i386 is also broken.
Comment 10 Steve 2008-10-21 18:23:42 EDT
I'va made a new bug-report for this bug, since it is not the same as in description:
https://bugzilla.redhat.com/show_bug.cgi?id=467966
Comment 11 Jonathan Matthew 2008-10-25 09:30:24 EDT
I'm also seeing this (or at least these symptoms) on a similar machine to the submitter's.  With the 2.6.25.11-97 kernel from F9, everything works.
Comment 12 W. Michael Petullo 2008-10-25 12:55:08 EDT
I downgraded my kernel to 2.6.26.6-79.fc9.ppc and the problem is fixed. Reassigned bug to kernel.
Comment 13 Jonathan Matthew 2008-11-12 06:34:37 EST
The 2.6.27.5-94 f10 kernel also works for me.  As far as I recall, 2.6.27.4-79 didn't.
Comment 14 W. Michael Petullo 2008-11-13 18:30:15 EST
Fixed in 2.6.27.5-94.fc10.ppc.

Note You need to log in before you can comment on or make changes to this bug.