Bug 463132 - resume from ram very slow (PM: resume devices took 122.854 seconds)
resume from ram very slow (PM: resume devices took 122.854 seconds)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10KernelBlocker
  Show dependency treegraph
 
Reported: 2008-09-22 02:39 EDT by Tomasz Torcz
Modified: 2008-10-10 10:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-10 10:47:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg captured after resume from ram (93.32 KB, text/plain)
2008-09-22 02:40 EDT, Tomasz Torcz
no flags Details
dmesg captured after boot (45.46 KB, text/plain)
2008-09-22 02:40 EDT, Tomasz Torcz
no flags Details
output of lspci -v (8.43 KB, text/plain)
2008-09-22 02:41 EDT, Tomasz Torcz
no flags Details
output of lsusb -v (34.50 KB, text/plain)
2008-09-22 02:41 EDT, Tomasz Torcz
no flags Details
output of lsmod (4.17 KB, text/plain)
2008-09-22 02:42 EDT, Tomasz Torcz
no flags Details
pm-suspend log after another long resume (143.955 seconds) (6.76 KB, text/plain)
2008-09-24 09:48 EDT, Tomasz Torcz
no flags Details

  None (edit)
Description Tomasz Torcz 2008-09-22 02:39:02 EDT
Description of problem:
I've suspended my laptop yesterday. Today resume took over two minutes between opening the lid and getting anything.

Version-Release number of selected component (if applicable):
Fedora 10 alpha upgraded to latest (pre-beta).
Thinkpad z61t with intel graphics and chipset.
*No* kernel modesetting.
Linux sandworm.fordon.pl.eu.org 2.6.27-0.329.rc6.git2.fc10.i686 #1 SMP Mon Sep 15 19:33:33 EDT 2008 i686 i686 i386 GNU/Linux


How reproducible:
Just happened today.
Comment 1 Tomasz Torcz 2008-09-22 02:40:16 EDT
Created attachment 317340 [details]
dmesg captured after resume from ram
Comment 2 Tomasz Torcz 2008-09-22 02:40:47 EDT
Created attachment 317341 [details]
dmesg captured after boot
Comment 3 Tomasz Torcz 2008-09-22 02:41:14 EDT
Created attachment 317342 [details]
output of lspci -v
Comment 4 Tomasz Torcz 2008-09-22 02:41:41 EDT
Created attachment 317343 [details]
output of lsusb -v
Comment 5 Tomasz Torcz 2008-09-22 02:42:06 EDT
Created attachment 317344 [details]
output of lsmod
Comment 6 Tomasz Torcz 2008-09-24 09:48:53 EDT
Created attachment 317588 [details]
pm-suspend log after another long resume (143.955 seconds)
Comment 7 Tomasz Torcz 2008-10-02 15:19:49 EDT
After few kernel updates and adding "initcall_debug printk.time=1" to kernel line I can't reproduce this behaviour (fortunately, I might say). Device resume takes 2-3 seconds.
Comment 8 Dave Jones 2008-10-10 10:47:47 EDT
ok, reopen if it regresses.

Note You need to log in before you can comment on or make changes to this bug.