Bug 463137 - Firefox will crash and system log out when visiting this website
Firefox will crash and system log out when visiting this website
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.7
i386 Linux
high Severity high
: rc
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks: 475937
  Show dependency treegraph
 
Reported: 2008-09-22 03:41 EDT by Yolkfull Chow
Modified: 2009-05-18 16:26 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:26:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (2.87 KB, text/plain)
2008-09-24 21:31 EDT, Yolkfull Chow
no flags Details
Xorg.0.log (42.91 KB, text/plain)
2008-09-24 21:36 EDT, Yolkfull Chow
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0998 normal SHIPPED_LIVE xorg-x11 bug fix and enhancement update 2009-05-18 14:39:40 EDT

  None (edit)
Description Yolkfull Chow 2008-09-22 03:41:46 EDT
Description of problem:
Firefox will crash and system will log out when visiting this website:
http://ubuntuguide.org/wiki/Ubuntu:Feisty_ru .

I had tried screen resolution 800*600, 1024*768, and 1152*864, both failed.


Version-Release number of selected component (if applicable):
firefox-3.0.2-3.el4

How reproducible:
Everytime

Steps to Reproduce:
1. set screen resolution to 1024*768 ( or 1152*864)
2. visit this website: http://ubuntuguide.org/wiki/Ubuntu:Feisty_ru
3.
  
Actual results:
firefox crash and system log out

Expected results:
should work

Additional info:
I test this on my laptop, firefox-3.0.1-1.fc10.i386 worked fine.
Comment 1 Yolkfull Chow 2008-09-22 05:46:33 EDT
I also tested 3.0.0beta5 and 3.0.1-1, also crash and logout system.
Comment 2 Matěj Cepl 2008-09-22 09:55:14 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

First of all, could we get output of the command

	rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*

Please also install firefox-debuginfo (debuginfo-install is from
yum-utils package).

	debuginfo-install firefox

Then run firefox with a parameter -g. That will start firefox running inside of gdb debugger. Then use command run and do whatever you did to make firefox crash. When it happens, you should go back to the gdb and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text editor and attach the file to the bug as an uncompressed attachment.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Yolkfull Chow 2008-09-23 06:14:28 EDT
(In reply to comment #2)
> Thanks for the bug report.  We have reviewed the information you have provided
> above, and there is some additional information we require that will be helpful
> in our diagnosis of this issue.
> 
> First of all, could we get output of the command
> 
>  rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*
> 
> Please also install firefox-debuginfo (debuginfo-install is from
> yum-utils package).
> 
>  debuginfo-install firefox
> 
> Then run firefox with a parameter -g. That will start firefox running inside of
> gdb debugger. Then use command run and do whatever you did to make firefox
> crash. When it happens, you should go back to the gdb and run
> 
>  (gdb) thread apply all backtrace
> 
> This produces usually many screens of the text. Copy all of them into a text
> editor and attach the file to the bug as an uncompressed attachment.
> 
> We will review this issue again once you've had a chance to attach this
> information.
> 
> Thanks in advance.

Hi Matej,Since firefox will not only crash and it will logout the X system, how could i get the backtrace?
Comment 4 Matěj Cepl 2008-09-23 08:43:45 EDT
so, when you are trying that running of firefox in gdb (you can redirect its stdout and stderr to the logfile for an additional security) there are no messages anywhere? I mean, when you try

gdb /usr/bin/firefox 2>&1 |tee firefox-log.txt

(and then you do what described above), the file firefox-log.txt is empty?
Comment 5 Yolkfull Chow 2008-09-23 22:13:52 EDT
The log is not empty but it will still cannot catch the backtrace.Following is the content of log:

------------------------
GNU gdb Red Hat Linux (6.3.0.0-1.159.el4rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...Using host libthread_db library "/lib/tls/libthread_db.so.1".

(gdb) r
Starting program: /usr/lib/firefox-3.0.2/firefox-bin 
[Thread debugging using libthread_db enabled]
[New Thread -1208248640 (LWP 26164)]
[New Thread -1214252128 (LWP 26167)]
[New Thread -1227883616 (LWP 26168)]
[New Thread -1240466528 (LWP 26169)]
[Thread -1240466528 (LWP 26169) exited]
[New Thread -1250956384 (LWP 26170)]
[Thread -1250956384 (LWP 26170) exited]
[New Thread -1250956384 (LWP 26171)]
[New Thread -1240466528 (LWP 26172)]
[New Thread -1263535200 (LWP 26173)]
[New Thread -1285555296 (LWP 26174)]
[New Thread -1296045152 (LWP 26175)]
[Thread -1285555296 (LWP 26174) exited]
[New Thread -1285555296 (LWP 26176)]
Gecko: Fatal IO error 104 (Connection reset by peer) on X server :0.0. 
------------------------------------------------------------

Moreover,when i login via vnc(both from my laptop and from the debugging machine) and launch firefox to open that URL, it will NOT crash and X server will not down. And, when i open the URL with opera on debugging machine,it will not crash or down the X server also.
Comment 6 Matěj Cepl 2008-09-24 06:31:30 EDT
Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 7 Matěj Cepl 2008-09-24 12:19:34 EDT
Actually, this is duplicate for RHEL4 of bug 455359
Comment 8 Yolkfull Chow 2008-09-24 21:31:16 EDT
Created attachment 317643 [details]
xorg.conf

The debugging machine is using nvidia video card, and system is using nvidia driver also.

#lspci |grep VGA
06:00.0 VGA compatible controller: nVidia Corporation NV41 [GeForce 6800 GS] (rev a2)


xorg.conf
...
Section "Device"
        Identifier  "Videocard0"
        Driver      "nv"
        VendorName  "Videocard vendor"
        BoardName   "NVIDIA Unknown (generic)"
EndSection
...
Comment 9 Yolkfull Chow 2008-09-24 21:36:22 EDT
Created attachment 317644 [details]
Xorg.0.log
Comment 10 RHEL Product and Program Management 2008-10-06 13:46:38 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 11 Adam Jackson 2008-12-08 14:46:35 EST
1603766 build (dist-4E-qu-candidate, /cvs/dist:rpms/xorg-x11/RHEL-4:xorg-x11-6_8_2-1_EL_54) completed successfully

MODIFIED
Comment 15 A S Alam 2009-01-27 02:16:50 EST
I tested with with following configuration:
firefox-3.0.5-1.el5_2 
three resolutions [800x600, 1024x768, 1152x864]
Intel 910GL Integrated Graphics Controller

[PASSED] [RHEL5.3-Client-20090106.0] - Fresh installed OS

(Firefox works fine)
Thanks
Comment 18 errata-xmlrpc 2009-05-18 16:26:27 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0998.html

Note You need to log in before you can comment on or make changes to this bug.