Bug 463149 - bc needs a ~/.bcrc to start
bc needs a ~/.bcrc to start
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: bc (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Zdenek Prikryl
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-22 06:39 EDT by Alain D D Williams
Modified: 2008-09-23 07:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-23 07:29:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alain D D Williams 2008-09-22 06:39:40 EDT
Description of problem:
The calculator bc will not start unless ~/.bcrc exists

Version-Release number of selected component (if applicable):
bc-1.06-21

How reproducible:
Every time.

Steps to Reproduce:
1. Type: bc
It replies: File /home/addw/.bcrc is unavailable.

2. Type: > ~/.bcrc
        bc
and it starts correctly.

The file does not need to contain anything, it just seems to need to exist.
This is different from how bc used to act; what it should do is to just ignore if the .bcrc file does not exist. The manual page makes no reference to this file.
Comment 1 Zdenek Prikryl 2008-09-23 06:44:09 EDT
Weird, I cannot reproduce it on rhel or fedora. Could you attach as an attachment the output from "$ strace bc"? Thanks.
Comment 2 Alain D D Williams 2008-09-23 07:05:12 EDT
One million apologies ... I recently upgraded a machine after a hardware failure, my environment contained BC_ENV_ARGS=/home/addw/.bcrc to set scaling and I did not copy the file over.

Again: apologies for wasting your time :-(
Comment 3 Zdenek Prikryl 2008-09-23 07:29:32 EDT
Ok, so I'm closing this as NOABUG.

Note You need to log in before you can comment on or make changes to this bug.