Bug 463163 - Incorrect dependency added to nash subpackage
Incorrect dependency added to nash subpackage
Status: CLOSED DUPLICATE of bug 463216
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.3
All Linux
medium Severity high
: beta
: ---
Assigned To: Peter Jones
Release Test Team
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-22 09:23 EDT by Jay Turner
Modified: 2015-01-07 19:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-22 12:49:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2008-09-22 09:23:34 EDT
Description of problem:
As a result of RPMDiff verification errors (http://errata.devel.redhat.com/rpmdiff/show/29662?result_id=266971) a mkinitrd dep was added to all subpackages as opposed to just the two (libbdevid-python, mkinitrd-devel) referenced in the rpmdiff output.  Net result is that mkinitrd requires nash and nash requires mkinitrd . . . circular dependency which yum/rpm doesn't handle too well.

This situation is made all the more interesting by the corresponding changelog entry:

* Thu Sep 18 2008 Peter Jones <pjones@redhat.com> - 5.1.19.6-32
- Fix some minor stuff rpmdiff found.
  A total lie here:
  Related: rhbz#426992

I.e. a total lie as pointed out by Peter himself.  The problem continues to get worse, as the next round of rpmdiff (http://errata.devel.redhat.com/rpmdiff/show/30083?result_id=271465) highlights the change but all of the changes are waived with:

****
Waived by David Cantrell on Fri Sep 19 17:21:28 -0400 2008 3 2
Old Score Before Waive: Needs inspection

This is fine, the new obsoletes is
inclusive of the old one.
****

Why none of the other changes highlighted are addressed in the waive message I don't know, but it clearly points out that nash has picked up a new dependency.


Version-Release number of selected component (if applicable):
5.1.19.6-{32,33}

How reproducible:
Always

Steps to Reproduce:
1. Attempt to install mkinitrd and nash
Comment 2 Peter Jones 2008-09-22 12:49:58 EDT

*** This bug has been marked as a duplicate of bug 463216 ***

Note You need to log in before you can comment on or make changes to this bug.