Bug 463168 - RFE: NM and all its deps should move from /usr to /
RFE: NM and all its deps should move from /usr to /
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-22 09:47 EDT by Hans de Goede
Modified: 2012-03-20 17:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-20 17:46:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2008-09-22 09:47:03 EDT
Short intro: I'm a long time Linux / Fedora developer and I've recently been hired as the latest member of the anaconda team.

My first assignment as anaconda team member is to get iscsi support in anaconda master (the Fedora version) in shape and on par with rhel-5.3

One of the problems I've encountered here is that Fedora now uses NM for all network configuration, this means that the iscsi "service" can not be started before NM is done. This means that I'll be changing the initscripts todo the same as netfs.

However even if changed to be started by NM once the network is up their is still a problem. This means that /usr cannot be on an iscsi partition (or on nfs for that matter) as NM is on /usr and now is needed to get to a network based /usr.

Since the FHS explicitly states that /usr could be network based this means that as NM may be needed for /usr it cannot be on /usr and thus should be moved to /

Alternatively we could ask FESCo to declare that /usr separate from / on a network based partition is not supported (/usr on the same partition/fs as / is fine even if / is network based, the initrd will take care of configuring the needed interfaces then).
Comment 1 Pavel Šimerda (pavlix) 2012-03-20 17:46:54 EDT
/bin, /sbin and /lib are symlinks to /usr/* since Fedora 17. The /usr filesystem is now handled by dracut.

http://fedoraproject.org/wiki/Features/UsrMove

Note You need to log in before you can comment on or make changes to this bug.