Bug 463177 - [LTC 6.0 FEAT] 201686:Installer - HiperSockets MAC Layer Routing Support
[LTC 6.0 FEAT] 201686:Installer - HiperSockets MAC Layer Routing Support
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.1
s390x All
high Severity high
: alpha
: 6.0
Assigned To: Anaconda Maintenance Team
Release Test Team
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-22 10:50 EDT by IBM Bug Proxy
Modified: 2010-09-28 15:18 EDT (History)
9 users (show)

See Also:
Fixed In Version: anaconda-12.38.5-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 16:39:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-22 10:50:43 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:21 EDT
1. Feature Overview:
Feature Id:	[201686]
a. Name of Feature:	Installer - HiperSockets MAC Layer Routing Support
b. Feature Description
HiperSockets support now also Layer2 modus (useful for applications depending on the existence of a
unique MAC address, like DHCP, tcpdump, channel bonding, HA...), so the installer should give the
possibility when configuring the network to be HiperSockets to:  
- choose between Layer2 and Layer3  
- if Layer2 to allow the user to set a predefined MAC address (optional), and if none is given, the
driver will generate one randomly.
Note: In previous releases there was a similar code path for OSA Layer2 support, which could be reused.

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Both
Affects Installer: Yes
Delivery Mechanism: Request Red Hat development assistance
Category:	Installation
Request Type:	Installer - Enhancement from Distributor
d. Upstream Acceptance:	No Code Required
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	no
g. Component Version Target:	n/a

3. Business Case
These changes will improve the installation experience for customers by making the installation
workflow more usable and efficient (since the customer won't have to do the changes manually after
the installation), which will result on an improvement of the customer satisfaction. Without this
feature, the customer will be restricted to install only in Layer3 mode, and if Layer2 mode is
needed, will have to spend effort on doing the changes manually after the installation.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.coms

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 Bill Nottingham 2008-10-01 16:29:18 EDT
Exactly how is this implemented in the driver? What needs frobbed where to enable this on a running system?
Comment 2 Gonzalo Muelas Serrano 2008-11-27 08:55:30 EST
Hello Red Hat,
to find out details about the implementation, I guess the best source will be the source code (the Layer2 functionality for HiperSockets is already upstream).
To enable Layer2 on HiperSockets, having the device offline, you have to:
echo <integer> > /sys/devices/qeth/<first_subchannel>/layer2

More info can be found under (recently updated):
http://www.ibm.com/developerworks/linux/linux390/development_documentation.html
Device Drivers, Features, and Commands - SC33-8411-01
Chapter 7
Comment 3 Gonzalo Muelas Serrano 2008-11-27 09:18:52 EST
Info provided...
Comment 4 Siddharth Nagar 2009-10-20 15:10:12 EDT
We need IBM to provide the following:

1. Workflow inside anaconda that is impacted.
2a. Patches for anaconda to provide options or UI wire screens.
2b. Kickstart options to support the above.
Comment 5 IBM Bug Proxy 2009-10-21 10:50:50 EDT
------- Comment From gmuelas@de.ibm.com 2009-10-21 10:41 EDT-------
(In reply to comment #8)

> We need IBM to provide the following:
>
> 1. Workflow inside anaconda that is impacted.
Please check with David Cantrell and Brock Organ.

> 2a. Patches for anaconda to provide options or UI wire screens.
IBM is requiring Red Hat to enhance your RHEL intaller because IBM does not have the patches, sorry.

> 2b. Kickstart options to support the above.
Please check with David Cantrell and Brock Organ, but I think it could be "LAYER2"

Thank you for your support,
Gonzalo Muelas Serrano.
Comment 6 David Cantrell 2010-01-15 21:40:37 EST
Fixing this bug requires patching linuxrc.s390 to ask if you want layer 2 or layer 3 if you choose the HiperSockets driver, then optionally prompting for a MAC address if you pick layer 2.  If the user picks layer 2, the script needs to echo 1 to /sys/devices/qeth/<subchannel>/layer2

The network.py file may need patching to handle the layer 2 vs. layer 3 difference to ensure the MAC address is treated as optional when in layer 2 mode.

This bug may need to be cloned for NetworkManager to address the UI configuration elements in nm-connection-editor and possibly nm-system-settings.
Comment 7 John Jarvis 2010-01-18 09:21:41 EST
IBM is signed up to test and provide feedback.
Comment 9 Brock Organ 2010-01-18 14:20:57 EST
I'm hesitant to add a QA ack for this item until we have a testable reference implementation in fedora first ... can we start to identify, build and test the changes there? 

(Then when that process is complete we can address the RHEL functionality with confidence that our specification will match the feature need ...)
Comment 10 IBM Bug Proxy 2010-01-25 04:30:37 EST
------- Comment From mgrf@de.ibm.com 2010-01-25 04:29 EDT-------
(In reply to comment #12)
> I'm hesitant to add a QA ack for this item until we have a testable reference
> implementation in fedora first ... can we start to identify, build and test the
> changes there?
>  (Then when that process is complete we can address the RHEL functionality
> with confidence that our specification will match the feature need ...)

At this point in time, RHEL 6 on System z is the best "Fedora" on System z
we've got.... and RHEL 6 anaconda is being rebased from F13...
Comment 11 John Jarvis 2010-02-05 11:14:26 EST
Without a working Fedora implementation we are unable to approve this for RHEL 6.0 inclusion.  Closing as DEFERRED, resetting flags and moving to the RHEL 6.1 tracker for review for inclusion in that release.
Comment 12 IBM Bug Proxy 2010-02-11 07:31:07 EST
------- Comment From mgrf@de.ibm.com 2010-02-11 07:28 EDT-------
This feature is implemented in linuxrc.s390 by System z.

It has been discussed upstream last year and is upstream with Fedora12.
Feature tests passed once on alpha build RHEL6.0-20091130.0

Final feature tests planned on RHEL6 betas

Additional changes in e.g. nm-system-settings from Network Manager should not be required

The git commit:
layer2 option provided for all qeth device types:
http://git.fedorahosted.org/git/anaconda.git?p=anaconda.git;a=commit;h=9249e40f42ffbbdcf42cd1caad72e3d622c7a75b
Comment 13 David Cantrell 2010-02-11 09:39:19 EST
Based on comment 12, moving to MODIFIED since this feature has been present since anaconda-12.38.5-1.
Comment 15 IBM Bug Proxy 2010-06-15 01:51:24 EDT
------- Comment From mgrf@de.ibm.com 2010-06-15 01:42 EDT-------
This feature is verified on R6 snapshots
Set feature to "verified"  Thx
Comment 16 John Jarvis 2010-06-15 10:06:58 EDT
Setting VERIFIED flag based on latest feedback.
Comment 17 Jan Stodola 2010-06-16 02:45:34 EDT
Moving to VERIFIED based on comment 15.
Thank you for testing.
Comment 18 releng-rhel@redhat.com 2010-07-02 16:39:43 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.