Bug 463187 - [LTC 6.0 FEAT] 201688:Installer migration - Merge CTCMPC into CTC device driver
[LTC 6.0 FEAT] 201688:Installer migration - Merge CTCMPC into CTC device driver
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
s390x All
high Severity high
: beta
: 6.0
Assigned To: Anaconda Maintenance Team
Release Test Team
: FutureFeature
Depends On: 557522
Blocks: 356741 554559
  Show dependency treegraph
 
Reported: 2008-09-22 11:11 EDT by IBM Bug Proxy
Modified: 2010-11-10 14:34 EST (History)
8 users (show)

See Also:
Fixed In Version: anaconda-13.21.20.1-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 14:34:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-22 11:11:28 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:21 EDT
1. Feature Overview:
Feature Id:	[201688]
a. Name of Feature:	Installer migration - Merge CTCMPC into CTC device driver
b. Feature Description
Assuming that the installer will still allow to use CTC devices for the installation for migration
purposes, since the merge of CTC and CTCMPC upstream in one module, it should be taken into
consideration for the installer infrastructure and messages/question that the module 'ctc' has been
renamed to 'ctcm'.

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Purely Arch Specific Code
Affects Installer: Yes
Delivery Mechanism: Request Red Hat development assistance
Category:	Installation
Request Type:	Installer - Enhancement from Distributor
d. Upstream Acceptance:	No Code Required
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	no
g. Component Version Target:	

3. Business Case
This feature is needed to allow customers to migrate their current system to the newest major
version without having to change their network infrastructure if they are still depending on CTC
(which some customers do for interoperability with other System z OS).

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 Bill Nottingham 2008-10-01 16:41:30 EDT
I think a more serious question is whether CTC should still be supported - as I recall, it was deprecated (if not officially unsupported) in RHEL 5. Am I mistaken?
Comment 4 Gonzalo Muelas Serrano 2008-11-27 09:09:04 EST
CTC (was upstream) functionality was deprecated, but CTCMPC (was not upstream) not.
Both are now provided with "ctcm" (is upstream).

Regarding the CTC functionality, this feature is only needed depending if Red Hat decides to continue to have CTC functionality in the RHEL 6 installation or not (in RHEL 5.x is deprecated but still offered).

Regarding the CTCMPC functionality, we have not requested any installation enhancement.
Comment 5 Bill Nottingham 2008-12-10 13:15:04 EST
Well, it appears from bug 475721 that CTC may have been broken throughout all of RHEL 5 and not noticed until now. Which, again, makes me wonder if it should be supported.
Comment 6 IBM Bug Proxy 2008-12-11 04:31:25 EST
(In reply to comment #6)
> Well, it appears from bug 475721 that CTC may have been broken throughout all
> of RHEL 5 and not noticed until now. Which, again, makes me wonder if it should
> be supported.
>

The bugzilla you are referring to has been reported in RHEL 5.3 against RHEL initscripts, not again the CTC kernel driver. So I would rather state:
"CTC initscripts may have been broken..."
If you find any problems in the CTC kernel driver: "ctc" module in RHEL5; "ctcm" module in RHEL6, it will be fixed bei IBM System z CTC mantainer.
Comment 7 Bill Nottingham 2008-12-11 10:22:34 EST
All I'm saying is that if a deprecated feature has been broken for the entirety of RHEL 5 (over a year and a half, not even counting the beta cycle, if that's the case) and it wasn't noticed until now, it implies it's not actually used enough to support in RHEL 6.
Comment 8 Siddharth Nagar 2009-10-20 15:30:24 EDT
We have no issue with including the ctcm driver (that is now upstream) in Anaconda.
Comment 9 David Cantrell 2010-01-15 21:01:59 EST
I think the only change that needed to happen in anaconda for the 'ctcm' driver was changing 'ctc' to 'ctcm' in loader.  Steffen did that on July 22, 2009, which subsequently went in to anaconda-12.6-1.

So I am fairly certain we have had this support since early in RHEL-6 development.  Can someone retest with a current tree (anaconda-13.21.0-1 or later) and see that ctcm is used?
Comment 11 Steffen Maier 2010-02-10 13:51:30 EST
While the new linuxrc.s390 does handle the new driver name, it also relies on automatic driver loading as requested by the anaconda community. Because of bug 557522, neither lcs nor ctcm are currently loaded which is why linuxrc cannot establish the necessary ccwgroup to form a network device of NETTYPE lcs or ctc. Tested with RHEL6.0-20091130.0. Therefore this bug depends on bug 557522.
Comment 12 IBM Bug Proxy 2010-02-11 12:01:33 EST
------- Comment From mgrf@de.ibm.com 2010-02-11 11:54 EDT-------
(In reply to comment #12)
> - -- From maier@linux.vnet.ibm.com 2010-02-10 13:51:30 EDT---
> Therefore this bug depends on bug 557522.

That has a tested patch attached and is:
RHBZ 557522 -  need udev rules to automatically load s390 network device drivers for LCS and CTC

Please include that patch to finally complete the integration of this feature. Thx
Comment 13 John Jarvis 2010-02-15 11:33:14 EST
Patches in BZ 557522 are in MODIFIED state and are included in kernel-2.6.32-16.el6.
Comment 14 David Cantrell 2010-03-25 11:42:09 EDT
This bug is done from the anaconda side.  It's been dependent on bug #557522, which is now in ON_QA.  Setting Fixed In Version field and moving to MODIFIED.
Comment 17 Jan Stodola 2010-06-21 07:32:28 EDT
Hello IBM,
were you able to test this feature with any recent snapshot of RHEL6.0?
I would like to make sure you accept implementation of this feature.
Thank you for your feedback.
Comment 18 IBM Bug Proxy 2010-07-23 05:31:25 EDT
------- Comment From mgrf@de.ibm.com 2010-07-23 05:23 EDT-------
This feature is verified on R6 snapshots
with one problem (severity = normal) reported
The fix can be integrated independent from feature verification.

->  LTC 64368  - RIT951753- [RHEL6.0 Snap4] ctc interface is not available on-boot with ctcm driver

Set feature to verified, the fix
Comment 19 Jan Stodola 2010-07-26 03:25:26 EDT
Thank you for feedback, moving to VERIFIED based on comment 18.
Comment 20 IBM Bug Proxy 2010-07-27 09:51:43 EDT
------- Comment From mgrf@de.ibm.com 2010-07-27 09:47 EDT-------
oopsa ...
the bug reported for this feature got re-opened today, based on snap7.
64285  -  RIT945673- RHEL6.0 installation using LCS and CTC network interfaces is not working.

Verification failed for CTC devices
install via LCS devices works

Nevertheless I hold this feature in status "verified" and the fix for CTC devices get tracked via the bugzilla 64285  -  RIT945673
Comment 21 releng-rhel@redhat.com 2010-11-10 14:34:39 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.