Bug 46326 - Installer fails on an HP Vectra XU 5/90
Installer fails on an HP Vectra XU 5/90
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-27 16:34 EDT by David Lamm
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lamm 2001-06-27 16:34:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
Kernel panic when upgrading 6.2 Redhat on the HP Vectra XU 5/90.  Using 
boot.img and ISO images on HD.

How reproducible:
Always

Steps to Reproduce:
1.Use Redhat 7.1 boot.img
2.Use driver disk for AMD type SCSI controller
3.Install from ISO images on HD
	

Actual Results:  Kernel panic just after selecting type of install.  ie 
(Workstation, Laptop, Server, Custom, ...etc).  Failed on both Workstation 
or Custom.

Expected Results:  No Kernel panic.

Additional info:

Wrote down the Kernel panic message.  It is as follows...

Ooops 0002
CPU  0
EIP  0010:[<c4838e37>]
EFLAGS  00010006
   .   .   .
   .   .   .
Kernel panic:  Aiee, Killing interrupt handler!
In Interrupt handler - not syncing


When this first happened I went to HP's website and dowloaded the latest 
BIOS which didn't help.
The system board is integrated with network, video and both IDE and SCSI 
controllers.  There are 2 SCSI drives, no IDE drives and no CD-ROM drive.  
There is also 1 additional network card.  The system is currently working 
well with Redhat 6.2 installed.
Comment 1 Brent Fox 2001-07-03 11:24:15 EDT
Changing component to the kernel.
Comment 2 Arjan van de Ven 2001-07-03 11:27:19 EDT
Can you run an "lspci" in 6.2 and paste/attach the output ?
That would give an idea about the hardware in this machine.
Also, try booting the installer with adding "ide=nodma" to
the syslinux prompt
Comment 3 Arjan van de Ven 2001-07-03 11:28:02 EDT
Also, I assume the driverdisk is the one that came with 7.1
Comment 4 David Lamm 2001-07-03 23:29:16 EDT
The driver disk was downloaded from an FTP mirror under the 7.1 directory.  The 
files on the disk are dated 4-8-2001.  However, one of the files is 
called "rhdd-6.1" which would seem to indicate it's a 6.1 driver disk.  Its 
placement in the 7.1 directory and the dates of the files would indicate a 7.1 
driver disk.  I'm assuming the file name is a typo!

Anyway, I also tried the "ide=nodma" option, but it had no effect.

I am also including the 'lspci' output as requested.

00:00.0 Host bridge: Intel Corporation 82434LX [Mercury/Neptune] (rev 11)
00:01.0 VGA compatible unclassified device: S3 Inc. 86c864 [Vision 864 DRAM] 
vers 1
00:02.0 Non-VGA unclassified device: Intel Corporation 82375EB (rev 04)
00:03.0 Ethernet controller: Advanced Micro Devices [AMD] 79c970 [PCnet LANCE] 
(rev 02)
00:04.0 SCSI storage controller: Advanced Micro Devices [AMD] 53c974 [PCscsi] 
(rev 02)
00:05.0 IDE interface: CMD Technology Inc PCI0640 (rev 02)


This did help me determine the correct SCSI driver to load.  It seems I was 
loading the wrong driver before.  I was using the "tmscsim" driver instead of 
the "AM53c974" driver.  Boy did I feel stupid!  I thought I had found the 
problem and would have to sheepishly report back that the installer was fine, 
it was just my head that was broken.
So, I tried using the "AM53c974" driver, selected the partitition where the ISO 
images are located, and watched as the installer automatically started loading 
the "tmscsim" driver.  Hmmm, maybe my head isn't that broken!
It never finished loading this driver, but the system did panic quite nicely.

I'm not sure why the installer tried to load the "tmscsim" driver after it 
successfully (console 3 verified) loaded the "AM53c974" driver, but it does 
seem to be the main culprit here.

As always, I'm willing to provide any information necessary to help resolve 
this problem!
Comment 5 Bugzilla owner 2004-09-30 11:39:03 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.