Bug 463274 - disk log mirror convert option is lost if down covert option is also given
disk log mirror convert option is lost if down covert option is also given
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.8
All Linux
medium Severity medium
: rc
: ---
Assigned To: Petr Rockai
Cluster QE
:
Depends On:
Blocks: RHEL4u8_relnotes
  Show dependency treegraph
 
Reported: 2008-09-22 15:47 EDT by Corey Marthaler
Modified: 2011-01-06 21:54 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 15:56:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2008-09-22 15:47:29 EDT
THIS IS THE RHEL4 VERSION OF BZ 463272.

Description of problem:
If you attempt to down convert a mirror as well as convert it from core to disk
log on the same cmd line, the disk log convert option will be dropped (not
executed). However if you attempt to down convert a mirror as well as convert
it from disk to core log on the same cmd line, it will work.

If you run the "half completed" cmd line that didn't do the disklog convert
initially a second time, then it'll work since the down convert has already
happened.

[root@grant-01 ~]# lvs -a -o +devices
  LV                VG         Attr   LSize  Origin Snap%  Move Log Copy% 
Convert Devices                                                 
  mirror            grant      Mwi-a-  1.00G                        100.00     
   mirror_mimage_0(0),mirror_mimage_1(0),mirror_mimage_2(0)
  [mirror_mimage_0] grant      iwi-ao  1.00G                                   
   /dev/sdb1(0)                                            
  [mirror_mimage_1] grant      iwi-ao  1.00G                                   
   /dev/sdb2(0)                                            
  [mirror_mimage_2] grant      iwi-ao  1.00G                                   
   /dev/sdb3(0)                                            
[root@grant-01 ~]# lvconvert --mirrorlog disk -m 1 grant/mirror
  Logical volume mirror converted.
[root@grant-01 ~]# lvs -a -o +devices
  LV                VG         Attr   LSize  Origin Snap%  Move Log Copy% 
Convert Devices                              
  mirror            grant      Mwi-a-  1.00G                         18.75     
   mirror_mimage_0(0),mirror_mimage_1(0)
  [mirror_mimage_0] grant      Iwi-ao  1.00G                                   
   /dev/sdb1(0)                         
  [mirror_mimage_1] grant      Iwi-ao  1.00G                                   
   /dev/sdb2(0)                         

## Note the above mirror still has an in-core log.

Version-Release number of selected component (if applicable):
2.6.9-78.0.4.ELsmp

lvm2-2.02.37-3.el4    BUILT: Thu Jun 12 10:09:19 CDT 2008
lvm2-cluster-2.02.37-3.el4    BUILT: Thu Jun 12 10:22:07 CDT 2008
device-mapper-1.02.25-2.el4    BUILT: Mon Jun  9 09:28:41 CDT 2008
cmirror-1.0.1-1    BUILT: Tue Jan 30 17:28:02 CST 2007
cmirror-kernel-2.6.9-43.4.el4_7.3    BUILT: Tue Sep 16 15:17:13 CDT 2008


How reproducible:
Everytime
Comment 1 RHEL Product and Program Management 2008-09-22 15:52:50 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Tom Coughlan 2008-10-06 15:56:18 EDT
I think the right way to handle this in RHEL 4 is to document the limitation, rather than take any risk that a fix may introduce a regression. 

I'll close this and set the flag requesting a release note. Petr, would you investigate the source of the problem, to see whether it may effect other command lines that specificy multiple operations? Once you understand the cause, please draft a release note (in the field above) that describes which type of combined operations do not execute completely. Then, maybe fix it in RHEL 5 
BZ 463272?  :)

Note You need to log in before you can comment on or make changes to this bug.