Bug 463278 - Incorrect D-Bus system bus user ID in system.conf
Incorrect D-Bus system bus user ID in system.conf
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dbus (Show other bugs)
5.3
All Linux
medium Severity high
: rc
: ---
Assigned To: Dan Williams
desktop-bugs@redhat.com
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-22 15:57 EDT by Jay Turner
Modified: 2015-01-07 19:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:54:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2008-09-22 15:57:21 EDT
Description of problem:
I'm not sure is this is NetworkManager, dbus, or something else, but after updating to the 20080919.2 Client tree today (via 'yum update') my wireless is no longer working.  The ipw3945d service is working just fine but the wireless device never shows up in the NM applet.

Version-Release number of selected component (if applicable):
0.7.0-0.11.svn4082.el5

How reproducible:
Always

Steps to Reproduce:
1. Load up a 5.3-candidate tree on a box with wireless, see if it works after enabling NetworkManager and disabling the network service

Additional info:
benl is seeing the same behavior with an ipw2200 card.  The only thing which appears in syslog is:

Sep 22 15:55:17 haring NetworkManager: <info>  Trying to start the supplicant... 
Sep 22 15:55:17 haring NetworkManager: <info>  Trying to start the system settings daemon... 
Sep 22 15:55:17 haring setroubleshoot: SELinux is preventing dbus-daemon (system_dbusd_t) "execute_no_trans" to /lib/dbus-1/dbus-daemon-launch-helper (lib_t). For complete SELinux messages. run sealert -l 7d323053-21fe-498b-b952-0db027210767

which points back to bug 463267 so that might be at the heart of the issue.  The odd thing is that I'm having this problem in permissive as well as with selinux completely disabled, which seems odd for a denial.
Comment 1 Jay Turner 2008-09-23 15:14:20 EDT
Some additional information.  Got the dbus selinux issues resolved, loaded up the new NetworkManager (0.7.0-0.11.svn4088.el5) and here's what I get when restarting NM (picking just the stuff related to eth0, the wireless interface):

Sep 23 14:30:40 haring NetworkManager: <info>  eth0: driver is 'ipw3945'. 
Sep 23 14:30:40 haring NetworkManager: <info>  eth0: driver does not support SSID scans (scan_capa 0x00). 
Sep 23 14:30:40 haring NetworkManager: <info>  Found new 802.11 WiFi device 'eth0'. 
Sep 23 14:30:40 haring NetworkManager: <info>  (eth0): exported as /org/freedesktop/Hal/devices/net_00_13_02_4a_10_55 
Sep 23 14:30:40 haring NetworkManager: <info>  Trying to start the supplicant... 
Sep 23 14:30:44 haring NetworkManager: <info>  (eth0): device state change: 1 -> 2 
Sep 23 14:30:44 haring NetworkManager: <info>  (eth0): bringing up device. 
Sep 23 14:30:44 haring kernel: ADDRCONF(NETDEV_UP): eth0: link is not ready
Sep 23 14:30:44 haring NetworkManager: <info>  (eth0): preparing device. 
Sep 23 14:30:44 haring NetworkManager: <info>  (eth0): deactivating device. 
Sep 23 14:30:44 haring NetworkManager: supplicant_interface_acquire: assertion `mgr_state == NM_SUPPLICANT_MANAGER_STATE_IDLE' failed


The last entry is quite interesting, as that's new with the NM rebase and might be the cause of the problems.
Comment 2 Dan Williams 2008-09-23 15:42:59 EDT
After NM gets launched, is a wpa_supplicant process running?  Should be something like:

/usr/sbin/wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -u -f /var/log/wpa_supplicant.log
Comment 3 Jay Turner 2008-09-24 08:45:35 EDT
Very strange.  No, there's not a wpa_supplicant process.  In fact, the wpa_supplicant service is chkconfig'd off for all runlevels.

The good news is that after configuring and starting the service manually, appears things are working.  Appears that NM is no longer handling the initiation of wpa_supplicant correctly.  Let me know what other information I can provide.
Comment 4 Dan Williams 2008-09-24 10:56:16 EDT
Ok, that means we have issues with D-Bus service activation, probably due to the SELinux stuff.  You shouldn't need to chkconfig the supplicant service on because it should be started on-demand by NM via dbus service activation.

If you chkconfig wpa_supplicant off again, and set selinux to permissive mode, then reboot, does you get the supplicant process?
Comment 6 Dan Williams 2008-09-24 13:26:52 EDT
Issue appears to be an incorrect user ID in the dbus system bus configuration.  Will build dbus-1.1.2-10.el5 to fix.
Comment 8 Jay Turner 2008-09-24 15:25:44 EDT
1.1.2-10.el5 makes things lots happier.
Comment 9 Jay Turner 2008-10-01 08:24:31 EDT
dbus-1.1.2-10.el5 included in 20080930.0 candidate trees.
Comment 12 errata-xmlrpc 2009-01-20 15:54:25 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0094.html

Note You need to log in before you can comment on or make changes to this bug.