This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 463279 - [LTC 6.0 FEAT] 201200:16GB huge pages for POWER
[LTC 6.0 FEAT] 201200:16GB huge pages for POWER
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
ppc64 All
medium Severity medium
: alpha
: 6.0
Assigned To: Kevin W Monroe
Martin Jenner
: FutureFeature
Depends On:
Blocks: 356741 RHEL6Kernel2.6.27
  Show dependency treegraph
 
Reported: 2008-09-22 16:10 EDT by IBM Bug Proxy
Modified: 2010-05-06 11:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-23 18:24:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-22 16:10:40 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:24 EDT
1. Feature Overview:
Feature Id:	[201200]
a. Name of Feature:	16GB huge pages for POWER
b. Feature Description
The ability to support a page size of 16GB

2. Feature Details:
Sponsor:	PPC - P
Architectures:
ppc64

Arch Specificity: Both
Affects Core Kernel: Yes
Delivery Mechanism: Direct from community
Category:	Performance
Request Type:	Driver - Feature from IBM
d. Upstream Acceptance:	Accepted
Sponsor Priority	2
f. Severity: Medium
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	2.6.27
Performance Assistance:	yes

3. Business Case
Using 16GB pages can increase performance for systems running workloads that consume very large
amounts of memory. The target market to leverage 16GB pages includes HPC and large database
workloads. The extent of the performance increase is workload-dependent but typically 5% performance
improvements are seen when moving from 64KB pages to 16MB pages for databases. A smaller increase is
expected for 16GB pages in database applications.

For the specialized HPC system space, selected large government bids have levied the requirement for
massive amounts of dedicated memory on dedicated single-use systems. The ability to specify and
dedicate 16GB pages provides support for these highly specialized applications.  The applications
and bids are often high visibility projects for the company. In general, most HPC customers will not
require 16GB pages.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Michael Hohnbaum, hbaum@us.ibm.com, 503-578-5486

Technical contact(s):
Paul Mackerras, pmac@au1.ibm.com
Comment 1 Bill Nottingham 2008-10-01 16:51:55 EDT
Is this code actually in 2.6.27?
Comment 2 IBM Bug Proxy 2008-10-13 18:21:06 EDT
(In reply to comment #4)
> ------- Comment From notting@redhat.com 2008-10-01 16:51:55 EDT-------
> Is this code actually in 2.6.27?
>

Yes.
The actual definition of 16G pages is in
commit 91224346aa8c1cdaa660300a98e0b074a3a95030

There are other supporting patches too; as examples:

commit 658013e93eb70494f7300bc90457b09a807232a4
commit ec4b2c0c8312d1118c2acd00c89988ecf955d5cc
commit 53ba51d21d6e048424ab8aadfebdb1f25ae07b60
commit a3437870160cf2caaac6bdd76c7377a5a4145a8c

There are some bug fixes coming in 2.6.28 related to this feature, but the core code though is in 2.6.27
Comment 3 Bill Nottingham 2008-10-13 21:01:45 EDT
Since it's in 2.6.27, and RHEL 6 will include a recent upstream kernel, setting to MODIFIED.

The feature requested has already been accepted into the upstream code base
planned for the next major release of Red Hat Enterprise Linux.

When the next milestone release of Red Hat Enterprise Linux 6 is available,
please verify that the feature requested is present and functioning as
desired.
Comment 4 IBM Bug Proxy 2009-03-02 16:31:02 EST
this is in 2.6.27
sha1 id: 91224346aa8c1cdaa660300a98e0b074a3a95030
Comment 5 Kevin W Monroe 2009-09-23 18:24:20 EDT
Closing - included in Red Hat Enterprise Linux 6.
Comment 6 IBM Bug Proxy 2010-05-06 11:53:52 EDT
------- Comment From ebmunson@us.ibm.com 2010-05-06 11:47 EDT-------
Verified with RHEL 6 Snap 1.

Note You need to log in before you can comment on or make changes to this bug.