This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 463284 - [LTC 6.0 FEAT] 201246:servicelog package
[LTC 6.0 FEAT] 201246:servicelog package
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: distribution (Show other bugs)
6.0
All All
high Severity high
: alpha
: 6.0
Assigned To: Roman Rakus
Release Test Team
: FutureFeature
Depends On: 590010
Blocks: 356741 554559
  Show dependency treegraph
 
Reported: 2008-09-22 16:20 EDT by IBM Bug Proxy
Modified: 2014-01-12 19:07 EST (History)
8 users (show)

See Also:
Fixed In Version: libservicelog-1.0.1-3.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 14:58:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-22 16:20:41 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:25 EDT
1. Feature Overview:
Feature Id:	[201246]
a. Name of Feature:	servicelog package
b. Feature Description
The servicelog package is used to store events that require a service action to be taken.  For
example, in the case of a fan failure, the location and part number of the failing fan would be
noted, as well as a pointer to the repair procedure.  Servicelog handles administrator notification
and call homes, and allows for repairs to be logged, to provide a complete history of failures and
repair actions for a system.

2. Feature Details:
Sponsor:	PPC
Architectures:
ppc64

Arch Specificity: Purely Common Code
Delivery Mechanism: Direct from community
Category:	Power Servicability
Request Type:	Package - New
d. Upstream Acceptance:	Accepted
Sponsor Priority	2
f. Severity: Medium
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	servicelog 0.3

3. Business Case
Servicelog provides a central location to track hardware/firmware failures and repairs.  Other
logging methods (such as syslog) are insufficient because they do not allow for the listing of open
(unrepaired) failures, or for indicating that a failure has been repaired.  It is used to store the
output of certain diagnostics on Power (provided by the ibm-ppc-diag package), and is the basis for
a self-healing strategy for Linux.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Mike Wortman, wortman@us.ibm.com, 512-838-8582

Technical contact(s):
Michael Strosaker, strosake@us.ibm.com

IBM Manager:
Larry Kessler, lkessler@us.ibm.com
Comment 1 Bill Nottingham 2008-10-01 16:56:12 EDT
Pointer to code?
Comment 2 IBM Bug Proxy 2008-10-01 17:32:11 EDT
(In reply to comment #5)
> ------- Comment From notting@redhat.com 2008-10-01 16:56:12 EDT-------
> Pointer to code?

Didn't notice that it was missing!  http://linux-diag.sourceforge.net/servicelog/
Comment 3 Bill Nottingham 2008-10-02 10:12:33 EDT
This request says 'arch specificity: purely common code'. However, from where this is filed, it's implied this is ppc64-specific.

Does this work on other arches? How does it fit into frameworks such as web-based management (openwsman or similar), and other hardware interfaces (such as OpenHPI)?
Comment 4 IBM Bug Proxy 2009-03-03 14:51:46 EST
This is purely common code; the BZ filing as ppc64 is an artifact of this packages lineage.
Comment 5 Roman Rakus 2009-03-11 11:03:29 EDT
libservicelog now in rawhide
Comment 6 Siddharth Nagar 2009-10-23 09:35:57 EDT
Changing component to 'distribution' as this is a new package made available for all platforms.
Comment 7 releng-rhel@redhat.com 2009-10-29 09:44:08 EDT
Fixed in 'libservicelog-1.0.1-3.el6', included in compose 'RHEL6.0-20091028.0'.
Moving to ON_QA.
Comment 8 IBM Bug Proxy 2009-11-16 13:30:47 EST
------- Comment From halves@linux.vnet.ibm.com 2009-11-16 13:26 EDT-------
libservicelog-1.0.1-3.el6.ppc64 found on RHEL6-20091110

Regards,

Higor
Comment 9 Alexander Todorov 2010-04-26 07:19:13 EDT
libservicelog-1.0.1-3.1.el6 found in  RHEL6.0-20100422.12/Server/ppc64. Moving to VERIFIED
Comment 10 Brad Peters 2010-05-10 13:42:56 EDT
This is odd; to me, it appears like the (463284) request was meant to add the servicelog package, but somehow it got garbled and resulted in the addition of only libservicelog.

To clarify, libservicelog and servicelog work together to provide the event storage database, notifications, and repair functions.  Ideally we want both to be present.  

From where things currently stand, it seems we need to rebase libservicelog to 1.1.9, then add servicelog-1.1.7 since, at least as of the RHEL6-snapshot1 (from may 7, ftp3), it is not yet present.
Comment 11 releng-rhel@redhat.com 2010-07-02 14:58:38 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.