Bug 463298 - virbr0 loses it's routing when managed by NetworkManager
virbr0 loses it's routing when managed by NetworkManager
Status: CLOSED DUPLICATE of bug 467687
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-22 16:43 EDT by Dan Yocum
Modified: 2009-02-02 12:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-02 12:58:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
before reconnecting w/ NM (4.95 KB, text/plain)
2009-02-02 12:30 EST, Dan Yocum
no flags Details
after reconnecting w/ NM (4.95 KB, text/plain)
2009-02-02 12:30 EST, Dan Yocum
no flags Details

  None (edit)
Description Dan Yocum 2008-09-22 16:43:32 EDT
Description of problem:

When switching between networks (eth0 -> wlan0, wlan0 -> eth0), virbr0 loses it's routing to the outside 'net.

Version-Release number of selected component (if applicable):

libvirt-0.4.4-2.fc9.x86_64

How reproducible:

Always

Steps to Reproduce:

1. Establish a link using NetworkManager.  
2. Start a VM (I'm using KVM + Qemu).  
3. From the VM ping an IP or hostname on the outside net (ping www.redhat.com).  
4. Restart the NetworkManager connection (left-click on the NM applet and click on the interface that is currently running to re-negotiate with the network).
5. From the VM ping an IP or hostname on the outside net (ping www.redhat.com).
6. Fail!
  
Actual results:

Fail.

Expected results:

ping successful

libvirtd should notice when the machine changes networks and recreate an appropriate routing table.

Additional info:
Comment 1 Mark McLoughlin 2009-01-21 06:11:32 EST
Can't reproduce here

Could you try running these commands before and after you restart the connection:

  $> brctl show
  $> iptables -L -v -n
  $> ps -ef | grep dnsmasq
  $> ifconfig -a
  $> cat /proc/sys/net/ipv4/ip_forward

I suspect it might be related to bug #467687
Comment 2 Dan Yocum 2009-02-02 12:30:00 EST
Created attachment 330653 [details]
before reconnecting w/ NM
Comment 3 Dan Yocum 2009-02-02 12:30:34 EST
Created attachment 330654 [details]
after reconnecting w/ NM
Comment 4 Dan Yocum 2009-02-02 12:32:29 EST
I recently upgraded to F10 and can't reproduce the problem, either.  *shrug*

Take a look at the attached files - I don't see a smoking gun, but it sure sounds like bug #467687 and this are related.

Cheers,
Dan
Comment 5 Mark McLoughlin 2009-02-02 12:58:46 EST
(In reply to comment #4)
> I recently upgraded to F10 and can't reproduce the problem, either.  *shrug*
> 
> Take a look at the attached files

Ah, okay - these log files are from a system that the problem isn't occurring on

> - I don't see a smoking gun, but it sure sounds like bug #467687 and this are 
> related.

Yeah, I think we can be fairly certain that it was the same issue. Marking as duplicate, but do re-open if it comes back and looks different.

*** This bug has been marked as a duplicate of bug 467687 ***

Note You need to log in before you can comment on or make changes to this bug.