Bug 4633 - glibc headers break h2ph which causes infinite loops
glibc headers break h2ph which causes infinite loops
Status: CLOSED DUPLICATE of bug 2297
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
6.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-20 16:51 EDT by Chris Seawood
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-29 22:26:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Seawood 1999-08-20 16:51:17 EDT
This problem has been noted in a couple of other bug reports
but they were for RH5.2 or not specific to this problem.

H2ph cannot handle the way that glibc embeds defines inside
enumerations. This code snippet from <bits/socket.h> shows
the cause of the problem:

enum __socket_type
{
  SOCK_STREAM = 1,              /* Sequenced, reliable,
connection-based
                                   byte streams.  */
#define SOCK_STREAM SOCK_STREAM
  SOCK_DGRAM = 2,               /* Connectionless,
unreliable datagrams
                                   of fixed maximum length.
*/

Somehow, h2ph either misses the SOCK_STREAM = 1 or overrides
it with #define SOCK_STREAM SOCK_STREAM.  This causes the
subsequent bits/socket.ph to have the follow function:

eval 'sub SOCK_STREAM () { &SOCK_STREAM;}' unless
defined(&SOCK_STREAM);

Which is obviously wrong and causes an infinite loop to
occur.  With some programs (aub was the only one I
explicitly tested), this causes perl eat memory and
eventually lock up the machine.

A brief glance at the srpm in rawhide shows that no patch
has been applied to h2ph so it probably won't fix this
problem.
Comment 1 Cristian Gafton 1999-08-29 22:26:59 EDT
*** This bug has been marked as a duplicate of 2297 ***

Note You need to log in before you can comment on or make changes to this bug.