Bug 463306 - RFE: need better worded message for upconverting --nosync mirrors
RFE: need better worded message for upconverting --nosync mirrors
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.3
All Linux
medium Severity low
: rc
: ---
Assigned To: Jonathan Earl Brassow
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-22 17:00 EDT by Corey Marthaler
Modified: 2010-01-11 22:54 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:57:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2008-09-22 17:00:40 EDT
Description of problem:
It took me awhile to figure out that the reason I was seeing the following message when up converting was because I created the mirror with the --nosync option.

[root@taft-03 ~]# lvconvert -m 2 taft/mirror
  Not adding mirror to mirrored LV without initial resync

The above sounds a bit confusing.

Something more like:
"Mirrors created without initial sync require resync before up converting"

If I resync it, then it'll work.

[root@grant-01 ~]# lvchange --resync grant/mirror
Do you really want to deactivate logical volume mirror to resync it? [y/n]: y
[root@grant-01 ~]# lvconvert -m 2 grant/mirror
  grant/mirror: Converted: 100.0%
  Logical volume mirror converted.


Version-Release number of selected component (if applicable):
lvm2-2.02.40-2.el5
Comment 2 Corey Marthaler 2009-07-01 12:40:04 EDT
Fix verified in lvm2-2.02.46-8.el5.

[root@grant-02 ~]# lvconvert -m 2 grant/mirror
  Can't add mirror to out-of-sync mirrored LV: use lvchange --resync first.
Comment 4 errata-xmlrpc 2009-09-02 07:57:00 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1393.html

Note You need to log in before you can comment on or make changes to this bug.