Bug 463310 - [LTC 6.0 FEAT] 201399:Update ibmvscsi driver with upstream fixes and enhancements
[LTC 6.0 FEAT] 201399:Update ibmvscsi driver with upstream fixes and enhancem...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
ppc64 All
medium Severity medium
: alpha
: 6.0
Assigned To: Kevin W Monroe
Martin Jenner
: FutureFeature
Depends On:
Blocks: 356741
  Show dependency treegraph
 
Reported: 2008-09-22 17:10 EDT by IBM Bug Proxy
Modified: 2009-09-23 18:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-23 18:25:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-22 17:10:50 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:27 EDT
1. Feature Overview:
Feature Id:	[201399]
a. Name of Feature:	Update ibmvscsi driver with upstream fixes and enhancements
b. Feature Description
Several enhancements and bugfixes have been added to the upstream ibmvscsi driver. This feature is
to track inclusion of those changes into the distro kernels.

2. Feature Details:
Sponsor:	PPC - P
Architectures:
ppc64

Arch Specificity: Purely Arch Specific Code
Affects Kernel Modules: Yes
Delivery Mechanism: Direct from community
Category:	Power Virtualization
Request Type:	Driver - Feature from Upstream
d. Upstream Acceptance:	Accepted
Sponsor Priority	2
f. Severity: Medium
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	latest vscsi driver available

3. Business Case
We have already had at least one crit sit with a customer where the fix was a fix that had been
upstream for some time, but was not backported to the distro kernels. Reduce future problems like
this and also ensure different distro releases have similar bug fixes and feature sets.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Mike Wortman, wortman@us.ibm.com, 512-838-8582

Technical contact(s):
Brian King, bjking1@us.ibm.com
Santiago Leon, saleon@us.ibm.com

IBM Manager:
Raymond Harney, harney@us.ibm.com
Comment 1 Bill Nottingham 2008-10-02 11:30:27 EDT
Well, RHEL 6 will pull the driver directly from upstream, so there shouldn't be any need to backport anything.

The feature requested has already been accepted into the upstream code base
planned for the next major release of Red Hat Enterprise Linux.

When the next milestone release of Red Hat Enterprise Linux 6 is available,
please verify that the feature requested is present and functioning as
desired.
Comment 2 IBM Bug Proxy 2009-02-27 15:51:02 EST
(In reply to comment #4)
Marking as submitted, code is upstream.  We will check that the code required is present when available.

There are two recent patches that will be confimred, they are:

[SCSI] ibmvscsi: Don't fail EH due to insufficient resources
commit  21465eda9eafa275ed11c27779d90aa95559b6f6

[SCSI] ibmvscsi: Make max_requests module parameter more accurate
commit  4f10aae0d1a285df6b16bf6ca5abd366140fd371
Comment 3 Kevin W Monroe 2009-09-23 18:25:22 EDT
Closing - included in Red Hat Enterprise Linux 6.

Note You need to log in before you can comment on or make changes to this bug.