This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 463371 - [LTC 6.0 FEAT] 201110:Broadcom iSCSI support - bnx2iscsi
[LTC 6.0 FEAT] 201110:Broadcom iSCSI support - bnx2iscsi
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All All
high Severity high
: alpha
: 6.0
Assigned To: Mike Christie
Martin Jenner
: FutureFeature
Depends On:
Blocks: 356741 RHEL6Kernel2.6.27 512364
  Show dependency treegraph
 
Reported: 2008-09-22 23:20 EDT by IBM Bug Proxy
Modified: 2010-05-21 17:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-01 16:26:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-22 23:20:40 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:30 EDT
1. Feature Overview:
Feature Id:	[201110]
a. Name of Feature:	Broadcom iSCSI support - bnx2iscsi
b. Feature Description
Broadcom recently submitted their iSCSI driver for 570x based controllers to the open source
community. Most System x servers have these controllers embedded on system boards. We are requesting
that this driver (bnx2iscsi) be integrated into distro releases. Please see:   
http://marc.info/?l=linux-netdev&m=118619702115855&w=2

2. Feature Details:
Sponsor:	xSeries
Architectures:
x86
x86_64

Arch Specificity: Purely Common Code
Affects Kernel Modules: Yes
Delivery Mechanism: Direct from community
Category:	xSeries
Request Type:	Driver - Feature from Upstream
d. Upstream Acceptance:	Submitted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	no
g. Component Version Target:	2.6.27

3. Business Case
Customers with System x servers containing planar-embedded Broadcom 570X NICs will be able to have
'built-in' iSCSI support.

Benefits
Enable iSCSI support on network interfaces (bcm5706, bcm5708) prevalent on most System x servers.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Monte Knutson, mknutson@us.ibm.com, 877-894-1495

Technical contact(s):
Kevin Stansell, kstansel@us.ibm.com
Chris McDermott, mcdermoc@us.ibm.com
Comment 1 Bill Nottingham 2008-10-02 12:29:27 EDT
This driver does not appear to be upstream as of yet.
Comment 3 Tom Coughlan 2009-10-01 16:26:26 EDT
This is in RHEL 5.4 and 2.6.31, so it will be in RHEL 6. I'll close this, since it is not really a new feature. If 6.0 bugfixes are needed, open a BZ for that.
Comment 4 IBM Bug Proxy 2010-05-21 17:20:49 EDT
------- Comment From coschult@us.ibm.com 2010-05-21 17:18 EDT-------
Verified on snap4. I am able to log into an iscsi target and work with the filesystem.

Note You need to log in before you can comment on or make changes to this bug.