Bug 463405 - Copy a Large amount files :The specified network name is no longer available
Copy a Large amount files :The specified network name is no longer available
Status: CLOSED DUPLICATE of bug 427298
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.1
i386 Windows
medium Severity medium
: rc
: ---
Assigned To: Petr Rockai
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-23 03:10 EDT by zhanglq
Modified: 2010-05-19 10:27 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-19 10:27:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhanglq 2008-09-23 03:10:11 EDT
Description of problem:
samba share based on a lvm2 volume with snapshot.
When Copy a Large amount files from Windows XP(SP2) to RHEL5.1 samba share,after about 10 minutes transfer speed gose to zero,then windows Client said:"Cannot copy <filename>: The specified network name is no longer
available"

Version-Release number of selected component (if applicable):
Any release of samba version V2 and V3.

How reproducible:
Steps to Reproduce:
1.create a lvm2 volume,and format this volume to ext3
2.create one or more snapshot to this volume
3.Use samba share one directory to client
3.use Windows XP or 2K3 Client copy large amount files(maybe 5GB or more) to this samba server.
4.After about 10 minutes transfer speed gose to zero
5.Wait serveral mintues more,then windows Client said:"Cannot copy <filename>: The specified network name is no longer available"
  
Actual results:


Expected results:


Additional info:
1.MY server and client both have  Gigabit Ethernet card
2.We change Linux kernel to 2.6.19,the problem also exist.
3.We change samba to 2.2.12,the problem also exist.
4.It may not be a problem of hardware,bacause we chage hardware and the
problem exist.
Comment 1 Petr Rockai 2009-03-01 04:30:11 EST
This is basically the same as the other full-snapshot-related issues. From your description, I gather that the snapshot becomes full and thus invalid, so automatic extension would solve the problem. I just need one thing before marking this a duplicate of bug 427298: are you writing to the snapshot, or to the origin? Because writing to origin should never fail due to full snapshots and that would be a different bug.
Comment 4 Petr Rockai 2010-05-19 10:27:10 EDT
Let's mark this duplicate, we have a better BZ for the essentially same problem. Zhanglq, please report any additional info you may have in that bugzilla. Thanks.

*** This bug has been marked as a duplicate of bug 427298 ***

Note You need to log in before you can comment on or make changes to this bug.