Bug 463411 - [te_IN] cursoring failed in firefox and rendering failed in konqueror for some GSUB conjunction
[te_IN] cursoring failed in firefox and rendering failed in konqueror for som...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: fonts-indic (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Rahul Bhalerao
QE Internationalization Bugs
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-23 05:15 EDT by Vivian Bian
Modified: 2010-10-18 12:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-19 11:26:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the page displayed in the firefox (48.77 KB, image/png)
2008-09-23 05:57 EDT, Vivian Bian
no flags Details
This is the page displayed in the konqueror (53.07 KB, image/png)
2008-09-23 05:58 EDT, Vivian Bian
no flags Details

  None (edit)
Description Vivian Bian 2008-09-23 05:15:35 EDT
Description of problem:
When     visit     the       URL     http://focus.bne.redhat.com/I18N/IndicTC/lang/te_IN/font/indicFonctTestCaseGSUB-Telugu.html       via     the      firefox      browser,  and  test     the       #285    font     there  were     the     cursoring      error     for    that     I      must     knock   three times     the      left /right      cursor      to     make      the       cursor        move      to         the        left /right          with    the        current     font , and       when          use        the          BackSpace          key       to delete        the        word ,it         could        not            match     the            number         of      the        unicode.More over,we       must       knock     the          Delete       key         three       times    to         delete        the          word.

What's     more  ,in      the        konqueror        browser, the            #285           word           seems           not        the        same           with     the          image.

The     Unicode      of        the        word        is     U+0C37 U+0C4D U+0C1F U+0C4D U+0C30 U+0C40 

Version-Release number of selected component (if applicable):
fonts-telugu-2.3.1-1.el5
firefox-3.0-0.beta5.6.el5
konqueror       in       rhel 5.2  
pango-1.14.9-3.el5


How reproducible:
Always

Steps to Reproduce:
1.visit   the      website     given     above        and      turn     to     the        te_IN        GSUB          #285   ,and    just     knock         the        Backspace           key       according      to the     unicode   (knock   the   Backspace    for     time s     the         same      as     the      number    of     the     unicode   of   the    word) 

2.Knock     the     Delete      key     on   the    word      just    for  once

3.Knock     the   left/right     key    on   the    word      just    for  once
  
Actual results:
The     cursor     can't    move    as  the     requirement   below:
Delete:it          should        delete    the       entire         composed        char      at       a      time
Backspace:need     to          several     times       to        remove the char,  it        depends        on         each   char        unicode
cursor(left,right):   must        not          be           positioned      at        the          middle        of   the      char anyhow,so        cursor       just          for      one         time

Expected results:

All   the        cursor s    can   work      as       the     requirement.
Additional info:
Comment 1 Vivian Bian 2008-09-23 05:57:26 EDT
Created attachment 317455 [details]
This is the page displayed in the firefox
Comment 2 Vivian Bian 2008-09-23 05:58:02 EDT
Created attachment 317457 [details]
This is the page displayed in the konqueror
Comment 3 Rahul Bhalerao 2008-09-23 08:54:19 EDT
I think the correct link to the test cases is,
http://focus.bne.redhat.com/I18N/IndicTC/lang/te_IN/font/IndicFontTestCaseGSUB-Telugu.html
Comment 4 Lawrence Lim 2008-09-24 22:19:35 EDT
This should be rendering problem? If so, the bugs should be submitted against the rendering engine of both browser.
Comment 5 Vivian Bian 2008-09-25 02:56:57 EDT
I've just separated this bug into two different bugs,#463891 and #463892 because they are really two different bugs either in firefox or in konqueror.So just check them.
Comment 6 Lawrence Lim 2008-09-25 03:10:49 EDT
Then what happen to this one?
Comment 7 Rahul Bhalerao 2008-09-25 03:20:05 EDT
This is not really a bug with pango, firefox or konqueror. Its actually a bug in test case data and also a bug in font. The reasoning as follows:

When the character sequence given in the test case (U+0C37 U+0C4D U+0C1F U+0C4D
U+0C30 U+0C40) is typed into gedit or kedit, using either Inscript layout or
raw code, the bug is not reproduced. When verified the sequence that is
actually entered in the test case, it is found that the test case actually has
a wrong sequence entered. 
The sequence of characters present in the test case is (U+0C37 U+0C1F U+0C30
U+0C40), i.e. without U+0C4D as opposed to what it is supposed to be. 

Still the wrong sequence being rendered as a (fake) correct one, is also a bug in
font. But we need to correct the character sequence used in the test case as
well.

I will keep this bug open until the wrong sequence is removed from the font. And close the other two that are reported for this one.
Comment 8 Lawrence Lim 2008-09-25 03:29:07 EDT
Thanks for the analysis Rahul. Will have the Test Case updated.

Note You need to log in before you can comment on or make changes to this bug.