Bug 463433 - Preupgrade hangs downloading installer metadata
Preupgrade hangs downloading installer metadata
Status: CLOSED DUPLICATE of bug 459935
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
9
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-23 09:31 EDT by Halfbin
Modified: 2014-01-21 18:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-29 06:18:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Halfbin 2008-09-23 09:31:41 EDT
Description of problem:

Preupgrade crashes while upgrading to Rawhide from F9 with a traceback and exception, hanging the UI saying "Downloading installer metadata..."

Version-Release number of selected component (if applicable):

0.9.3-3

How reproducible:

Always.

Steps to Reproduce:
1.$ /usr/bin/preupgrade in console
2.Select rawhide, go through the motions
3.Stare exasperated at the traceback
  
Actual results:

[xxxxxxx@xxxxxx ~]$ preupgrade
Loaded plugins: refresh-packagekit
No package matched to remove
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 198, in on_assistant_apply
    self._do_main()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 206, in _do_main
    self.main_preupgrade()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 349, in main_preupgrade
    self.pu.retrieve_treeinfo()
  File "/usr/lib/python2.5/site-packages/preupgrade/__init__.py", line 395, in retrieve_treeinfo
    self.instimage = cp.get('stage2', 'instimage')
  File "/usr/lib64/python2.5/ConfigParser.py", line 520, in get
    raise NoOptionError(option, section)
ConfigParser.NoOptionError: No option 'instimage' in section: 'stage2'

The UI isn't frozen, but stops at "Downloading installer metadata...", with the system tray tooltip reporting 92.5%.

Expected results:

Preupgrade completes, leaving me with a yummy rawhide system
Comment 1 Mark Wielaard 2008-09-28 06:05:55 EDT
Same issue here when upgrading from Fedora 9 to Rawhide with preupgrade 0.9.3-3.fc9. The problem is that http://download.fedora.redhat.com/pub/fedora/linux/development/i386/os/.treeinfo contains only a mainimage option in the [stage2] section, but not an instimage option.
Comment 2 Will Woods 2008-09-29 00:28:26 EDT
Rawhide drops the instimage entry because we no longer produce them. Current preupgrade doesn't use instimage at all, so this isn't a problem.

preupgrade-0.9.8 or higher will fix this problem. Either fetch packages from koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=63559 (you'll also need the anaconda-yum-plugins package from koji)
or wait for it to hit updates-testing.
Comment 3 Will Woods 2008-10-14 12:03:44 EDT

*** This bug has been marked as a duplicate of bug 459935 ***

Note You need to log in before you can comment on or make changes to this bug.