Bug 463461 - RFE: don't scan %{_docdir} for autoprov/req
RFE: don't scan %{_docdir} for autoprov/req
Status: CLOSED DUPLICATE of bug 234691
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-23 11:38 EDT by Chris Weyl
Modified: 2009-07-23 08:14 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-27 07:55:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Weyl 2008-09-23 11:38:08 EDT
%{_docdir} can contain all sorts of data, but according to the packaging guidelines, none of it should cause provides/requires to be added to the package.

This is a RFE, asking for the auto-req and auto-prov scripts to skip scanning %{_docdir}'s content.
Comment 1 Panu Matilainen 2008-09-27 07:55:00 EDT
Basically it's a question of executable vs not executable: if %doc files aren't marked executable, no dependencies are collected from them. If they are packaged as executable, somebody might be actually expecting them to work too so it's reasonable that even %doc dependencies are collected too. It's just that the internal dependency generator has some extra twists as shown in bug 234691.

*** This bug has been marked as a duplicate of bug 234691 ***

Note You need to log in before you can comment on or make changes to this bug.